summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan D. Scott2014-12-30 17:32:35 -0800
committerIan D. Scott2014-12-30 17:32:35 -0800
commitdb875c623d1e0e1b6bae0c57e65346fe058892fb (patch)
treeec078923f4c0eef8ea022c090be6f68cca2f9f9d
downloadaur-db875c623d1e0e1b6bae0c57e65346fe058892fb.tar.gz
Add wikicurses
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..940d3373e54d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wikicurses
+ pkgdesc = A simple curses interface for accessing Wikipedia.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/ids1024/wikicurses
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-urwid
+ depends = python-beautifulsoup4
+ depends = python-lxml
+ backup = etc/wikicurses.conf
+ source = https://github.com/ids1024/wikicurses/archive/v1.0.tar.gz
+ md5sums = SKIP
+
+pkgname = wikicurses
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c089675d0866
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Ian D, Scott <ian@perebruin.com>
+pkgname=wikicurses
+pkgver=1.0
+pkgrel=1
+pkgdesc="A simple curses interface for accessing Wikipedia."
+arch=('any')
+url="https://github.com/ids1024/wikicurses"
+license=('MIT')
+depends=('python' 'python-urwid' 'python-beautifulsoup4' 'python-lxml')
+backup=('etc/wikicurses.conf')
+source=("https://github.com/ids1024/wikicurses/archive/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/wikicurses-git/LICENSE"
+}