summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan D. Scott2014-12-27 16:08:17 -0800
committerIan D. Scott2014-12-27 16:08:17 -0800
commit450c5d4b2fcdc51ea32c5cf4c9ff70574fa7d9bc (patch)
tree545ce92e4d116ec1cdedfd7e456ad385826f20fe
parent9cebb09b90767c441548224702f7f6372a303c5b (diff)
downloadaur-450c5d4b2fcdc51ea32c5cf4c9ff70574fa7d9bc.tar.gz
Wikicurses-git: Install license; add git to makedepends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 451289dabc66..63bd03fb5551 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,8 @@ pkgbase = wikicurses-git
pkgrel = 1
url = https://github.com/ids1024/wikicurses
arch = any
- license = mit
+ license = MIT
+ makedepends = git
depends = python
depends = python-urwid
depends = python-beautifulsoup4
diff --git a/PKGBUILD b/PKGBUILD
index 19d0c3bc501c..7dd3816795ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,8 @@ pkgrel=1
pkgdesc="A simple curses interface for accessing Wikipedia."
arch=('any')
url="https://github.com/ids1024/wikicurses"
-license=('mit')
+license=('MIT')
+makedepends=('git')
depends=('python' 'python-urwid' 'python-beautifulsoup4')
backup=('etc/wikicurses.conf')
source=('git://github.com/ids1024/wikicurses.git')
@@ -20,5 +21,6 @@ pkgver () {
package() {
cd "$srcdir/$_gitname"
python setup.py install --root="$pkgdir"
- install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/wikicurses-git/LICENSE"
}