summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDany Nativel2015-06-10 18:03:44 +0200
committerDany Nativel2015-06-10 18:05:31 +0200
commit22d425d2a7b0a0ac274a9e8b50b47d4229efa4c8 (patch)
tree3ad4bac220f1cfeedb521ee1b59e1b10232d6fd3
downloadaur-22d425d2a7b0a0ac274a9e8b50b47d4229efa4c8.tar.gz
Initial import to AUR4
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD51
-rwxr-xr-xwikidpad3
-rw-r--r--wikidpad.desktop8
-rw-r--r--wikidpad.pngbin0 -> 16166 bytes
6 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b13d14f340f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = wikidpad
+ pkgdesc = wikidPad is a Wiki-like notebook for storing your thoughts, ideas, todo lists, contacts, or anything else you can think of to write down.
+ pkgver = 2.2
+ pkgrel = 1
+ url = http://wikidpad.sourceforge.net/
+ arch = any
+ license = custom
+ makedepends = unzip
+ depends = wxpython
+ depends = python2-pysqlite
+ noextract = WikidPad-2.2-src.zip
+ source = http://downloads.sourceforge.net/wikidpad/WikidPad-2.2-src.zip
+ source = wikidpad
+ source = wikidpad.desktop
+ source = wikidpad.png
+ md5sums = 27590187290b28bdc9b244d01ac9cff8
+ md5sums = 5ac44ec35c09861e631c86596142a47c
+ md5sums = f5b1ea28f93fefdccca204024e1bcfbf
+ md5sums = c44e552a8b856610a3e859d1602d5cf1
+
+pkgname = wikidpad
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..819e2c596d83
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+wikidpad/
+*.tar.gz
+*.tar.xz
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce7b71340ab8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: alphazo <alphazo@gmail.com>
+# Original PKGBUILD from reflexing <reflexing@reflexing.ru>
+pkgname=wikidpad
+pkgver=2.2
+pkgrel=1
+pkgdesc="wikidPad is a Wiki-like notebook for storing your thoughts, ideas, todo lists, contacts, or anything else you can think of to write down."
+arch=('any')
+url="http://wikidpad.sourceforge.net/"
+license=('custom')
+depends=('wxpython' 'python2-pysqlite')
+makedepends=('unzip')
+source=(http://downloads.sourceforge.net/wikidpad/WikidPad-$pkgver-src.zip
+ wikidpad
+ wikidpad.desktop
+ wikidpad.png
+)
+noextract=(WikidPad-$pkgver-src.zip)
+md5sums=('27590187290b28bdc9b244d01ac9cff8'
+ '5ac44ec35c09861e631c86596142a47c'
+ 'f5b1ea28f93fefdccca204024e1bcfbf'
+ 'c44e552a8b856610a3e859d1602d5cf1')
+
+prepare() {
+ cd "$srcdir"
+
+ # proper extract
+ mkdir $pkgname-$pkgver
+ unzip WikidPad-$pkgver-src.zip -d $pkgname-$pkgver
+
+ # Patch for Python2 compatibility
+ cd $pkgname-$pkgver
+ sed -i -e "s|env python|env python2|" *.py
+ sed -i -e "s|/bin/python|/usr/bin/python2|" *.py
+ cd ..
+}
+
+package() {
+ # dirty copying whole Python sources due to the lack of good 'python setup.py install'
+ # functionality (TODO: setup.py fixes to make it crossplatform)
+ mkdir -p $pkgdir/usr/share/$pkgname
+ cp -r $pkgname-$pkgver/* $pkgdir/usr/share/$pkgname
+
+ # install run wrapper
+ install -Dm755 $srcdir/$pkgname $pkgdir/usr/bin/$pkgname
+
+ # install icons
+ install -Dm644 $srcdir/$pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+
+ # install DE menu items
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+} \ No newline at end of file
diff --git a/wikidpad b/wikidpad
new file mode 100755
index 000000000000..db0473df7ac8
--- /dev/null
+++ b/wikidpad
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/wikidpad
+python2 WikidPad.py $*
diff --git a/wikidpad.desktop b/wikidpad.desktop
new file mode 100644
index 000000000000..8f67b7978f7b
--- /dev/null
+++ b/wikidpad.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=wikidPad
+Comment=wikidPad is a Wiki-like notebook for storing your thoughts, ideas, todo lists, contacts, or anything else you can think of to write down.
+Exec=wikidpad
+Icon=wikidpad.png
+Terminal=false
+Type=Application
+Categories=Application;Office
diff --git a/wikidpad.png b/wikidpad.png
new file mode 100644
index 000000000000..16e176a1ffe7
--- /dev/null
+++ b/wikidpad.png
Binary files differ