summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwen Le Bihan2021-04-12 23:23:43 +0200
committerEwen Le Bihan2021-04-12 23:23:43 +0200
commit62296649ab158aee52c7b75996c9970db7d435d3 (patch)
tree4b54ffb8e4ae9f21e2cd7e67bbddab7e3f53b8b2
parent683fb906e1739456e9ebe4e7ae00d2925e4f4a70 (diff)
downloadaur-62296649ab158aee52c7b75996c9970db7d435d3.tar.gz
fix package()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 3 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7247170cbe62..34b9fb0f65d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wikitrad
pkgdesc = A CLI to translate terms with wikipedia
pkgver = 0.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ewen-lbh/wikitrad
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index f8720b9e6a08..be6ba59061a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,13 @@
# Maintainer: Ewen Le Bihan <hey@ewen.works>
pkgname=wikitrad
pkgver=0.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="A CLI to translate terms with wikipedia"
arch=(any)
url="https://github.com/ewen-lbh/wikitrad"
license=("GPL")
makedepends=("python" "python-pip")
conflicts=("wikitrad-git")
-build() {
- pip install --no-deps --target="wikitrad" wikitrad==$pkgver
-}
package() {
- sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
- mkdir -p "$pkgdir"/"$sitepackages"
- cp -r "$srcdir"/wikitrad/* "$pkgdir"/"$sitepackages"
+ pip install wikitrad==$pkgver --root="$pkgdir" --prefix=/usr
}