summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-01-10 10:32:36 +0330
committerMohammadreza Abdollahzadeh2022-01-10 10:32:36 +0330
commitad269b983315ec3242eb06fc1d712f63b4d58cd2 (patch)
tree331168134fe555083ce1a4c41198dc8cd8d02b68
parentcf0a1f7b60026a11d373cda4286b87200065b735 (diff)
downloadaur-ad269b983315ec3242eb06fc1d712f63b4d58cd2.tar.gz
fix install file
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
-rw-r--r--wildfly.install27
3 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90f36399d1b7..cac9f495aadb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = wildfly
optdepends = libaio: ActiveMQ Artemis
optdepends = lib32-glibc: native OpenSSL support
conflicts = wildfly-devel
+ options = !strip
backup = opt/wildfly/domain/configuration/application-roles.properties
backup = opt/wildfly/domain/configuration/application-users.properties
backup = opt/wildfly/domain/configuration/logging.properties
diff --git a/PKGBUILD b/PKGBUILD
index cf3e8244f17c..133d288a1132 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,13 @@ pkgname=wildfly
pkgver=26.0.0
pkgrel=1
pkgdesc='Wildfly Application Server.'
-arch=('any')
url='http://www.wildfly.org/'
license=('LGPL')
+arch=('any')
depends=('java-runtime>=8')
optdepends=('libaio: ActiveMQ Artemis'
'lib32-glibc: native OpenSSL support')
conflicts=("${pkgname}-devel")
-
_pkgloc=opt
_cfgloc=etc
_sysdloc=usr/lib/systemd/system
@@ -37,13 +36,11 @@ backup=("${_pkgloc}/${pkgname}/domain/configuration/application-roles.properties
"${_pkgloc}/${pkgname}/bin/jboss-cli.xml"
"${_pkgloc}/${pkgname}/bin/standalone.conf"
"${_cfgloc}/${pkgname}/${pkgname}.conf")
-
+options=(!strip)
install="${pkgname}.install"
-
source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}.Final/${pkgname}-${pkgver}.Final.tar.gz"
"${pkgname}-sysusers.conf"
"${pkgname}-tmpfiles.conf")
-
sha256sums=('f6ff4dcd5312f83e37b663e2e16ce6474f09324c11dc1712b79320aabfcd096f'
'd2c43e331a76c363a621db3bff3db93889388fd656bf786e1dc7c2a8283046ac'
'796faf23aba8acacd40701dae855e66990ac3c62e71903095200023adb6e8540')
diff --git a/wildfly.install b/wildfly.install
index 7be928b74181..dc76a746f867 100644
--- a/wildfly.install
+++ b/wildfly.install
@@ -1,10 +1,27 @@
post_install() {
- echo " Wildfly is installed as a systemd service."
- echo " You should run the add-user script (/opt/wildfly/bin/add-user.sh) in order to add a management user"
- echo " if you want to access the management console, which listens locally on port 9990."
- echo " The main server listens on all networks at port 8080."
+ echo " -> Wildfly is installed as a systemd service."
+ echo " -> You should run the add-user script (/opt/wildfly/bin/add-user.sh) in order to add a management user"
+ echo " -> if you want to access the management console, which listens locally on port 9990."
+ echo " -> The main server listens on all networks at port 8080."
+}
+
+pre_upgrade() {
+ echo " -> Stoping wildfly.service ..."
+ systemctl stop wildfly.service
+ wait
}
post_upgrade() {
- post_install "$1"
+ echo " -> Updating installation directory permissions ..."
+ chmod -R u=rwX,g=rwX,o=rX opt/wildfly
+ post_install "$1"
}
+
+pre_remove() {
+ echo " -> Stoping wildfly.service ..."
+ systemctl stop wildfly.service
+ wait
+ echo " -> Disabling wildfly.service ..."
+ systemctl disable wildfly.service
+}
+