summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpike292015-12-03 18:37:29 +0100
committerSpike292015-12-03 18:37:29 +0100
commit379158669cc88e722b3aaafd50b18bf53f2f4a00 (patch)
treec5d771b16bc5aa9c71ecd2a4f08f65183a89120f
parentab632cd30955e31a3e78bfea37a5feec3e3e67cc (diff)
downloadaur-379158669cc88e722b3aaafd50b18bf53f2f4a00.tar.gz
Upstream release 2.4.906
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD33
-rw-r--r--link-X11.patch11
3 files changed, 19 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8a9cafbb473..0ec61df7286b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = wilink
pkgdesc = Instant messaging client and SIP softphone for Wifirst customers
- pkgver = 2.4.2
- pkgrel = 4
+ pkgver = 2.4.906
+ pkgrel = 1
url = https://github.com/jlaine/wilink
install = wilink.install
arch = i686
arch = x86_64
license = GPL3
- makedepends = cmake>=2.8.2
- depends = libmad
- depends = libvorbis
depends = libxss
depends = qxmpp
- depends = qdjango
- depends = libnotify
- depends = libgnome-keyring
- depends = libgphoto2
- source = https://download.wifirst.net/public/wiLink-2.4.2.tar.bz2
- source = link-X11.patch
- sha1sums = a4c826c0a70c3ca0dcd953a2474f0ea576d0f9b1
- sha1sums = 42b07fdca0a26fe4e2c34c53b50158c60536266e
+ depends = qt5-multimedia
+ depends = qt5-x11extras
+ depends = qt5-quickcontrols
+ depends = qt5-webkit
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ source = https://github.com/jlaine/wilink/archive/v2.4.906.tar.gz
+ sha1sums = 60f912e2ae958e6b7e809a57e08d4a3a57d36ed6
pkgname = wilink
diff --git a/PKGBUILD b/PKGBUILD
index 01efc5cedc91..2550c5d96974 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,27 @@
# Maintainer: Spike29 <leguen.yannick@gmail.com>
# Contributor: SpepS <dreamspepser at yahoo dot it>
-_pkg='wiLink'
pkgname='wilink'
-pkgver='2.4.2'
-pkgrel='4'
+pkgver='2.4.906'
+pkgrel='1'
pkgdesc='Instant messaging client and SIP softphone for Wifirst customers'
arch=('i686' 'x86_64')
url='https://github.com/jlaine/wilink'
license=('GPL3')
-depends=('libmad' 'libvorbis' 'libxss' 'qxmpp' 'qdjango' 'libnotify' 'libgnome-keyring' 'libgphoto2')
-makedepends=('cmake>=2.8.2')
+depends=('libxss' 'qxmpp' 'qt5-multimedia' 'qt5-x11extras' 'qt5-quickcontrols' 'qt5-webkit' 'desktop-file-utils' 'hicolor-icon-theme')
install="$pkgname.install"
-source=("https://download.wifirst.net/public/${_pkg}-${pkgver}.tar.bz2"
- "link-X11.patch")
-sha1sums=('a4c826c0a70c3ca0dcd953a2474f0ea576d0f9b1'
- '42b07fdca0a26fe4e2c34c53b50158c60536266e')
+source=("https://github.com/jlaine/${pkgname}/archive/v${pkgver}.tar.gz")
+sha1sums=('60f912e2ae958e6b7e809a57e08d4a3a57d36ed6')
build() {
- cd "$scrdir"
-
- # patching src/app/CMakeLists to solve an issue with an unlinked X11 library
- patch -p0 -i link-X11.patch
-
- # building
- cd "$_pkg-$pkgver/"
+ cd "$srcdir/$pkgname-$pkgver/"
[ -d build ] || mkdir build && cd "build/"
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ qmake-qt5 PREFIX=/usr WILINK_SYSTEM_QXMPP=1 ..
make
}
package() {
# installing
- cd "$srcdir/$_pkg-$pkgver/build/"
- make DESTDIR="$pkgdir/" install
-
- # setting up higher resolution icon
- rm "$pkgdir/usr/share/pixmaps/$_pkg.xpm"
- install -Dm644 ../src/data/images/128x128/$_pkg.png \
- "$pkgdir/usr/share/pixmaps/$_pkg.png"
+ cd "$srcdir/$pkgname-$pkgver/build/"
+ make INSTALL_ROOT="$pkgdir/" install
}
diff --git a/link-X11.patch b/link-X11.patch
deleted file mode 100644
index 32ba00d0f34f..000000000000
--- a/link-X11.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- wiLink-2.4.2/src/app/CMakeLists.txt.orig 2013-03-12 09:55:15.000000000 +0100
-+++ wiLink-2.4.2/src/app/CMakeLists.txt 2013-06-26 15:27:29.000000000 +0200
-@@ -19,6 +19,8 @@
- if(APPLE)
- list(APPEND app_SOURCES application_mac.mm)
- list(APPEND app_LIBRARIES "-framework AppKit")
-+elseif(UNIX)
-+ list(APPEND app_LIBRARIES X11)
- endif()
-
- qt4_wrap_cpp(app_MOC_SOURCES ${app_MOC_HEADERS})