summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYannick Le Guen2015-06-12 18:01:51 +0200
committerYannick Le Guen2015-06-12 18:01:51 +0200
commitab632cd30955e31a3e78bfea37a5feec3e3e67cc (patch)
treeb6f7338447a17d5405338eca54a6712af1c655d3
downloadaur-ab632cd30955e31a3e78bfea37a5feec3e3e67cc.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
-rw-r--r--link-X11.patch11
-rw-r--r--wilink.install12
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8a9cafbb473
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = wilink
+ pkgdesc = Instant messaging client and SIP softphone for Wifirst customers
+ pkgver = 2.4.2
+ pkgrel = 4
+ url = https://github.com/jlaine/wilink
+ install = wilink.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake>=2.8.2
+ depends = libmad
+ depends = libvorbis
+ depends = libxss
+ depends = qxmpp
+ depends = qdjango
+ depends = libnotify
+ depends = libgnome-keyring
+ depends = libgphoto2
+ source = https://download.wifirst.net/public/wiLink-2.4.2.tar.bz2
+ source = link-X11.patch
+ sha1sums = a4c826c0a70c3ca0dcd953a2474f0ea576d0f9b1
+ sha1sums = 42b07fdca0a26fe4e2c34c53b50158c60536266e
+
+pkgname = wilink
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01efc5cedc91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Spike29 <leguen.yannick@gmail.com>
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+
+_pkg='wiLink'
+pkgname='wilink'
+pkgver='2.4.2'
+pkgrel='4'
+pkgdesc='Instant messaging client and SIP softphone for Wifirst customers'
+arch=('i686' 'x86_64')
+url='https://github.com/jlaine/wilink'
+license=('GPL3')
+depends=('libmad' 'libvorbis' 'libxss' 'qxmpp' 'qdjango' 'libnotify' 'libgnome-keyring' 'libgphoto2')
+makedepends=('cmake>=2.8.2')
+install="$pkgname.install"
+source=("https://download.wifirst.net/public/${_pkg}-${pkgver}.tar.bz2"
+ "link-X11.patch")
+sha1sums=('a4c826c0a70c3ca0dcd953a2474f0ea576d0f9b1'
+ '42b07fdca0a26fe4e2c34c53b50158c60536266e')
+
+build() {
+ cd "$scrdir"
+
+ # patching src/app/CMakeLists to solve an issue with an unlinked X11 library
+ patch -p0 -i link-X11.patch
+
+ # building
+ cd "$_pkg-$pkgver/"
+ [ -d build ] || mkdir build && cd "build/"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ # installing
+ cd "$srcdir/$_pkg-$pkgver/build/"
+ make DESTDIR="$pkgdir/" install
+
+ # setting up higher resolution icon
+ rm "$pkgdir/usr/share/pixmaps/$_pkg.xpm"
+ install -Dm644 ../src/data/images/128x128/$_pkg.png \
+ "$pkgdir/usr/share/pixmaps/$_pkg.png"
+}
diff --git a/link-X11.patch b/link-X11.patch
new file mode 100644
index 000000000000..32ba00d0f34f
--- /dev/null
+++ b/link-X11.patch
@@ -0,0 +1,11 @@
+--- wiLink-2.4.2/src/app/CMakeLists.txt.orig 2013-03-12 09:55:15.000000000 +0100
++++ wiLink-2.4.2/src/app/CMakeLists.txt 2013-06-26 15:27:29.000000000 +0200
+@@ -19,6 +19,8 @@
+ if(APPLE)
+ list(APPEND app_SOURCES application_mac.mm)
+ list(APPEND app_LIBRARIES "-framework AppKit")
++elseif(UNIX)
++ list(APPEND app_LIBRARIES X11)
+ endif()
+
+ qt4_wrap_cpp(app_MOC_SOURCES ${app_MOC_HEADERS})
diff --git a/wilink.install b/wilink.install
new file mode 100644
index 000000000000..bce670aff4af
--- /dev/null
+++ b/wilink.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}