summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralive4ever2018-12-17 01:08:45 +0000
committeralive4ever2018-12-17 01:08:45 +0000
commit105bead5a1713c3d18aa72bf5ac8646f16bd2a3f (patch)
treea90f995d1ae5b657e266b2fc97a87a1cb33ead3a
parenteab2b257ade8d2f692e378b5ef1893faaf67422f (diff)
downloadaur-105bead5a1713c3d18aa72bf5ac8646f16bd2a3f.tar.gz
Fix package build
wimboot needs gcab and doesn't depend on lcab anymore. Also add a patch to recognize R_X86_64_PLT32 relocation in addition to R_X86_64_PC32.
-rw-r--r--.SRCINFO8
-rw-r--r--01-efireloc.diff14
-rw-r--r--PKGBUILD12
-rw-r--r--wimboot-git.install2
4 files changed, 28 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ce60509e20c..92657ac4c7d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wimboot-git
pkgdesc = iPXE kernel to boot wim images from network for both UEFI and BIOS system
- pkgver = v2.5.2.r0.901fe95
+ pkgver = v2.6.0.r2.55cfe8a
pkgrel = 1
url = https://git.ipxe.org/wimboot.git
install = wimboot-git.install
@@ -8,11 +8,13 @@ pkgbase = wimboot-git
license = GPL
makedepends = git
makedepends = pesign
- makedepends = lcab
+ makedepends = gcab
optdepends = ipxe-git: iPXE network boot program
optdepends = ipxe-netboot: Alternative iPXE network boot program, with Archlinux network install support
source = wimboot::git+https://git.ipxe.org/wimboot.git
- md5sums = SKIP
+ source = 01-efireloc.diff
+ sha256sums = SKIP
+ sha256sums = 6f8184d75ff2c30a19f9192a8d6f159a390a677e6fd110fd4aea79ac14e9f31d
pkgname = wimboot-git
diff --git a/01-efireloc.diff b/01-efireloc.diff
new file mode 100644
index 000000000000..bf51cda2af97
--- /dev/null
+++ b/01-efireloc.diff
@@ -0,0 +1,14 @@
+diff --git a/src/efireloc.c b/src/efireloc.c
+index 519dd75..e0736cd 100644
+--- a/src/efireloc.c
++++ b/src/efireloc.c
+@@ -326,7 +326,8 @@ static void process_reloc ( bfd *bfd __unused, asection *section, arelent *rel,
+ /* Generate a 2-byte PE relocation */
+ generate_pe_reloc ( pe_reltab, offset, 2 );
+ } else if ( ( strcmp ( howto->name, "R_386_PC32" ) == 0 ) ||
+- ( strcmp ( howto->name, "R_X86_64_PC32" ) == 0 ) ) {
++ ( strcmp ( howto->name, "R_X86_64_PC32" ) == 0 ) ||
++ ( strcmp ( howto->name, "R_X86_64_PLT32" ) == 0 ) ) {
+ /* Skip PC-relative relocations; all relative offsets
+ * remain unaltered when the object is loaded.
+ */
diff --git a/PKGBUILD b/PKGBUILD
index cb5961152e27..17b33f0fb6f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Alif <alive4ever at live.com>
pkgname=wimboot-git
-pkgver=v2.5.2.r0.901fe95
+pkgver=v2.6.0.r2.55cfe8a
pkgrel=1
pkgdesc="iPXE kernel to boot wim images from network for both UEFI and BIOS system"
arch=(any)
url="https://git.ipxe.org/wimboot.git"
license=('GPL')
-makedepends=('git' 'pesign' 'lcab')
+makedepends=('git' 'pesign' 'gcab')
optdepends=("ipxe-git: iPXE network boot program"
"ipxe-netboot: Alternative iPXE network boot program, with Archlinux network install support")
install=$pkgname.install
-source=('wimboot::git+https://git.ipxe.org/wimboot.git')
-md5sums=('SKIP')
+source=('wimboot::git+https://git.ipxe.org/wimboot.git'
+ '01-efireloc.diff')
+sha256sums=('SKIP'
+ '6f8184d75ff2c30a19f9192a8d6f159a390a677e6fd110fd4aea79ac14e9f31d')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -19,6 +21,8 @@ pkgver() {
}
build() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 < "$srcdir/01-efireloc.diff"
cd "$srcdir/${pkgname%-git}/src"
make
}
diff --git a/wimboot-git.install b/wimboot-git.install
index be7b379333ec..0db714ca287a 100644
--- a/wimboot-git.install
+++ b/wimboot-git.install
@@ -7,7 +7,7 @@ bootmgr.efi, boot/bcd, and boot/boot.sdi) on
memory.
For more information, visit
-http://ipxe.org/wimboot
+https://ipxe.org/wimboot
EOF
}