summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhayao2020-03-16 12:28:17 +0900
committerhayao2020-03-16 12:28:17 +0900
commit41290f1c8bdadbc20cb0f6d9c598a0e61df36319 (patch)
treec110e66b60048741df7044a36b946ba85e7ae2b9
downloadaur-41290f1c8bdadbc20cb0f6d9c598a0e61df36319.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63d9aa247063
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = win10x-icon-theme-git
+ pkgdesc = A colorful Design icon theme for linux desktops
+ pkgver = r2.e79f634
+ pkgrel = 1
+ url = https://github.com/yeyushengfan258/Win10x-icon-theme
+ arch = any
+ license = GPL
+ depends = gtk-update-icon-cache
+ conflicts = win10x-icon-theme
+ source = git+https://github.com/yeyushengfan258/Win10x-icon-theme.git
+ md5sums = SKIP
+
+pkgname = win10x-icon-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8391daa03cfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yamada Hayao <shun819.mail@gmail.com>
+
+pkgname=win10x-icon-theme-git
+_pkgname=win10x-icon-theme
+_gitname=Win10x-icon-theme
+pkgver=r2.e79f634
+pkgrel=1
+pkgdesc="A colorful Design icon theme for linux desktops"
+arch=('any')
+url='https://github.com/yeyushengfan258/Win10x-icon-theme'
+license=('GPL')
+depends=('gtk-update-icon-cache')
+optdepends=()
+source=("git+${url}.git")
+md5sums=('SKIP')
+conflicts=('win10x-icon-theme')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}"
+ cp -r * "${pkgdir}"
+ cd "${pkgdir}"
+ mkdir -p "${pkgdir}/usr/share/icons"
+ ${_gitname}/install.sh -d "${pkgdir}/usr/share/icons"
+ rm -rf "${pkgdir}/${_gitname}"
+}