summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornycex2020-07-17 19:16:42 +0200
committernycex2020-07-17 19:16:42 +0200
commit6e6c2a20c37917344de16a2099a2267de7f3859c (patch)
tree361a5b977edb42d1cb8ff422c5a05ac68114a57d
parent01d792c5b539ca66cde54e4e5f8afcdd52ecf11c (diff)
downloadaur-6e6c2a20c37917344de16a2099a2267de7f3859c.tar.gz
apply font fix
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
-rw-r--r--winbox5
3 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 284c2afe24de..e3bbf3b83184 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = winbox-xdg
arch = x86_64
license = custom
depends = wine
+ depends = ttf-tahoma
optdepends = ttf-ms-fonts: for better fonts
conflicts = winbox
source = winbox-3.24.exe::https://download.mikrotik.com/winbox/3.24/winbox64.exe
diff --git a/PKGBUILD b/PKGBUILD
index a7b34af83c61..b5b316392275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgdesc="Mikrotik RouterOS GUI Configurator (wine). xdg base directory specifica
url="http://www.mikrotik.com"
arch=('x86_64')
license=('custom')
-depends=('wine')
+depends=('wine' 'ttf-tahoma')
conflicts=('winbox')
optdepends=(
'ttf-ms-fonts: for better fonts'
diff --git a/winbox b/winbox
index 90daf7e01b3e..0b80c3704d19 100644
--- a/winbox
+++ b/winbox
@@ -2,10 +2,11 @@
export WINEPREFIX="${WINBOX_HOME:-"${XDG_DATA_HOME:-"${HOME}/.local/share"}/winbox"}/wine"
export WINEARCH=win64
-export WINEDLLOVERRIDES="mscoree=" # disable mono
+export WINEDLLOVERRIDES="mscoree,mshtml=" # disable mono
export WINEDEBUG=-all
if [ ! -d "${WINEPREFIX}" ] ; then
- mkdir -p "${WINEPREFIX}"
+ mkdir -p "${WINEPREFIX}/drive_c/windows/Fonts/"
+ cp /usr/share/fonts/TTF/tahoma.ttf /usr/share/fonts/TTF/tahomabd.ttf "${WINEPREFIX}/drive_c/windows/Fonts/"
wineboot -u
fi