summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2014-05-08 17:30:36 -0600
committerBrian Bidulock2015-06-10 22:25:15 -0600
commit35a9aac4148567b5e64fd329f9b773e9a91adfaa (patch)
tree93f54f12cc2e1f4fd94b5398605453e588dd5807
parent851accad9f9d8da5a9b0838abb365b32e20ecef7 (diff)
downloadaur-35a9aac4148567b5e64fd329f9b773e9a91adfaa.tar.gz
version 0.95.5.r269.gdf22014-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0e31f64858a..1a2a4ca05943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = windowmaker-crm-git
pkgdesc = An X11 window manager with a NEXTSTEP look and feel
- pkgver = 0.95.5.263
+ pkgver = 0.95.5.r269.gdf22014
pkgrel = 1
url = http://www.windowmaker.org
arch = i686
@@ -16,11 +16,13 @@ pkgbase = windowmaker-crm-git
depends = libtiff>=3.9.1
depends = giflib
depends = libxmu
+ depends = imagemagick
+ depends = libwebp
provides = windowmaker
conflicts = windowmaker
conflicts = windowmaker-git
options = !libtool
- source = git://repo.or.cz/wmaker-crm.git#branch=next
+ source = windowmaker-crm-git::git://repo.or.cz/wmaker-crm.git#branch=next
source = wmaker.desktop
md5sums = SKIP
md5sums = 2fba97bebfd691836b92b8f0db79ff13
diff --git a/PKGBUILD b/PKGBUILD
index 7e5a31457643..a316297dca8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,47 +2,46 @@
# Contributor: Daniel Isenmann <daniel@archlinux.org>
pkgname=windowmaker-crm-git
-pkgver=0.95.5.263
+pkgver=0.95.5.r269.gdf22014
pkgrel=1
pkgdesc="An X11 window manager with a NEXTSTEP look and feel"
arch=(i686 x86_64)
url="http://www.windowmaker.org"
license=('GPL' 'custom')
-depends=('libxinerama' 'libxrandr' 'libbsd' 'libxpm' 'libxft' 'libtiff>=3.9.1' 'giflib' 'libxmu')
+depends=('libxinerama' 'libxrandr' 'libbsd' 'libxpm' 'libxft' 'libtiff>=3.9.1' 'giflib' 'libxmu' 'imagemagick' 'libwebp')
makedepends=('git')
options=('!libtool')
provides=('windowmaker')
conflicts=('windowmaker' 'windowmaker-git')
-source=("git://repo.or.cz/wmaker-crm.git#branch=next"
+source=("$pkgname::git://repo.or.cz/wmaker-crm.git#branch=next"
"wmaker.desktop")
md5sums=('SKIP'
'2fba97bebfd691836b92b8f0db79ff13')
-_gitname="wmaker-crm"
-
pkgver() {
- cd $_gitname
- git describe --always | sed 's|wmaker.||;s|-|.|g;s|[.]g[a-f0-9]*$||'
+ cd $pkgname
+ git describe --long | sed -r 's/wmaker.//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
- cd $_gitname
+ cd $pkgname
sed -e 's/^RLoadWEBP.*/RLoadWEBP(const char *file_name, int index)/' \
-i wrlib/load_webp.c
+ [ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'|tr '\n' ' '`"
+ ./autogen.sh
}
build() {
- cd "$srcdir/$_gitname"
- [ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
- ./autogen.sh
+ cd $pkgname
+ [ -z "$LINGUAS" ] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'|tr '\n' ' '`"
./configure --prefix=/usr --sysconfdir=/etc --enable-xinerama \
--with-nlsdir=/usr/share/locale --with-gnustepdir=/usr/lib/GNUstep \
--enable-usermenu --enable-modelock --enable-xrandr
- make
+ make V=0
}
package() {
- cd "$srcdir/$_gitname"
+ cd $pkgname
make DESTDIR="$pkgdir" install
install -D -m644 COPYING.WTFPL "$pkgdir/usr/share/licenses/$pkgname/COPYING.WTFPL"