summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormain()2017-05-18 15:39:29 +0200
committermain()2017-05-18 15:39:29 +0200
commitc16f8987d6d3d9331921037611904457684f372c (patch)
tree14fb0cff1173d73a27d9a1d691b83daf94cc6b1c
parenta6eb4764c46d4356c4f772a8db07ac27564d1dbb (diff)
downloadaur-c16f8987d6d3d9331921037611904457684f372c.tar.gz
Use Makefile
Probably never have to update this again I guess?
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD47
2 files changed, 9 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e59d5037ebe3..8440428761c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = windows-gaming-git
pkgdesc = Windows gaming utils
- pkgver = r18.85b1ac4
+ pkgver = r40.6b86b19
pkgrel = 1
install = windows-gaming.install
arch = x86_64
@@ -18,8 +18,9 @@ pkgbase = windows-gaming-git
depends = acl
depends = udev
depends = coreutils
- depends = pciutils
- optdepends = samba: shared folder support
+ depends = hwids
+ optdepends = samba: shared folder
+ optdepends = qemu: windowed setup
provides = windows-gaming
conflicts = windows-gaming
source = git+https://github.com/main--/windows-gaming.git
diff --git a/PKGBUILD b/PKGBUILD
index d9fd02d1e713..1d33f7bd2d45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=windows-gaming-git # '-bzr', '-git', '-hg' or '-svn'
-pkgver=r18.85b1ac4
+pkgver=r40.6b86b19
pkgrel=1
pkgdesc="Windows gaming utils"
arch=('x86_64')
url=""
license=('GPL')
groups=()
-depends=('qemu-headless' 'sudo' 'libsystemd' 'acl' 'udev' 'coreutils' 'pciutils')
-optdepends=('samba: shared folder support')
+depends=('qemu-headless' 'sudo' 'libsystemd' 'acl' 'udev' 'coreutils' 'hwids')
+optdepends=('samba: shared folder' 'qemu: windowed setup')
makedepends=('git' 'rpmextract' 'curl' 'libarchive' 'cargo' 'mono' 'cdrkit') # 'bzr', 'git', 'mercurial' or 'subversion'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -19,18 +19,10 @@ source=('git+https://github.com/main--/windows-gaming.git' 'https://fedorapeople
noextract=()
md5sums=('SKIP' '954ca57735102d16e87a7c4caa979f67')
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
pkgver() {
cd "$srcdir/${pkgname%-git}"
-# The examples below are not absolute and need to be adapted to each repo. The
-# primary goal is to generate version numbers that will increase according to
-# pacman's version comparisons with later commits to the repo. The format
-# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
-# are not available, is recommended.
-
# Git, tags available
# printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
@@ -44,39 +36,10 @@ prepare() {
build() {
cd "$srcdir/${pkgname%-git}"
-
- cd windows-gaming-driver
- cargo build --release
- cd ..
-
- cd guest-agent
- xbuild /p:Configuration=Release VfioService/VfioService.sln
- cp VfioService/VfioService/bin/Release/VfioService.exe .
- mkisofs -m VfioService -o windows-gaming-ga.iso -r -J -input-charset iso8859-1 -V "windows-gaming-ga" .
- cd ..
-
- # grab ovmf
- curl -o ovmf.rpm "https://www.kraxel.org/repos/jenkins/edk2/$(curl -s 'https://www.kraxel.org/repos/jenkins/edk2/' | grep -Eo 'edk2.git-ovmf-x64-[-\.a-z0-9]+\.noarch\.rpm' | head -n1)"
- rpm2cpio ovmf.rpm | bsdtar -xvf - --strip-components 4 './usr/share/edk2.git/ovmf-x64/OVMF_CODE-pure-efi.fd' './usr/share/edk2.git/ovmf-x64/OVMF_VARS-pure-efi.fd'
-}
-
-check() {
- cd "$srcdir/${pkgname%-git}"
+ make
}
package() {
cd "$srcdir/${pkgname%-git}"
-
- install -D windows-gaming-driver/target/release/windows-gaming-driver $pkgdir/usr/bin/windows-gaming-driver
- install -D -m644 ovmf-x64/OVMF_CODE-pure-efi.fd $pkgdir/usr/lib/windows-gaming/ovmf-code.fd
- install -D -m644 ovmf-x64/OVMF_VARS-pure-efi.fd $pkgdir/usr/lib/windows-gaming/ovmf-vars.fd
- install -D -m644 guest-agent/windows-gaming-ga.iso $pkgdir/usr/lib/windows-gaming/windows-gaming-ga.iso
- install -D -m644 ../virtio-win_amd64.vfd $pkgdir/usr/lib/windows-gaming/virtio-win.vfd
- install -D -m644 misc/windows.service $pkgdir/usr/lib/systemd/system/windows.service
- install -D -m644 misc/windows.service $pkgdir/usr/lib/systemd/user/windows.service
- install -D -m644 misc/80-vfio.rules $pkgdir/usr/lib/udev/rules.d/80-vfio.rules
+ make DESTDIR="$pkgdir/" install
}
-
-
-
-# JUCK FARO