summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormain()2016-12-16 09:35:12 +0100
committermain()2016-12-16 09:35:12 +0100
commitea43c90fe22727f7b0cebba1000beb3a9ebb703b (patch)
tree9f57c436baaa37e81d12bc01a225897b09edbf70
parent3037fd5413b6d5343e2a7687018067cd27d3913f (diff)
downloadaur-ea43c90fe22727f7b0cebba1000beb3a9ebb703b.tar.gz
Update to r14
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20ef707765e9..301064e93e4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = windows-gaming-git
pkgdesc = Windows gaming utils
- pkgver = r12.60739a8
+ pkgver = r14.f457273
pkgrel = 1
arch = x86_64
license = GPL
@@ -14,10 +14,13 @@ pkgbase = windows-gaming-git
depends = qemu-headless
depends = sudo
depends = libsystemd
+ depends = acl
+ depends = udev
+ depends = coreutils
+ depends = pciutils
optdepends = samba: shared folder support
provides = windows-gaming
conflicts = windows-gaming
- backup = etc/windows-gaming-driver.toml
source = git+https://github.com/main--/windows-gaming.git
source = https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/archive-virtio/virtio-win-0.1.126-2/virtio-win_amd64.vfd
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 97fefc09ecf6..a706d0c7ec12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,20 +8,20 @@
# Maintainer: Your Name <youremail@domain.com>
pkgname=windows-gaming-git # '-bzr', '-git', '-hg' or '-svn'
-pkgver=r12.60739a8
+pkgver=r14.f457273
pkgrel=1
pkgdesc="Windows gaming utils"
arch=('x86_64')
url=""
license=('GPL')
groups=()
-depends=('qemu-headless' 'sudo' 'libsystemd')
+depends=('qemu-headless' 'sudo' 'libsystemd' 'acl' 'udev' 'coreutils' 'pciutils')
optdepends=('samba: shared folder support')
makedepends=('git' 'rpmextract' 'curl' 'libarchive' 'cargo' 'mono' 'cdrkit') # 'bzr', 'git', 'mercurial' or 'subversion'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
-backup=('etc/windows-gaming-driver.toml')
+backup=()
options=()
install=
source=('git+https://github.com/main--/windows-gaming.git' 'https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/archive-virtio/virtio-win-0.1.126-2/virtio-win_amd64.vfd')
@@ -76,11 +76,12 @@ check() {
package() {
cd "$srcdir/${pkgname%-git}"
- install -D windows-gaming-driver/target/release/windows-gaming-driver $pkgdir/usr/lib/windows-gaming/windows-gaming-driver
- cp ovmf-x64/OVMF_CODE-pure-efi.fd $pkgdir/usr/lib/windows-gaming/ovmf-code.fd
- cp ovmf-x64/OVMF_VARS-pure-efi.fd $pkgdir/usr/lib/windows-gaming/ovmf-vars.fd
- cp guest-agent/windows-gaming-ga.iso $pkgdir/usr/lib/windows-gaming/
- cp ../virtio-win_amd64.vfd $pkgdir/usr/lib/windows-gaming/virtio-win.vfd
- install -D -m644 config-sample.toml $pkgdir/etc/windows-gaming-driver.toml
- install -D -m644 windows.service $pkgdir/usr/lib/systemd/system/windows.service
+ install -D windows-gaming-driver/target/release/windows-gaming-driver $pkgdir/usr/sbin/windows-gaming-driver
+ install -D -m644 ovmf-x64/OVMF_CODE-pure-efi.fd $pkgdir/usr/lib/windows-gaming/ovmf-code.fd
+ install -D -m644 ovmf-x64/OVMF_VARS-pure-efi.fd $pkgdir/usr/lib/windows-gaming/ovmf-vars.fd
+ install -D -m644 guest-agent/windows-gaming-ga.iso $pkgdir/usr/lib/windows-gaming/windows-gaming-ga.iso
+ install -D -m644 ../virtio-win_amd64.vfd $pkgdir/usr/lib/windows-gaming/virtio-win.vfd
+ install -D -m644 misc/windows.service $pkgdir/usr/lib/systemd/system/windows.service
+ install -D -m644 misc/windows.service $pkgdir/usr/lib/systemd/user/windows.service
+ install -D -m644 misc/80-vfio.rules $pkgdir/usr/lib/udev/rules.d/80-vfio.rules
}