summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfwhcat2019-05-02 23:17:17 +0200
committerfwhcat2019-05-02 23:17:17 +0200
commit28493f7333c4e0922598ec0511c53d3e4b7af3f5 (patch)
tree5b3ed2fa9aa352b862b010232525bb0c28985f26
downloadaur-28493f7333c4e0922598ec0511c53d3e4b7af3f5.tar.gz
Packaging done right.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD35
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39d50746e406
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 5.1.3
+# Thu May 2 20:28:44 UTC 2019
+pkgbase = windows10-icon-theme-git
+ pkgdesc = Windows 10 icon theme
+ pkgver = r5.7cf4204
+ pkgrel = 1
+ url = https://github.com/B00merang-Artwork/Windows-10
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = windows10-icon-theme
+ conflicts = windows10-icon-theme
+ source = windows10-icon-theme::git+https://github.com/B00merang-Artwork/Windows-10.git
+ sha256sums = SKIP
+
+pkgname = windows10-icon-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5befe97c0c5c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+windows10-icon-theme/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9feeaac0ca95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: fwhcat <fabien.wang@gmail.com>
+
+_pkgname=windows10-icon-theme
+pkgname=${_pkgname}-git
+pkgver=r5.7cf4204
+pkgrel=1
+pkgdesc="Windows 10 icon theme"
+arch=('any')
+url="https://github.com/B00merang-Artwork/Windows-10"
+license=('GPL3')
+
+makedepends=('git')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+source=("${_pkgname}::git+https://github.com/B00merang-Artwork/Windows-10.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package()
+{
+ cd "${srcdir}/${_pkgname}"
+ install -d -m 755 "$pkgdir/usr/share/icons/Windows10"
+
+ cp -a * "$pkgdir/usr/share/icons/Windows10"
+ rm -rf "$pkgdir/.git/*"
+ rm -f "$pkgdir/usr/share/icons/Windows10/README.md"
+ find "$pkgdir/usr/share/icons/Windows10" -type f -exec chmod 644 {} +
+ find "$pkgdir/usr/share/icons/Windows10" -type l -exec chmod -c 644 {} +
+}