summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblocklisted2023-03-31 18:10:21 +0200
committerblocklisted2023-03-31 18:10:21 +0200
commit6c9ba84a5709d44ad5a609c509d7f4296e7b6edf (patch)
tree3254497bc2c3cbfe78f100fd92fc620affb604f3
parenta3a24d32179a8b1abfea40e9aa3f4122f4841f04 (diff)
downloadaur-6c9ba84a5709d44ad5a609c509d7f4296e7b6edf.tar.gz
update to 2.6.14 and switch to arch release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--windscribe-v2-bin.install91
3 files changed, 64 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 874313e96376..5d88f1cc8c29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = windscribe-v2-bin
pkgdesc = Windscribe GUI tool for Linux
- pkgver = 2.5.18
- pkgrel = 2
+ pkgver = 2.6.14
+ pkgrel = 1
url = https://windscribe.com/guides/linux
install = windscribe-v2-bin.install
arch = x86_64
license = GPL2
- depends = bash
depends = nftables
+ depends = c-ares
+ depends = freetype2
+ depends = hicolor-icon-theme
+ depends = curl
+ depends = systemd
+ depends = glibc>=2.28
provides = windscribe
conflicts = windscribe-cli
options = !strip
- source = https://deploy.totallyacdn.com/desktop-apps/2.5.18/windscribe_2.5.18_amd64.deb
+ source = https://deploy.totallyacdn.com/desktop-apps/2.6.14/windscribe_2.6.14_x86_64.pkg.tar.zst
sha1sums = f539a4e0254ee800203b3671885d2ca433f610f7
pkgname = windscribe-v2-bin
diff --git a/PKGBUILD b/PKGBUILD
index c13ba59d94d5..92cf037116fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: blocklisted <blocklisted at protonmail dot com>
pkgname=windscribe-v2-bin
-pkgver=2.5.18
-pkgrel=2
+pkgver=2.6.14
+pkgrel=1
pkgdesc="Windscribe GUI tool for Linux"
arch=('x86_64')
url="https://windscribe.com/guides/linux"
license=('GPL2')
-depends=('bash' 'nftables')
+depends=('nftables' 'c-ares' 'freetype2' 'hicolor-icon-theme' 'curl' 'systemd' 'glibc>=2.28')
provides=('windscribe')
-conflicts=('windscribe-cli')
+conflicts=('windscribe-cli' 'windscribe')
options=('!strip')
install=windscribe-v2-bin.install
-source=("https://deploy.totallyacdn.com/desktop-apps/${pkgver}/windscribe_${pkgver}_amd64.deb")
-sha1sums=('f539a4e0254ee800203b3671885d2ca433f610f7')
+source=("https://deploy.totallyacdn.com/desktop-apps/${pkgver}/windscribe_${pkgver}_x86_64.pkg.tar.zst")
+sha1sums=('e1c200528b03445406fdd9295ba524043f2cfcfa')
package() {
- bsdtar -C "${pkgdir}" -xJf data.tar.xz
-
- chmod -R 755 ${pkgdir}
+ mv ${srcdir}/etc ${pkgdir}
+ mv ${srcdir}/opt ${pkgdir}
+ mv ${srcdir}/usr ${pkgdir}
}
diff --git a/windscribe-v2-bin.install b/windscribe-v2-bin.install
index 1ce3101eff1f..fdf2a488f28c 100644
--- a/windscribe-v2-bin.install
+++ b/windscribe-v2-bin.install
@@ -1,56 +1,57 @@
pre_install() {
- end=$((SECONDS+10))
-
- while :
- do
- if [ -z "$(ps -eo args | grep WindscribeEngine | grep -v grep)" ]; then
- break
- fi
-
- if [ $SECONDS -gt $end ]; then
- echo 'Error during Windscribe installation. WindscribeEngine is running. Please re-launch Windscribe. And try to update again.'
- exit 1
- fi
- done
-
- systemctl stop windscribe-helper > /dev/null 2>&1
- systemctl disable windscribe-helper > /dev/null 2>&1
-
- # Stop and disable firewalld service if it is active, otherwise it will conflict with iptables on OS reboot
- # Relevant for Fedora distributions
- systemctl is-active --quiet firewalld
- if [ $? -eq 0 ]
- then
- echo "Firewalld service is running. It will be stopped and disabled to avoid conflicts with the Windscribe iptables firewall."
- sudo systemctl stop firewalld
- sudo systemctl disable firewalld
- fi
-
- echo "Finish pre-install script"
+ end=$((SECONDS+10))
+
+ while :
+ do
+ if [ -z "$(ps -eo args | grep WindscribeEngine | grep -v grep)" ]; then
+ break
+ fi
+
+ if [ $SECONDS -gt $end ]; then
+ echo 'Error during Windscribe installation. WindscribeEngine is running. Please re-launch Windscribe. And try to update again.'
+ exit 1
+ fi
+ done
+
+ systemctl stop windscribe-helper > /dev/null 2>&1
+ systemctl disable windscribe-helper > /dev/null 2>&1
+
+ # Stop and disable firewalld service if it is active, otherwise it will conflict with iptables on OS reboot
+ # Relevant for Fedora distributions
+ systemctl is-active --quiet firewalld
+ if [ $? -eq 0 ]
+ then
+ echo "Firewalld service is running. It will be stopped and disabled to avoid conflicts with the Windscribe iptables firewall."
+ sudo systemctl stop firewalld
+ sudo systemctl disable firewalld
+ fi
+
+ echo "Finish pre-install script"
}
post_install() {
- set -e
- #systemctl enable systemd-resolved
- #systemctl start systemd-resolved
- systemctl enable windscribe-helper
- systemctl start windscribe-helper
+ systemctl preset windscribe-helper
+ systemctl enable windscribe-helper
+ systemctl start windscribe-helper
+ systemctl enable systemd-resolved
+ systemctl start systemd-resolved
+ ln -s /opt/windscribe/Windscribe /usr/bin/windscribe
+ update-desktop-database
+ echo linux_zst_x64 > ../etc/windscribe/platform
}
-post_upgrade() {
- set -e
- systemctl enable windscribe-helper
- systemctl start windscribe-helper
+pre_upgrade() {
+ set -e
+ systemctl stop windscribe-helper
+ systemctl disable windscribe-helper
}
-pre_remove() {
- set -e
- systemctl stop windscribe-helper
- systemctl disable windscribe-helper
+post_upgrade() {
+ post_install
}
-pre_upgrade() {
- set -e
- systemctl stop windscribe-helper
- systemctl disable windscribe-helper
+pre_remove() {
+ systemctl stop windscribe-helper
+ systemctl disable windscribe-helper
+ rm /usr/bin/windscribe
}