summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblocklisted2022-01-02 22:06:43 +0100
committerBlockListed2022-01-02 22:06:43 +0100
commita8ecb9c931f500dca258a3bbf1eb069d3dc34e5f (patch)
treedc804a48d5df2c512c1de026994d23b1ae9e7f33
parentf81636f4ab79919f2e6b842e94ae302210dbe1bb (diff)
downloadaur-a8ecb9c931f500dca258a3bbf1eb069d3dc34e5f.tar.gz
fixed issue where upgrading didn't stop the service before the upgrade, which results in systemd complaining
-rw-r--r--PKGBUILD4
-rw-r--r--windscribe-v2-bin.install12
2 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae28e1238df1..f4a8d740288b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: blocklisted <blocklisted at protonmail dot com>
pkgname=windscribe-v2-bin
pkgver=2.3.15_beta
-pkgrel=1
+pkgrel=2
pkgdesc="Windscribe GUI tool for Linux"
arch=('x86_64')
url="https://windscribe.com/guides/linux"
@@ -18,4 +18,4 @@ package() {
bsdtar -C "${pkgdir}" -xJf data.tar.xz
chmod -R 755 ${pkgdir}
-} \ No newline at end of file
+}
diff --git a/windscribe-v2-bin.install b/windscribe-v2-bin.install
index a775971fe510..76c07902c112 100644
--- a/windscribe-v2-bin.install
+++ b/windscribe-v2-bin.install
@@ -35,8 +35,20 @@ post_install() {
systemctl start windscribe-helper
}
+post_upgrade() {
+ set -e
+ systemctl enable windscribe-helper
+ systemctl start windscribe-helper
+}
+
pre_remove() {
set -e
systemctl stop windscribe-helper
systemctl disable windscribe-helper
}
+
+pre_upgrade() {
+ set -e
+ systemctl stop windscribe-helper
+ systemctl disable windscribe-helper
+}