summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShayne Hartford2022-03-08 07:52:27 -0500
committerShayne Hartford2022-03-08 07:52:27 -0500
commit19f6e550a6d1a1dce6c30df13627231bcf6f6804 (patch)
treeff7f69e6b510c06edbd179275e974e4facd32885
downloadaur-19f6e550a6d1a1dce6c30df13627231bcf6f6804.tar.gz
Upload package
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD46
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d557e5399d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = windscribegui-git
+ pkgdesc = Qt 5/6 based GUI for Windscribe VPN written in Python
+ pkgver = r2.3cecaab
+ pkgrel = 1
+ url = https://github.com/shaybox/windscribegui
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-pip
+ makedepends = python-poetry
+ depends = windscribe-cli
+ depends = python-qtpy
+ depends = python-windscribe
+ optdepends = python-pyqt5: Qt5
+ optdepends = python-pyqt6: Qt6
+ source = git+https://github.com/shaybox/windscribegui.git
+ sha512sums = SKIP
+
+pkgname = windscribegui-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6c8ad9b698a8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!SteamAccountSwitcher.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77baa7fe6205
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Shayne Hartford <shayneehartford@gmail.com>
+
+_pkgname=windscribegui
+pkgname="${_pkgname}-git"
+pkgver=r2.3cecaab
+pkgrel=1
+pkgdesc="Qt 5/6 based GUI for Windscribe VPN written in Python"
+arch=("any")
+url="https://github.com/shaybox/${_pkgname}"
+license=("MIT")
+depends=(
+ "windscribe-cli"
+ "python-qtpy"
+ "python-windscribe"
+)
+makedepends=(
+ "git"
+ "python-pip"
+ "python-poetry"
+)
+optdepends=(
+ "python-pyqt5: Qt5"
+ "python-pyqt6: Qt6"
+)
+source=(
+ "git+${url}.git"
+)
+sha512sums=(
+ "SKIP"
+)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ poetry build --format wheel
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm644 "data/share/applications/windscribe.desktop" "${pkgdir}/usr/share/applications/windscribe.desktop"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps dist/*.whl
+}