summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Franco2017-04-25 19:49:01 +0200
committerPierre Franco2017-04-25 19:49:01 +0200
commit94818af080e49c5daf45ac3e60dcdf911c1c0c4d (patch)
treebf8137b43ae83dc89e1d247b0042fcc98d772236
parente4ba82ae1c1aefa9492eed41f0fdc16b5a40b8a1 (diff)
downloadaur-94818af080e49c5daf45ac3e60dcdf911c1c0c4d.tar.gz
PKGBUILD and patches cleanup
-rw-r--r--PKGBUILD2
-rw-r--r--heap_perf.patch56
-rw-r--r--increase_max_frag_samplers.patch16
3 files changed, 0 insertions, 74 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a117a5a0c31..2a37e6331223 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -176,7 +176,6 @@ build()
--with-x \
--enable-win64 \
--with-xattr \
- --with-d3dadapter \
--disable-tests
# Gstreamer was disabled for FS#33655
@@ -197,7 +196,6 @@ build()
--with-x \
--with-xattr \
--disable-tests \
- --with-d3dadapter \
"${_wine32opts[@]}"
# These additional flags solve FS#23277
diff --git a/heap_perf.patch b/heap_perf.patch
deleted file mode 100644
index 7a2fff7ac30f..000000000000
--- a/heap_perf.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff --git a/dlls/ntdll/heap.c b/dlls/ntdll/heap.c
-index 95c3554..7b6f35f 100644
---- a/dlls/ntdll/heap.c
-+++ b/dlls/ntdll/heap.c
-@@ -116,9 +116,8 @@ C_ASSERT( sizeof(ARENA_LARGE) % LARGE_ALIGNMENT == 0 );
- /* Max size of the blocks on the free lists */
- static const SIZE_T HEAP_freeListSizes[] =
- {
-- 0x10, 0x18, 0x20, 0x28, 0x30, 0x38, 0x40, 0x48, 0x50, 0x58, 0x60, 0x68,
-- 0x70, 0x78, 0x80, 0x88, 0x90, 0x98, 0xA0, 0xA8, 0xB0, 0xB8, 0xC0, 0xC8,
-- 0xD0, 0xD8, 0xE0, 0xE8, 0xF0, 0xF8, 0x100, 0x200, 0x400, 0x1000, ~0UL
-+ 0x8, 0x10, 0x20, 0x30, 0x40, 0x60, 0x80, 0x100, 0x200, 0x400, 0x1000,
-+ 0x10000, 0x100000, 0x1000000, 0x10000000, ~0UL
- };
- #define HEAP_NB_FREE_LISTS (sizeof(HEAP_freeListSizes)/sizeof(HEAP_freeListSizes[0]))
-
-@@ -309,6 +308,20 @@ static inline unsigned int get_freelist_index( SIZE_T size )
- return i;
- }
-
-+/* compute the smallest index whose elements are at least as big as size */
-+/* size is the size of the whole block including the arena header */
-+static inline unsigned int get_freelist_index_at_least( SIZE_T size )
-+{
-+ return get_freelist_index(size);
-+}
-+
-+/* compute the smallest index whose elements are at most as big as size */
-+/* size is the size of the whole block including the arena header */
-+static inline unsigned int get_freelist_index_at_most( SIZE_T size )
-+{
-+ return get_freelist_index(size + 1) - 1;
-+}
-+
- /* get the memory protection type to use for a given heap */
- static inline ULONG get_protection_type( DWORD flags )
- {
-@@ -468,7 +481,8 @@ static HEAP *HEAP_GetPtr(
- */
- static inline void HEAP_InsertFreeBlock( HEAP *heap, ARENA_FREE *pArena, BOOL last )
- {
-- FREE_LIST_ENTRY *pEntry = heap->freeList + get_freelist_index( pArena->size + sizeof(*pArena) );
-+ FREE_LIST_ENTRY *pEntry = heap->freeList + get_freelist_index_at_most( pArena->size + sizeof(*pArena) );
-+
- if (last)
- {
- /* insert at end of free list, i.e. before the next free list entry */
-@@ -994,7 +1008,7 @@ static ARENA_FREE *HEAP_FindFreeBlock( HEAP *heap, SIZE_T size,
- SUBHEAP *subheap;
- struct list *ptr;
- SIZE_T total_size;
-- FREE_LIST_ENTRY *pEntry = heap->freeList + get_freelist_index( size + sizeof(ARENA_INUSE) );
-+ FREE_LIST_ENTRY *pEntry = heap->freeList + get_freelist_index_at_least( size + sizeof(ARENA_INUSE) );
-
- /* Find a suitable free list, and in it find a block large enough */
-
diff --git a/increase_max_frag_samplers.patch b/increase_max_frag_samplers.patch
deleted file mode 100644
index 873ed44e58fa..000000000000
--- a/increase_max_frag_samplers.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-@@ -, +, @@
----
- dlls/wined3d/wined3d_private.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
---- a/dlls/wined3d/wined3d_private.h
-+++ a/dlls/wined3d/wined3d_private.h
-@@ -180,7 +180,7 @@ void wined3d_rb_free(void *ptr) DECLSPEC_HIDDEN;
- #define MAX_STREAM_OUT 4
- #define MAX_STREAMS 16
- #define MAX_TEXTURES 8
--#define MAX_FRAGMENT_SAMPLERS 16
-+#define MAX_FRAGMENT_SAMPLERS 32
- #define MAX_VERTEX_SAMPLERS 4
- #define MAX_COMBINED_SAMPLERS (MAX_FRAGMENT_SAMPLERS + MAX_VERTEX_SAMPLERS)
- #define MAX_ACTIVE_LIGHTS 8
---