summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Franco2016-10-18 13:08:47 +0200
committerPierre Franco2016-10-18 13:08:47 +0200
commitd0299d72a8b41134c12c698ed58bdcbe94a55bea (patch)
tree2919f2636557519d1112390d22015f2e4bd62fb3
parent06487f817e7c0e999f0724ea5c7c7337b724d898 (diff)
downloadaur-d0299d72a8b41134c12c698ed58bdcbe94a55bea.tar.gz
Updated to version 1.9.21-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD18
2 files changed, 23 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ad84b88e8fd..758a54b929f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Oct 10 12:44:33 UTC 2016
+# Tue Oct 18 11:08:34 UTC 2016
pkgbase = wine-gaming-nine
pkgdesc = Based off wine-staging, including the gallium-nine patches and some more hacks
- pkgver = 1.9.20
- pkgrel = 2
+ pkgver = 1.9.21
+ pkgrel = 1
url = http://www.wine-staging.com
arch = i686
arch = x86_64
@@ -131,23 +131,23 @@ pkgbase = wine-gaming-nine
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=1.9.20
- provides = wine-wow64=1.9.20
- provides = wine-staging=1.9.20
+ provides = wine=1.9.21
+ provides = wine-wow64=1.9.21
+ provides = wine-staging=1.9.21
conflicts = wine
conflicts = wine-wow64
conflicts = wine-staging
options = staticlibs
- source = https://github.com/wine-compholio/wine-patched/archive/staging-1.9.20.tar.gz
- source = https://github.com/sarnex/wine-d3d9-patches/archive/wine-d3d9-1.9.20.tar.gz
+ source = https://github.com/wine-compholio/wine-patched/archive/staging-1.9.21.tar.gz
+ source = https://github.com/sarnex/wine-d3d9-patches/archive/wine-d3d9-1.9.21.tar.gz
source = 30-win32-aliases.conf
source = heap_perf.patch
source = increase_max_frag_samplers.patch
source = keybindings.patch
source = steam.patch
source = wbemprox_query_v2.patch
- sha1sums = 1322112de8dee5111647ab3ac285afc5ca6fcce9
- sha1sums = dd43f92fc8911f728526d8a557d19ffcc1aadafc
+ sha1sums = 401917142ec6a92f4823786f3250e3069723c65f
+ sha1sums = 6c0f061fa4704946a251f14bbf84bbf69c019220
sha1sums = 023a5c901c6a091c56e76b6a62d141d87cce9fdb
sha1sums = 0f4ac455436d5714a2cf0b537ed25f4fa5c1a7fd
sha1sums = a84456790932fb2e7bb75ddeac86fd45b7c09e79
diff --git a/PKGBUILD b/PKGBUILD
index 31d163524cbd..ec78a3c212cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,11 @@
# -Heap allocation perfomance improvement patch
# -Wbemprox videocontroller query fix v2 (see https://bugs.winehq.org/show_bug.cgi?id=38879 )
# -Steam patch, Crossover Hack version (see https://bugs.winehq.org/show_bug.cgi?id=39403 )
+# -Increase fragment samplers threshold (see https://bugs.winehq.org/show_bug.cgi?id=41213 ) OPTIONAL
pkgname=wine-gaming-nine
-pkgver=1.9.20
-pkgrel=2
+pkgver=1.9.21
+pkgrel=1
_pkgbasever=${pkgver/rc/-rc}
_winesrcdir="wine-patched-staging-$_pkgbasever"
@@ -24,8 +25,8 @@ source=("https://github.com/wine-compholio/wine-patched/archive/staging-$_pkgbas
steam.patch
wbemprox_query_v2.patch
)
-sha1sums=('1322112de8dee5111647ab3ac285afc5ca6fcce9'
- 'dd43f92fc8911f728526d8a557d19ffcc1aadafc'
+sha1sums=('401917142ec6a92f4823786f3250e3069723c65f'
+ '6c0f061fa4704946a251f14bbf84bbf69c019220'
'023a5c901c6a091c56e76b6a62d141d87cce9fdb'
'0f4ac455436d5714a2cf0b537ed25f4fa5c1a7fd'
'a84456790932fb2e7bb75ddeac86fd45b7c09e79'
@@ -135,7 +136,14 @@ prepare()
patch -p1 < "$srcdir/wine-d3d9-patches-wine-d3d9-$_pkgbasever/wine-d3d9.patch"
patch -p1 < ../steam.patch
patch -p1 < ../heap_perf.patch
- patch -p1 < ../increase_max_frag_samplers.patch
+
+ read -p "Do you want to apply the patch increasing the fragment samplers threshold (makes some DX11 games work, might break other stuff)? [y/N]" -n 1 -r
+ echo
+ if [[ $REPLY =~ ^[Yy]$ ]]
+ then
+ patch -p1 < ../increase_max_frag_samplers.patch
+ fi
+
patch -p1 < ../wbemprox_query_v2.patch
patch -p1 -R < ../keybindings.patch