summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre Franco2017-01-13 20:12:28 +0100
committerPierre Franco2017-01-13 20:12:28 +0100
commitfbbbaf4c0c2447ae1e4e7d62054dd0cb0d455a08 (patch)
treeb88a665c77f254a2b32d4c7282a68a2000736809
parentdd3db161076d272e7b3eb13255774daa1d3e73d7 (diff)
downloadaur-fbbbaf4c0c2447ae1e4e7d62054dd0cb0d455a08.tar.gz
Updated to version 2.0-rc4-2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--flex_fix.patch43
3 files changed, 51 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5876ac7d49b7..3597ef870995 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 13 18:38:25 UTC 2017
+# Fri Jan 13 19:11:04 UTC 2017
pkgbase = wine-gaming-nine
pkgdesc = Based off wine-staging, including the gallium-nine patches and some more hacks
pkgver = 2.0rc4
- pkgrel = 1
+ pkgrel = 2
url = http://www.wine-staging.com
arch = i686
arch = x86_64
@@ -142,6 +142,7 @@ pkgbase = wine-gaming-nine
source = https://github.com/wine-compholio/wine-patched/archive/staging-2.0-rc4.tar.gz
source = https://github.com/sarnex/wine-d3d9-patches/archive/wine-d3d9-2.0-rc2.tar.gz
source = 30-win32-aliases.conf
+ source = flex_fix.patch
source = heap_perf.patch
source = increase_max_frag_samplers.patch
source = keybindings.patch
@@ -150,6 +151,7 @@ pkgbase = wine-gaming-nine
sha1sums = b2639f4b62ac83eafbb66beff46be2cba28c08a5
sha1sums = 6145411f5aaa9189eeb93dc46b46e7a9e3fe2883
sha1sums = 023a5c901c6a091c56e76b6a62d141d87cce9fdb
+ sha1sums = 6d9fb35e74042233b0c0e7d6b212d2caad236b81
sha1sums = 0f4ac455436d5714a2cf0b537ed25f4fa5c1a7fd
sha1sums = a84456790932fb2e7bb75ddeac86fd45b7c09e79
sha1sums = f3febb8836f38320742a546c667106608d4c4395
diff --git a/PKGBUILD b/PKGBUILD
index 196bc312dd8b..1c2168ce71da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=wine-gaming-nine
pkgver=2.0rc4
-pkgrel=1
+pkgrel=2
_pkgbasever=${pkgver/rc/-rc}
_d3d9ver=2.0-rc2
@@ -20,7 +20,8 @@ _winesrcdir="wine-patched-staging-$_pkgbasever"
source=("https://github.com/wine-compholio/wine-patched/archive/staging-$_pkgbasever.tar.gz"
"https://github.com/sarnex/wine-d3d9-patches/archive/wine-d3d9-$_d3d9ver.tar.gz"
30-win32-aliases.conf
- heap_perf.patch
+ flex_fix.patch
+ heap_perf.patch
increase_max_frag_samplers.patch
keybindings.patch
steam.patch
@@ -29,6 +30,7 @@ source=("https://github.com/wine-compholio/wine-patched/archive/staging-$_pkgbas
sha1sums=('b2639f4b62ac83eafbb66beff46be2cba28c08a5'
'6145411f5aaa9189eeb93dc46b46e7a9e3fe2883'
'023a5c901c6a091c56e76b6a62d141d87cce9fdb'
+ '6d9fb35e74042233b0c0e7d6b212d2caad236b81'
'0f4ac455436d5714a2cf0b537ed25f4fa5c1a7fd'
'a84456790932fb2e7bb75ddeac86fd45b7c09e79'
'f3febb8836f38320742a546c667106608d4c4395'
diff --git a/flex_fix.patch b/flex_fix.patch
new file mode 100644
index 000000000000..6218bc422397
--- /dev/null
+++ b/flex_fix.patch
@@ -0,0 +1,43 @@
+From 7573939745b6cf62caa04cbcfcfa6982ba036542 Mon Sep 17 00:00:00 2001
+From: nvinson234 <nvinson234@gmail.com>
+Date: Sun, 1 Jan 2017 20:24:49 +0100
+Subject: [PATCH] undefined reference yywrap in winhlp32/macro.lex.yy.c
+ (flex-2.6.3)
+
+flex-2.6.3 uses C preprocessor macros to change the prefix of its functions
+from the standard yy to a user-defined one. This is a change in Flex behavior
+and causes wine to fail with any version of Flex newer than 2.6.1.
+
+The failure is caused because programs/winhlp32/macros.lex.l only defines the
+yywrap macro if it is not already defined. The end result is C code that is
+looking for an undefined yywrap() function.
+
+I have attached a patch that fixes this issue by removing the yywrap macro check and definition from macros.lex.l and adding the noyywrap flex option.
+---
+ programs/winhlp32/macro.lex.l | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/programs/winhlp32/macro.lex.l b/programs/winhlp32/macro.lex.l
+index 8f6945ca98..ff8a4832d3 100644
+--- a/programs/winhlp32/macro.lex.l
++++ b/programs/winhlp32/macro.lex.l
+@@ -20,7 +20,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA
+ */
+ %}
+-%option noinput nounput never-interactive 8bit
++%option noinput nounput noyywrap never-interactive 8bit
+ %x quote
+ %{
+ #include "config.h"
+@@ -367,7 +367,3 @@ WINHELP_WINDOW* MACRO_CurrentWindow(void)
+ {
+ return lex_data ? lex_data->window : Globals.active_win;
+ }
+-
+-#ifndef yywrap
+-int yywrap(void) { return 1; }
+-#endif
+--
+2.11.0
+