summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-03-05 20:24:07 +0200
committerStelios Tsampas2024-03-05 20:24:07 +0200
commit07a7c50b03b205dd5938c71fd49eff52ba0f865c (patch)
tree456b49777d2edd70737376b5d320eade64ab5c14
parentb77d53eb1e8058b1cdc70a5b3021795951777a48 (diff)
downloadaur-07a7c50b03b205dd5938c71fd49eff52ba0f865c.tar.gz
[wine-ge-custom] Set mtune=generic and allow avx to be enabled
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca93f004090b..263830393ee3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wine-ge-custom
pkgdesc = A compatibility layer for running Windows programs - GloriousEggroll branch
pkgver = GE.Proton8.26
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/GloriousEggroll/wine-ge-custom
install = wine.install
diff --git a/PKGBUILD b/PKGBUILD
index 5576e5d22cb1..e2e01bcd5cda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=wine-ge-custom
_srctag=GE-Proton8-26
_commit=21f5f463cb761b94bcd00553f924f55516389f5b
pkgver=${_srctag//-/.}
-pkgrel=1
+pkgrel=2
epoch=1
_pkgbasever=${pkgver/rc/-rc}
@@ -138,12 +138,12 @@ build() {
local -A flags
for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
local march="${flags["-march"]:-nocona}"
- local mtune="${flags["-mtune"]:-core-avx2}"
+ local mtune="generic" #"${flags["-mtune"]:-core-avx2}"
# From Proton
- OPTIMIZE_FLAGS="-O2 -march=$march -mtune=$mtune -mfpmath=sse -pipe -fno-semantic-interposition"
+ OPTIMIZE_FLAGS="-O3 -march=$march -mtune=$mtune -mfpmath=sse -pipe -fno-semantic-interposition"
SANITY_FLAGS="-fwrapv -fno-strict-aliasing"
- COMMON_FLAGS="$OPTIMIZE_FLAGS $SANITY_FLAGS -s -mno-avx2"
+ COMMON_FLAGS="$OPTIMIZE_FLAGS $SANITY_FLAGS -s"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
export CROSSLDFLAGS="$LDFLAGS -Wl,--file-alignment,4096"