summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-05-10 11:50:19 +0300
committerStelios Tsampas2024-05-10 11:50:19 +0300
commit219f7f8768c2a6c47d4aa8aaa2be5dc66e98e799 (patch)
tree51971f62cd6d3cb667826e2d1f284de59da2173d
parent43683b677756263b51ec06ccdd48277cb901a140 (diff)
downloadaur-219f7f8768c2a6c47d4aa8aaa2be5dc66e98e799.tar.gz
[wine-ge-custom] Fix build
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 34 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c972473671cb..5fac1bdea87b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = wine-ge-custom
pkgdesc = A compatibility layer for running Windows programs - GloriousEggroll branch
pkgver = GE.Proton9.4
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/GloriousEggroll/wine-ge-custom
install = wine.install
arch = x86_64
arch = x86_64_v3
- license = LGPL
+ license = LGPL-2.1-or-later
makedepends = autoconf
makedepends = bison
makedepends = perl
@@ -51,8 +51,12 @@ pkgbase = wine-ge-custom
makedepends = lib32-vulkan-icd-loader
makedepends = sdl2
makedepends = lib32-sdl2
+ makedepends = libcups
+ makedepends = lib32-libcups
+ makedepends = sane
makedepends = libgphoto2
makedepends = ffmpeg
+ makedepends = samba
makedepends = opencl-headers
depends = attr
depends = lib32-attr
@@ -107,8 +111,11 @@ pkgbase = wine-ge-custom
optdepends = lib32-vulkan-icd-loader
optdepends = sdl2
optdepends = lib32-sdl2
+ optdepends = sane
optdepends = libgphoto2
optdepends = ffmpeg
+ optdepends = cups
+ optdepends = samba
optdepends = dosbox
provides = wine=9.0
conflicts = wine
@@ -116,16 +123,16 @@ pkgbase = wine-ge-custom
options = !lto
options = !debug
source = wine-ge-custom::git+https://github.com/loathingKernel/wine-ge-custom.git#commit=e664ad5c3bdb4b6bc20882232cc88eb00784295f
- source = wine-wmclass.patch
- source = wine-isolate_home.patch
source = 30-win32-aliases.conf
source = wine-binfmt.conf
+ source = wine-wmclass.patch
+ source = wine-isolate_home.patch
validpgpkeys = 5AC1A08B03BD7A313E0A955AF5E6E9EEB9461DD7
validpgpkeys = DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D
sha512sums = 1ddc28026d4b54f585e1fb953f0a223fa6433ed7115ea16b50d29a5c6ba5b69da5d25c29ccc6036fb831dfff98f47b2eeb903869f740b702b0eb7aac6a658d31
- sha512sums = 30437d8ee92c5741fa50a7fe346ccfc48ba809dad0d740903a05a67781d23ea38a5094038a070a253e3fdd8046783b46a5420df6361bdd30cb229d3d88107569
- sha512sums = 3dcdbd523fcbe79b9e9e9b026b9d0a5edf296514c7b48bd465d2dc05a8ca08e23ba8817e2de08edfe52286a2a2f81db42b65f71254cabe496752b9d45131d282
sha512sums = 6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb
sha512sums = bdde7ae015d8a98ba55e84b86dc05aca1d4f8de85be7e4bd6187054bfe4ac83b5a20538945b63fb073caab78022141e9545685e4e3698c97ff173cf30859e285
+ sha512sums = 30437d8ee92c5741fa50a7fe346ccfc48ba809dad0d740903a05a67781d23ea38a5094038a070a253e3fdd8046783b46a5420df6361bdd30cb229d3d88107569
+ sha512sums = 3dcdbd523fcbe79b9e9e9b026b9d0a5edf296514c7b48bd465d2dc05a8ca08e23ba8817e2de08edfe52286a2a2f81db42b65f71254cabe496752b9d45131d282
pkgname = wine-ge-custom
diff --git a/PKGBUILD b/PKGBUILD
index 7703a93cdb43..22e9cf83d958 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=wine-ge-custom
_srctag=GE-Proton9-4
_commit=e664ad5c3bdb4b6bc20882232cc88eb00784295f
pkgver=${_srctag//-/.}
-pkgrel=1
+pkgrel=2
epoch=1
_pkgbasever=${pkgver/rc/-rc}
@@ -17,15 +17,19 @@ _winever=$_pkgbasever
#_winever=${_pkgbasever%.*}
source=(wine-ge-custom::git+https://github.com/loathingKernel/wine-ge-custom.git#commit=${_commit}
- wine-wmclass.patch
- wine-isolate_home.patch
30-win32-aliases.conf
wine-binfmt.conf)
+source+=(
+ wine-wmclass.patch
+ wine-isolate_home.patch
+)
sha512sums=('1ddc28026d4b54f585e1fb953f0a223fa6433ed7115ea16b50d29a5c6ba5b69da5d25c29ccc6036fb831dfff98f47b2eeb903869f740b702b0eb7aac6a658d31'
- '30437d8ee92c5741fa50a7fe346ccfc48ba809dad0d740903a05a67781d23ea38a5094038a070a253e3fdd8046783b46a5420df6361bdd30cb229d3d88107569'
- '3dcdbd523fcbe79b9e9e9b026b9d0a5edf296514c7b48bd465d2dc05a8ca08e23ba8817e2de08edfe52286a2a2f81db42b65f71254cabe496752b9d45131d282'
'6e54ece7ec7022b3c9d94ad64bdf1017338da16c618966e8baf398e6f18f80f7b0576edf1d1da47ed77b96d577e4cbb2bb0156b0b11c183a0accf22654b0a2bb'
'bdde7ae015d8a98ba55e84b86dc05aca1d4f8de85be7e4bd6187054bfe4ac83b5a20538945b63fb073caab78022141e9545685e4e3698c97ff173cf30859e285')
+sha512sums+=(
+ '30437d8ee92c5741fa50a7fe346ccfc48ba809dad0d740903a05a67781d23ea38a5094038a070a253e3fdd8046783b46a5420df6361bdd30cb229d3d88107569'
+ '3dcdbd523fcbe79b9e9e9b026b9d0a5edf296514c7b48bd465d2dc05a8ca08e23ba8817e2de08edfe52286a2a2f81db42b65f71254cabe496752b9d45131d282'
+)
validpgpkeys=(5AC1A08B03BD7A313E0A955AF5E6E9EEB9461DD7
DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D)
@@ -33,7 +37,7 @@ pkgdesc="A compatibility layer for running Windows programs - GloriousEggroll br
url="https://github.com/GloriousEggroll/wine-ge-custom"
arch=(x86_64 x86_64_v3)
options=(!staticlibs !lto !debug)
-license=(LGPL)
+license=(LGPL-2.1-or-later)
depends=(
attr lib32-attr
@@ -73,8 +77,11 @@ makedepends=(autoconf bison perl flex mingw-w64-gcc
gst-plugins-good lib32-gst-plugins-good
vulkan-icd-loader lib32-vulkan-icd-loader
sdl2 lib32-sdl2
+ libcups lib32-libcups
+ sane
libgphoto2
ffmpeg
+ samba
opencl-headers
)
@@ -94,9 +101,11 @@ optdepends=(
gst-plugins-good lib32-gst-plugins-good
vulkan-icd-loader lib32-vulkan-icd-loader
sdl2 lib32-sdl2
+ sane
libgphoto2
ffmpeg
- dosbox
+ cups
+ samba dosbox
)
provides=("wine=9.0")
@@ -128,8 +137,7 @@ prepare() {
build() {
# Doesn't compile without remove these flags as of 4.10
- export CFLAGS="${CFLAGS/-fno-plt/}"
- export LDFLAGS="${LDFLAGS/,-z,now/}"
+ export CFLAGS="$CFLAGS -ffat-lto-objects"
local -a split=($CFLAGS)
local -A flags
@@ -140,7 +148,8 @@ build() {
# From Proton
OPTIMIZE_FLAGS="-O3 -march=$march -mtune=$mtune -mfpmath=sse -pipe -fno-semantic-interposition"
SANITY_FLAGS="-fwrapv -fno-strict-aliasing"
- COMMON_FLAGS="$OPTIMIZE_FLAGS $SANITY_FLAGS -s"
+ TEMPORARY_FLAGS="-Wno-incompatible-pointer-types"
+ COMMON_FLAGS="$OPTIMIZE_FLAGS $SANITY_FLAGS $TEMPORARY_FLAGS -s"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
export CROSSLDFLAGS="$LDFLAGS -Wl,--file-alignment,4096"
@@ -220,8 +229,8 @@ package() {
i686-w64-mingw32-strip --strip-unneeded "$pkgdir"/usr/lib32/wine/i386-windows/*.{dll,exe}
x86_64-w64-mingw32-strip --strip-unneeded "$pkgdir"/usr/lib/wine/x86_64-windows/*.{dll,exe}
- #find "$pkgdir"/usr/lib{,32}/wine -iname "*.a" -delete
- #find "$pkgdir"/usr/lib{,32}/wine -iname "*.def" -delete
+ find "$pkgdir"/usr/lib{,32}/wine -iname "*.a" -delete
+ find "$pkgdir"/usr/lib{,32}/wine -iname "*.def" -delete
}
# vim:set ts=8 sts=2 sw=2 et: