summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr2019-12-30 08:19:52 +0100
committerPiotr2019-12-30 08:19:52 +0100
commite7adcd078da3741f1d89fa3c2902d78cfa12a592 (patch)
tree05b3f4131ed083a388c2884a2ed9840f045b012a
downloadaur-e7adcd078da3741f1d89fa3c2902d78cfa12a592.tar.gz
Old version needed by proton
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebe3efc374ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wine-gecko-2.47
+ pkgdesc = Wine's built-in replacement for Microsoft's Internet Explorer
+ pkgver = 2.47
+ pkgrel = 1
+ url = https://wiki.winehq.org/Gecko
+ arch = x86_64
+ license = MPL
+ optdepends = wine: require version >1.9.13, <5.0
+ provides = wine_gecko=2.47
+ conflicts = wine_gecko=2.47
+ replaces = wine_gecko=2.47
+ source = https://dl.winehq.org/wine/wine-gecko/2.47/wine_gecko-2.47-x86.msi
+ md5sums = 5ebc4ec71c92b3db3d84b334a1db385d
+ source_x86_64 = https://dl.winehq.org/wine/wine-gecko/2.47/wine_gecko-2.47-x86_64.msi
+ md5sums_x86_64 = d93ac0d2e6aceafe9113a9918916df45
+
+pkgname = wine-gecko-2.47
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6b2151e535b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: PitBall
+
+pkgname=wine-gecko-2.47
+pkgver=2.47
+pkgrel=1
+pkgdesc="Wine's built-in replacement for Microsoft's Internet Explorer"
+arch=('x86_64')
+url="https://wiki.winehq.org/Gecko"
+license=('MPL')
+optdepends=('wine: require version >1.9.13, <5.0')
+replaces=('wine_gecko=2.47')
+provides=('wine_gecko=2.47')
+conflicts=('wine_gecko=2.47')
+source=(https://dl.winehq.org/wine/wine-gecko/$pkgver/wine_gecko-$pkgver-x86.msi)
+source_x86_64=(https://dl.winehq.org/wine/wine-gecko/$pkgver/wine_gecko-$pkgver-x86_64.msi)
+md5sums=('5ebc4ec71c92b3db3d84b334a1db385d')
+md5sums_x86_64=('d93ac0d2e6aceafe9113a9918916df45')
+
+package() {
+ install -Dm644 wine_gecko-$pkgver-x86.msi wine_gecko-$pkgver-x86_64.msi -t "$pkgdir"/usr/share/wine/gecko/
+}