summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-03-04 16:21:07 -0300
committerDaniel Bermond2018-03-04 16:21:07 -0300
commit015b30bca6c89a132cc04b31adee84923a53194c (patch)
tree0f5b521bd0cbb5d68a339d336affc094282a21b4
parent084aae7f61585b1c4fdccc7a650134b52379d051 (diff)
downloadaur-015b30bca6c89a132cc04b31adee84923a53194c.tar.gz
Add freetype harmony fix and wine binfmt
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--harmony-fix.diff63
-rw-r--r--wine-binfmt.conf2
-rw-r--r--wine-git.install7
5 files changed, 98 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1f01a9d76df..76ad05483f20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
-# Generated by mksrcinfo v8
-# Sat Dec 9 00:44:08 UTC 2017
pkgbase = wine-git
pkgdesc = A compatibility layer for running Windows programs (git version)
- pkgver = 3.0rc1.r0.g5a7ce7ccb1
+ pkgver = 3.3.r0.gf17120d11b
pkgrel = 1
- url = https://www.winehq.org
+ url = https://www.winehq.org/
+ install = wine-git.install
arch = i686
arch = x86_64
license = LGPL
@@ -120,9 +119,9 @@ pkgbase = wine-git
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=3.0rc1.r0.g5a7ce7ccb1
- provides = bin32-wine=3.0rc1.r0.g5a7ce7ccb1
- provides = wine-wow64=3.0rc1.r0.g5a7ce7ccb1
+ provides = wine=3.3.r0.gf17120d11b
+ provides = bin32-wine=3.3.r0.gf17120d11b
+ provides = wine-wow64=3.3.r0.gf17120d11b
conflicts = wine
conflicts = wine-staging
conflicts = wine-staging-git
@@ -131,9 +130,13 @@ pkgbase = wine-git
replaces = bin32-wine
options = staticlibs
source = wine-git::git://source.winehq.org/git/wine.git
+ source = harmony-fix.diff
source = 30-win32-aliases.conf
+ source = wine-binfmt.conf
sha256sums = SKIP
+ sha256sums = 50ccb5bd2067e5d2739c5f7abcef11ef096aa246f5ceea11d2c3b508fc7f77a1
sha256sums = 9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7
+ sha256sums = 6dfdefec305024ca11f35ad7536565f5551f09119dda2028f194aee8f77077a4
pkgname = wine-git
depends = fontconfig
diff --git a/PKGBUILD b/PKGBUILD
index 5de7dff9e744..64f28a982d8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
# Contributor: sxe <sxxe@gmx.de>
pkgname=wine-git
-pkgver=3.0rc1.r0.g5a7ce7ccb1
+pkgver=3.3.r0.gf17120d11b
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (git version)'
arch=('i686' 'x86_64')
-url='https://www.winehq.org'
+url='https://www.winehq.org/'
license=('LGPL')
_depends=(
'fontconfig' 'lib32-fontconfig'
@@ -72,10 +72,15 @@ optdepends=(
'dosbox'
)
options=('staticlibs')
+install="$pkgname".install
source=("$pkgname"::'git://source.winehq.org/git/wine.git'
- '30-win32-aliases.conf')
+ 'harmony-fix.diff'
+ '30-win32-aliases.conf'
+ 'wine-binfmt.conf')
sha256sums=('SKIP'
- '9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7')
+ '50ccb5bd2067e5d2739c5f7abcef11ef096aa246f5ceea11d2c3b508fc7f77a1'
+ '9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7'
+ '6dfdefec305024ca11f35ad7536565f5551f09119dda2028f194aee8f77077a4')
if [ "$CARCH" = 'i686' ]
then
@@ -97,6 +102,9 @@ prepare() {
# fix path of opencl headers
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
+
+ # freetype harmony fix
+ patch -Np1 -i "${srcdir}/harmony-fix.diff"
}
pkgver() {
@@ -183,5 +191,8 @@ package() {
# font aliasing settings for Win32 applications
install -d "$pkgdir"/etc/fonts/conf.{avail,d}
install -m644 "${srcdir}/30-win32-aliases.conf" "${pkgdir}/etc/fonts/conf.avail"
- ln -s ../conf.avail/30-win32-aliases.conf "${pkgdir}/etc/fonts/conf.d/30-win32-aliases.conf"
+ ln -s ../conf.avail/30-win32-aliases.conf "${pkgdir}/etc/fonts/conf.d/30-win32-aliases.conf"
+
+ # wine binfmt
+ install -D -m644 "${srcdir}/wine-binfmt.conf" "${pkgdir}/usr/lib/binfmt.d/wine.conf"
}
diff --git a/harmony-fix.diff b/harmony-fix.diff
new file mode 100644
index 000000000000..fe0c8c929d4a
--- /dev/null
+++ b/harmony-fix.diff
@@ -0,0 +1,63 @@
+diff -u -r wine/dlls/gdi32/freetype.c wine-ft281/dlls/gdi32/freetype.c
+--- wine/dlls/gdi32/freetype.c 2017-10-04 18:01:36.000000000 +0200
++++ wine-ft281/dlls/gdi32/freetype.c 2017-10-10 10:29:17.506632615 +0200
+@@ -996,18 +996,23 @@
+
+ static BOOL is_subpixel_rendering_enabled( void )
+ {
+-#ifdef FT_LCD_FILTER_H
+ static int enabled = -1;
+ if (enabled == -1)
+ {
+- enabled = (pFT_Library_SetLcdFilter &&
+- pFT_Library_SetLcdFilter( NULL, 0 ) != FT_Err_Unimplemented_Feature);
++ /* >= 2.8.1 provides LCD rendering without filters */
++ if (FT_Version.major > 2 ||
++ FT_Version.major == 2 && FT_Version.minor > 8 ||
++ FT_Version.major == 2 && FT_Version.minor == 8 && FT_Version.patch >= 1)
++ enabled = TRUE;
++#ifdef FT_LCD_FILTER_H
++ else if (pFT_Library_SetLcdFilter &&
++ pFT_Library_SetLcdFilter( NULL, 0 ) != FT_Err_Unimplemented_Feature)
++ enabled = TRUE;
++#endif
++ else enabled = FALSE;
+ TRACE("subpixel rendering is %senabled\n", enabled ? "" : "NOT ");
+ }
+ return enabled;
+-#else
+- return FALSE;
+-#endif
+ }
+
+
+@@ -7271,7 +7276,6 @@
+ case WINE_GGO_HBGR_BITMAP:
+ case WINE_GGO_VRGB_BITMAP:
+ case WINE_GGO_VBGR_BITMAP:
+-#ifdef FT_LCD_FILTER_H
+ {
+ switch (ft_face->glyph->format)
+ {
+@@ -7357,8 +7361,11 @@
+ if ( needsTransform )
+ pFT_Outline_Transform (&ft_face->glyph->outline, &transMatTategaki);
+
++#ifdef FT_LCD_FILTER_H
+ if ( pFT_Library_SetLcdFilter )
+ pFT_Library_SetLcdFilter( library, FT_LCD_FILTER_DEFAULT );
++#endif
++
+ pFT_Render_Glyph (ft_face->glyph, render_mode);
+
+ src = ft_face->glyph->bitmap.buffer;
+@@ -7439,9 +7446,6 @@
+
+ break;
+ }
+-#else
+- return GDI_ERROR;
+-#endif
+
+ case GGO_NATIVE:
+ {
diff --git a/wine-binfmt.conf b/wine-binfmt.conf
new file mode 100644
index 000000000000..4d4307336587
--- /dev/null
+++ b/wine-binfmt.conf
@@ -0,0 +1,2 @@
+# Start WINE on Windows executables
+:DOSWin:M::MZ::/usr/bin/wine:
diff --git a/wine-git.install b/wine-git.install
new file mode 100644
index 000000000000..88a31c4353e6
--- /dev/null
+++ b/wine-git.install
@@ -0,0 +1,7 @@
+post_install() {
+ printf '%s\n' "Run 'systemctl restart systemd-binfmt' in order to make the wine binfmt available on your system."
+}
+
+post_remove() {
+ printf '%s\n' "binfmt binary formats will be updated at reboot"
+}