summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsxe2015-06-23 10:53:00 +0200
committersxe2015-06-23 10:53:00 +0200
commita7297684a139f0f30c0c6709de58c1ff9eba7e9f (patch)
treecf3d4233a6afc3f8e0819290a34e3bde2480506f
downloadaur-a7297684a139f0f30c0c6709de58c1ff9eba7e9f.tar.gz
Initial import
-rw-r--r--.SRCINFO142
-rw-r--r--30-win32-aliases.conf20
-rw-r--r--PKGBUILD184
-rw-r--r--wine-git.install12
4 files changed, 358 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..eecdb3357fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,142 @@
+pkgbase = wine-git
+ pkgdesc = A compatibility layer for running Windows programs. Latest GIT version.
+ pkgver = 1.7.34.r0.gb34b2ca
+ pkgrel = 2
+ url = http://www.winehq.com
+ install = wine-git.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = autoconf
+ makedepends = ncurses
+ makedepends = bison
+ makedepends = perl
+ makedepends = fontforge
+ makedepends = flex
+ makedepends = prelink
+ makedepends = gcc>=4.5.0-2
+ makedepends = gcc-multilib>=4.5.0-2
+ makedepends = giflib
+ makedepends = lib32-giflib
+ makedepends = libpng
+ makedepends = lib32-libpng
+ makedepends = gnutls
+ makedepends = lib32-gnutls
+ makedepends = libxinerama
+ makedepends = lib32-libxinerama
+ makedepends = libxcomposite
+ makedepends = lib32-libxcomposite
+ makedepends = libxmu
+ makedepends = lib32-libxmu
+ makedepends = libxxf86vm
+ makedepends = lib32-libxxf86vm
+ makedepends = libxml2
+ makedepends = lib32-libxml2
+ makedepends = libldap
+ makedepends = lib32-libldap
+ makedepends = lcms
+ makedepends = lib32-lcms
+ makedepends = mpg123
+ makedepends = lib32-mpg123
+ makedepends = openal
+ makedepends = lib32-openal
+ makedepends = v4l-utils
+ makedepends = lib32-v4l-utils
+ makedepends = alsa-lib
+ makedepends = lib32-alsa-lib
+ makedepends = libxcomposite
+ makedepends = lib32-libxcomposite
+ makedepends = mesa
+ makedepends = lib32-mesa
+ makedepends = samba
+ makedepends = git
+ makedepends = fontconfig
+ makedepends = lib32-fontconfig
+ makedepends = libxcursor
+ makedepends = lib32-libxcursor
+ makedepends = libxrandr
+ makedepends = lib32-libxrandr
+ makedepends = libxdamage
+ makedepends = lib32-libxdamage
+ makedepends = libxi
+ makedepends = lib32-libxi
+ makedepends = gettext
+ makedepends = lib32-gettext
+ makedepends = freetype2
+ makedepends = lib32-freetype2
+ makedepends = glu
+ makedepends = lib32-glu
+ makedepends = libsm
+ makedepends = lib32-libsm
+ makedepends = gcc-libs
+ makedepends = lib32-gcc-libs
+ makedepends = desktop-file-utils
+ optdepends = giflib
+ optdepends = lib32-giflib
+ optdepends = libpng
+ optdepends = lib32-libpng
+ optdepends = libldap
+ optdepends = lib32-libldap
+ optdepends = gnutls
+ optdepends = lib32-gnutls
+ optdepends = lcms
+ optdepends = lib32-lcms
+ optdepends = libxml2
+ optdepends = lib32-libxml2
+ optdepends = mpg123
+ optdepends = lib32-mpg123
+ optdepends = openal
+ optdepends = lib32-openal
+ optdepends = v4l-utils
+ optdepends = lib32-v4l-utils
+ optdepends = libpulse
+ optdepends = lib32-libpulse
+ optdepends = alsa-plugins
+ optdepends = lib32-alsa-plugins
+ optdepends = alsa-lib
+ optdepends = lib32-alsa-lib
+ optdepends = libjpeg-turbo
+ optdepends = lib32-libjpeg-turbo
+ optdepends = libxcomposite
+ optdepends = lib32-libxcomposite
+ optdepends = libxinerama
+ optdepends = lib32-libxinerama
+ optdepends = ncurses
+ optdepends = lib32-ncurses
+ optdepends = libcl
+ optdepends = lib32-libcl
+ optdepends = cups
+ optdepends = samba
+ optdepends = dosbox
+ conflicts = bin32-wine
+ conflicts = wine-wow64
+ replaces = bin32-wine
+ source = wine-git::git://source.winehq.org/git/wine.git
+ source = 30-win32-aliases.conf
+ md5sums = SKIP
+ md5sums = 1ff4e467f59409272088d92173a0f801
+
+pkgname = wine-git
+ depends = fontconfig
+ depends = lib32-fontconfig
+ depends = libxcursor
+ depends = lib32-libxcursor
+ depends = libxrandr
+ depends = lib32-libxrandr
+ depends = libxdamage
+ depends = lib32-libxdamage
+ depends = libxi
+ depends = lib32-libxi
+ depends = gettext
+ depends = lib32-gettext
+ depends = freetype2
+ depends = lib32-freetype2
+ depends = glu
+ depends = lib32-glu
+ depends = libsm
+ depends = lib32-libsm
+ depends = gcc-libs
+ depends = lib32-gcc-libs
+ depends = desktop-file-utils
+ provides = wine=
+
diff --git a/30-win32-aliases.conf b/30-win32-aliases.conf
new file mode 100644
index 00000000000..99ae1f7b83a
--- /dev/null
+++ b/30-win32-aliases.conf
@@ -0,0 +1,20 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+ <alias binding="same">
+ <family>MS Shell Dlg</family>
+ <accept><family>Microsoft Sans Serif</family></accept>
+ <default><family>sans-serif</family></default>
+ </alias>
+ <alias binding="same">
+ <family>MS Shell Dlg 2</family>
+ <accept><family>Tahoma</family></accept>
+ <default><family>sans-serif</family></default>
+ </alias>
+
+ <alias binding="same">
+ <family>MS Sans Serif</family>
+ <prefer><family>Microsoft Sans Serif</family></prefer>
+ <default><family>sans-serif</family></default>
+ </alias>
+</fontconfig>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..0d775271ec8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,184 @@
+# Maintainer: sxe <sxxe@gmx.de>
+# Based on the wine package in the community repository
+
+pkgname=wine-git
+_gitname="wine"
+pkgver=1.7.34.r0.gb34b2ca
+pkgrel=2
+pkgdesc="A compatibility layer for running Windows programs. Latest GIT version."
+url="http://www.winehq.com"
+arch=('i686' 'x86_64')
+license='LGPL'
+install='wine-git.install'
+
+source=('wine-git::git://source.winehq.org/git/wine.git'
+ '30-win32-aliases.conf')
+md5sums=('SKIP'
+ '1ff4e467f59409272088d92173a0f801')
+
+_depends=(
+ fontconfig lib32-fontconfig
+ libxcursor lib32-libxcursor
+ libxrandr lib32-libxrandr
+ libxdamage lib32-libxdamage
+ libxi lib32-libxi
+ gettext lib32-gettext
+ freetype2 lib32-freetype2
+ glu lib32-glu
+ libsm lib32-libsm
+ gcc-libs lib32-gcc-libs
+ desktop-file-utils
+)
+
+makedepends=(autoconf ncurses bison perl fontforge flex prelink
+ 'gcc>=4.5.0-2' 'gcc-multilib>=4.5.0-2'
+ giflib lib32-giflib
+ libpng lib32-libpng
+ gnutls lib32-gnutls
+ libxinerama lib32-libxinerama
+ libxcomposite lib32-libxcomposite
+ libxmu lib32-libxmu
+ libxxf86vm lib32-libxxf86vm
+ libxml2 lib32-libxml2
+ libldap lib32-libldap
+ lcms lib32-lcms
+ mpg123 lib32-mpg123
+ openal lib32-openal
+ v4l-utils lib32-v4l-utils
+ alsa-lib lib32-alsa-lib
+ libxcomposite lib32-libxcomposite
+ mesa lib32-mesa
+ samba
+ git
+)
+
+optdepends=(
+ giflib lib32-giflib
+ libpng lib32-libpng
+ libldap lib32-libldap
+ gnutls lib32-gnutls
+ lcms lib32-lcms
+ libxml2 lib32-libxml2
+ mpg123 lib32-mpg123
+ openal lib32-openal
+ v4l-utils lib32-v4l-utils
+ libpulse lib32-libpulse
+ alsa-plugins lib32-alsa-plugins
+ alsa-lib lib32-alsa-lib
+ libjpeg-turbo lib32-libjpeg-turbo
+ libxcomposite lib32-libxcomposite
+ libxinerama lib32-libxinerama
+ ncurses lib32-ncurses
+ libcl lib32-libcl
+ cups
+ samba dosbox
+)
+
+# Check if libowfat is installed.
+# It has to be removed because WINE cannot be build if installed.
+# Thanks to haagch
+if [ -f /usr/lib/libowfat.a ]; then
+ msg2 "Error: libowfat.a detected. Please remove the libowfat package. WINE cannot be build if installed."
+ exit 0;
+fi
+
+if [[ $CARCH == i686 ]]; then
+ # Strip lib32 etc. on i686
+ _depends=(${_depends[@]/*32-*/})
+ makedepends=(${makedepends[@]/*32-*/} ${_depends[@]})
+ makedepends=(${makedepends[@]/*-multilib*/})
+ optdepends=(${optdepends[@]/*32-*/})
+else
+ makedepends=(${makedepends[@]} ${_depends[@]})
+ conflicts=('bin32-wine' 'wine-wow64')
+ replaces=('bin32-wine')
+fi
+
+pkgver() {
+ #date +%Y%m%d
+ cd "$srcdir/$pkgname"
+ git describe --always --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^wine.//'
+}
+
+build() {
+ cd "$srcdir"
+
+ # ncurses fix
+ sed -i 's|libncurses|libncursesw|g' "$srcdir/$pkgname/configure"
+ sed -i 's|lncurses|lncursesw|g' "$srcdir/$pkgname/configure"
+
+ # Get rid of old build dirs
+ rm -rf $pkgname-{32,64}-build
+ mkdir $pkgname-32-build
+
+ # These additional CPPFLAGS solve FS#27662 and FS#34195
+ export CPPFLAGS="${CPPFLAGS/-D_FORTIFY_SOURCE=2/} -D_FORTIFY_SOURCE=0"
+
+ if [[ $CARCH == x86_64 ]]; then
+
+ msg2 "Building Wine-64..."
+
+ mkdir $pkgname-64-build
+ cd "$srcdir/$pkgname-64-build"
+ ../$pkgname/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --with-x \
+ --without-gstreamer \
+ --enable-win64
+ # Gstreamer was disabled for FS#33655
+
+ make
+
+ _wine32opts=(
+ --libdir=/usr/lib32
+ --with-wine64="$srcdir/$pkgname-64-build"
+ )
+
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ fi
+
+ msg2 "Building Wine-32..."
+ cd "$srcdir/$pkgname-32-build"
+ ../$pkgname/configure \
+ --prefix=/usr \
+ --with-x \
+ --without-gstreamer \
+ "${_wine32opts[@]}"
+
+ # These additional flags solve FS#23277
+ make CFLAGS+="-mstackrealign -mincoming-stack-boundary=2" CXXFLAGS+="-mstackrealign -mincoming-stack-boundary=2"
+}
+
+package() {
+ depends=(${_depends[@]})
+
+ gitver=$(cd "$srcdir/$pkgname" && git describe --long | sed -r 's/^wine-//;s/([^-]*-g)/r\1/;s/-/./g')
+ provides=("wine=$gitver")
+ if [[ $CARCH == x86_64 ]]; then
+ provides[2]="bin32-wine=$gitver"
+ provides[3]="wine-wow64=$gitver"
+ fi
+
+ msg2 "Packaging Wine-32..."
+ cd "$srcdir/$pkgname-32-build"
+
+ if [[ $CARCH == i686 ]]; then
+ make prefix="$pkgdir/usr" install
+ else
+ make prefix="$pkgdir/usr" \
+ libdir="$pkgdir/usr/lib32" \
+ dlldir="$pkgdir/usr/lib32/wine" install
+
+ msg2 "Packaging Wine-64..."
+ cd "$srcdir/$pkgname-64-build"
+ make prefix="$pkgdir/usr" \
+ libdir="$pkgdir/usr/lib" \
+ dlldir="$pkgdir/usr/lib/wine" install
+ fi
+
+ # Font aliasing settings for Win32 applications
+ install -d "$pkgdir"/etc/fonts/conf.{avail,d}
+ install -m644 "$srcdir/30-win32-aliases.conf" "$pkgdir/etc/fonts/conf.avail"
+ ln -s ../conf.avail/30-win32-aliases.conf "$pkgdir/etc/fonts/conf.d/30-win32-aliases.conf"
+}
diff --git a/wine-git.install b/wine-git.install
new file mode 100644
index 00000000000..f71262186a6
--- /dev/null
+++ b/wine-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ echo "This wine package is wow64 enabled. This means it can run 32bit/64bit Windows apps on x86_64."
+ echo "If you are on x86_64, the default WINEARCH will be win64."
+ echo "This will cause a lot of Windows applications to malfunction even if they usually work in wine."
+ echo "Please create your ~/.wine with 'WINEARCH=win32 winecfg' if you are unsure and on x86_64."
+ echo "See the Arch wiki on wine for more information."
+}
+
+post_remove() {
+ update-desktop-database -q
+}