diff options
author | Daniel Bermond | 2024-05-22 23:07:07 -0300 |
---|---|---|
committer | Daniel Bermond | 2024-05-22 23:07:07 -0300 |
commit | c83d52ca1e1172fad0fe8f67f88e96f86f476ee8 (patch) | |
tree | 20f05e4dd99f4d863c44adff752e40e6ac127fcd | |
parent | 5e3c99e201ac26da98b4b7cd1b4c2432a4e02600 (diff) | |
download | aur-c83d52ca1e1172fad0fe8f67f88e96f86f476ee8.tar.gz |
Add cross compilation flags
-rw-r--r-- | .SRCINFO | 10 | ||||
-rw-r--r-- | PKGBUILD | 9 |
2 files changed, 12 insertions, 7 deletions
@@ -1,11 +1,11 @@ pkgbase = wine-git pkgdesc = A compatibility layer for running Windows programs (git version) - pkgver = 9.1.r52.ge3431a02e1d + pkgver = 9.9.r71.g1bccb4cf9a5 pkgrel = 1 url = https://www.winehq.org/ install = wine-git.install arch = x86_64 - license = LGPL + license = LGPL-2.1-or-later makedepends = git makedepends = perl makedepends = mingw-w64-gcc @@ -107,9 +107,9 @@ pkgbase = wine-git optdepends = lib32-v4l-utils optdepends = wine-gecko optdepends = wine-mono - provides = wine=9.1.r52.ge3431a02e1d - provides = bin32-wine=9.1.r52.ge3431a02e1d - provides = wine-wow64=9.1.r52.ge3431a02e1d + provides = wine=9.9.r71.g1bccb4cf9a5 + provides = bin32-wine=9.9.r71.g1bccb4cf9a5 + provides = wine-wow64=9.9.r71.g1bccb4cf9a5 conflicts = wine conflicts = bin32-wine conflicts = wine-wow64 @@ -3,12 +3,12 @@ # Contributor: sxe <sxxe@gmx.de> pkgname=wine-git -pkgver=9.1.r52.ge3431a02e1d +pkgver=9.9.r71.g1bccb4cf9a5 pkgrel=1 pkgdesc='A compatibility layer for running Windows programs (git version)' arch=('x86_64') url='https://www.winehq.org/' -license=('LGPL') +license=('LGPL-2.1-or-later') depends=( 'desktop-file-utils' 'fontconfig' 'lib32-fontconfig' @@ -97,6 +97,11 @@ pkgver() { build() { export CFLAGS+=' -ffat-lto-objects' + # apply flags for cross-compilation + export CROSSCFLAGS="${CFLAGS/-Werror=format-security/}" + export CROSSCXXFLAGS="${CXXFLAGS/-Werror=format-security/}" + export CROSSLDFLAGS="${LDFLAGS//-Wl,-z*([^[:space:]])/}" + # build wine 64-bit # (according to the wine wiki, this 64-bit/32-bit building order is mandatory) printf '%s\n' ' -> Building wine-64...' |