summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2019-06-03 17:57:58 -0600
committerSam Burgos2019-06-03 17:57:58 -0600
commit9036bda6a576882f606deef40f6b580182d0f168 (patch)
tree687fe8983ecbb8f1edb91fb6cbfca2186f76b1e7
downloadaur-9036bda6a576882f606deef40f6b580182d0f168.tar.gz
initial commit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD39
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f2027166b1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = wine-installer
+ pkgdesc = A meta-installer for Wine along with desktop files and libraries for WINE to work properly
+ pkgver = 4.0.5
+ pkgrel = 1
+ url = http://packages.linuxmint.com/pool/main/w/wine-installer
+ arch = x86_64
+ license = GPL
+ depends = gsm
+ depends = isdn4k-utils
+ depends = lib32-glu
+ depends = lib32-gpm
+ depends = lib32-gst-plugins-base
+ depends = lib32-krb5
+ depends = lib32-libcups
+ depends = lib32-libxcomposite
+ depends = lib32-libxslt
+ depends = lib32-mesa
+ depends = lib32-sdl2
+ depends = lib32-v4l-utils
+ depends = mesa
+ depends = sane
+ depends = sdl2
+ depends = unixodbc
+ depends = wine
+ depends = wine_gecko
+ depends = wine-mono
+ depends = winetricks
+ source = wine-installer-4.0.5.tar.xz::http://packages.linuxmint.com/pool/main/w/wine-installer/wine-installer_4.0.5.tar.xz
+ sha256sums = b360b6c34e2fbc84fd959caa204ba48c850db5fb437487ff2516e67c0632057f
+
+pkgname = wine-installer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..234dfb0b14c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Sam Burgos < santiago dot burgos1089 at gmail dot com >
+
+pkgname=wine-installer
+pkgver=4.0.5
+pkgrel=1
+pkgdesc='A meta-installer for Wine along with desktop files and libraries for WINE to work properly'
+arch=(x86_64)
+url="http://packages.linuxmint.com/pool/main/w/${pkgname}"
+license=(GPL)
+depends=(
+ gsm
+ isdn4k-utils
+ lib32-glu
+ lib32-gpm
+ lib32-gst-plugins-base
+ lib32-krb5
+ lib32-libcups
+ lib32-libxcomposite
+ lib32-libxslt
+ lib32-mesa
+ lib32-sdl2
+ lib32-v4l-utils
+ mesa
+ sane
+ sdl2
+ unixodbc
+ wine
+ wine_gecko
+ wine-mono
+ winetricks
+)
+source=("${pkgname}-${pkgver}.tar.xz::${url}/${pkgname}_${pkgver}.tar.xz")
+sha256sums=('b360b6c34e2fbc84fd959caa204ba48c850db5fb437487ff2516e67c0632057f')
+
+package() {
+ cd ${pkgname}
+ cp -r usr "$pkgdir"
+ cp -r etc "$pkgdir"
+} \ No newline at end of file