summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Jöhnk2022-02-16 16:58:33 +0100
committerManuel Reimer2022-02-17 14:01:50 +0100
commit51cb3145df4be5e29982620933e10a054c456b28 (patch)
tree2b8cfa09ec262d21ac3ae85d68552ab0935a270e
parent499c8012aa121109de87b24201a5b3b897bf4d5d (diff)
downloadaur-51cb3145df4be5e29982620933e10a054c456b28.tar.gz
Update glibc to 2.35
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
-rw-r--r--bz27343.patch48
3 files changed, 6 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb87b26d1287..5e95e77c2f16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-lol-glibc
pkgdesc = GNU C Library patched for wine-lol
- pkgver = 2.33
+ pkgver = 2.35
pkgrel = 1
url = https://www.gnu.org/software/libc
arch = x86_64
@@ -16,12 +16,9 @@ pkgbase = wine-lol-glibc
optdepends = gd: for memusagestat
options = !strip
options = staticlibs
- source = https://ftp.gnu.org/gnu/glibc/glibc-2.33.tar.xz
- source = bz27343.patch
+ source = https://ftp.gnu.org/gnu/glibc/glibc-2.35.tar.xz
source = wine-lol-poc1-glibc.diff::https://bugs.winehq.org/attachment.cgi?id=64482
- md5sums = 390bbd889c7e8e8a7041564cb6b27cca
- md5sums = cfe57018d06bf748b8ca1779980fef33
+ md5sums = dd571c67d85d89d7f60b854a4e207423
md5sums = 65e6d204ab9ad787c8dce999c4ba5c17
pkgname = wine-lol-glibc
-
diff --git a/PKGBUILD b/PKGBUILD
index 0e859c43c0be..a1b7e51f0540 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=wine-lol-glibc
pkgdesc='GNU C Library patched for wine-lol'
-pkgver=2.33
+pkgver=2.35
pkgrel=1
arch=(x86_64)
url='https://www.gnu.org/software/libc'
@@ -19,10 +19,8 @@ options=(!strip staticlibs)
#_commit=067fc32968b601493f4b247a3ac00caeea3f3d61
#source=(git+https://sourceware.org/git/glibc.git#commit=$_commit
source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz
- bz27343.patch
wine-lol-poc1-glibc.diff::https://bugs.winehq.org/attachment.cgi?id=64482)
-md5sums=('390bbd889c7e8e8a7041564cb6b27cca'
- 'cfe57018d06bf748b8ca1779980fef33'
+md5sums=('dd571c67d85d89d7f60b854a4e207423'
'65e6d204ab9ad787c8dce999c4ba5c17')
prepare() {
@@ -31,9 +29,6 @@ prepare() {
[[ -d glibc-$pkgver ]] && ln -s glibc-$pkgver glibc
cd glibc
- # commit c3479fb7939898ec22c655c383454d6e8b982a67
- patch -p1 -i "$srcdir"/bz27343.patch
-
# Add wine-lol glibc hack
patch -p1 -i "$srcdir/wine-lol-poc1-glibc.diff"
}
@@ -52,6 +47,7 @@ build() {
--enable-stack-protector=strong
--enable-stackguard-randomization
--enable-static-pie
+ --enable-cet
--disable-profile
--disable-werror
)
diff --git a/bz27343.patch b/bz27343.patch
deleted file mode 100644
index 3db6a9440eb2..000000000000
--- a/bz27343.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From c3479fb7939898ec22c655c383454d6e8b982a67 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Fri, 5 Feb 2021 07:32:18 +0000
-Subject: [PATCH] nsswitch: return result when nss database is locked [BZ
- #27343]
-
-Before the change nss_database_check_reload_and_get() did not populate
-the '*result' value when it returned success in a case of chroot
-detection. This caused initgroups() to use garage pointer in the
-following test (extracted from unbound):
-
-```
-
-int main() {
- // load some NSS modules
- struct passwd * pw = getpwnam("root");
-
- chdir("/tmp");
- chroot("/tmp");
- chdir("/");
- // access nsswitch.conf in a chroot
- initgroups("root", 0);
-}
-```
-
-Reviewed-by: DJ Delorie <dj@redhat.com>
----
- nss/nss_database.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/nss/nss_database.c b/nss/nss_database.c
-index cf0306adc4..e1bef6bd75 100644
---- a/nss/nss_database.c
-+++ b/nss/nss_database.c
-@@ -398,8 +398,9 @@ nss_database_check_reload_and_get (struct nss_database_state *local,
- && (str.st_ino != local->root_ino
- || str.st_dev != local->root_dev)))
- {
-- /* Change detected; disable reloading. */
-+ /* Change detected; disable reloading and return current state. */
- atomic_store_release (&local->data.reload_disabled, 1);
-+ *result = local->data.services[database_index];
- __libc_lock_unlock (local->lock);
- __nss_module_disable_loading ();
- return true;
---
-2.27.0
-