summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2020-08-23 20:45:32 +0200
committerManuel Reimer2020-08-23 20:45:32 +0200
commit61da61a20807dd7e0948f8e5f46958a08dde70fe (patch)
tree3976ea9d233f0a70fc2b73a80c90df766e9d5c41
parent30fb7b64780ce7eca4f2c78505a0e4992ae39b95 (diff)
downloadaur-61da61a20807dd7e0948f8e5f46958a08dde70fe.tar.gz
Update wine-lol-glibc (2.32)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--bz20338.patch114
3 files changed, 6 insertions, 124 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd0e2450b672..a56ff121ebc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-lol-glibc
pkgdesc = GNU C Library patched for wine-lol
- pkgver = 2.31
+ pkgver = 2.32
pkgrel = 1
url = https://www.gnu.org/software/libc
arch = x86_64
@@ -16,11 +16,9 @@ pkgbase = wine-lol-glibc
optdepends = gd: for memusagestat
options = !strip
options = staticlibs
- source = https://ftp.gnu.org/gnu/glibc/glibc-2.31.tar.xz
- source = bz20338.patch
+ source = https://ftp.gnu.org/gnu/glibc/glibc-2.32.tar.xz
source = wine-lol-poc1-glibc.diff::https://bugs.winehq.org/attachment.cgi?id=64482
- md5sums = 78a720f17412f3c3282be5a6f3363ec6
- md5sums = 430673eccc78e52c249aa4b0f1786450
+ md5sums = 720c7992861c57cf97d66a2f36d8d1fa
md5sums = 65e6d204ab9ad787c8dce999c4ba5c17
pkgname = wine-lol-glibc
diff --git a/PKGBUILD b/PKGBUILD
index e61f44c487e5..c6f7d9a4e46c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=wine-lol-glibc
pkgdesc='GNU C Library patched for wine-lol'
-pkgver=2.31
+pkgver=2.32
pkgrel=1
arch=(x86_64)
url='https://www.gnu.org/software/libc'
@@ -19,10 +19,8 @@ options=(!strip staticlibs)
#_commit=067fc32968b601493f4b247a3ac00caeea3f3d61
#source=(git+https://sourceware.org/git/glibc.git#commit=$_commit
source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz
- bz20338.patch
wine-lol-poc1-glibc.diff::https://bugs.winehq.org/attachment.cgi?id=64482)
-md5sums=('78a720f17412f3c3282be5a6f3363ec6'
- '430673eccc78e52c249aa4b0f1786450'
+md5sums=('720c7992861c57cf97d66a2f36d8d1fa'
'65e6d204ab9ad787c8dce999c4ba5c17')
prepare() {
@@ -34,7 +32,7 @@ prepare() {
local i; for i in ${source[@]}; do
case ${i%::*} in
*.patch)
- msg2 "Applying ${i}"
+ echo " -> Applying ${i}"
patch -p1 -i "$srcdir/${i}"
;;
esac
diff --git a/bz20338.patch b/bz20338.patch
deleted file mode 100644
index ddcc3efe4202..000000000000
--- a/bz20338.patch
+++ /dev/null
@@ -1,114 +0,0 @@
-From 74250a7cdf106d4ca7d9506e6d5dc7c448dc3434 Mon Sep 17 00:00:00 2001
-From: David Michael <david.michael@coreos.com>
-Date: Thu, 15 Dec 2016 15:22:57 -0800
-Subject: [PATCH] gshadow: Sync fgetsgent_r.c with grp/fgetgrent_r.c
-
- [BZ #20338]
- * gshadow/fgetsgent_r.c: Include <libio/iolibio.h>.
- (flockfile): New macro.
- (funlockfile): Likewise.
- (__fgetsgent_r): Sync with __fgetgrent_r.
- * nss/nss_files/files-sgrp.c: Fix "fgetsgent_r.c" typo.
----
- gshadow/fgetsgent_r.c | 35 ++++++++++++++++++++++++-----------
- nss/nss_files/files-sgrp.c | 2 +-
- 2 files changed, 25 insertions(+), 12 deletions(-)
-
-diff --git a/gshadow/fgetsgent_r.c b/gshadow/fgetsgent_r.c
-index b70f6fa..02cd33a 100644
---- a/gshadow/fgetsgent_r.c
-+++ b/gshadow/fgetsgent_r.c
-@@ -20,39 +20,44 @@
- #include <gshadow.h>
- #include <stdio.h>
-
-+#include <libio/iolibio.h>
-+#define flockfile(s) _IO_flockfile (s)
-+#define funlockfile(s) _IO_funlockfile (s)
-+
- /* Define a line parsing function using the common code
- used in the nss_files module. */
-
- #define STRUCTURE sgrp
- #define ENTNAME sgent
--#define EXTERN_PARSER 1
-+#define EXTERN_PARSER 1
- struct sgent_data {};
-
- #include <nss/nss_files/files-parse.c>
-
-
--/* Read one shadow entry from the given stream. */
-+/* Read one entry from the given stream. */
- int
- __fgetsgent_r (FILE *stream, struct sgrp *resbuf, char *buffer, size_t buflen,
- struct sgrp **result)
- {
- char *p;
-+ int parse_result;
-
-- _IO_flockfile (stream);
-+ flockfile (stream);
- do
- {
- buffer[buflen - 1] = '\xff';
- p = fgets_unlocked (buffer, buflen, stream);
-- if (p == NULL && feof_unlocked (stream))
-+ if (__builtin_expect (p == NULL, 0) && feof_unlocked (stream))
- {
-- _IO_funlockfile (stream);
-+ funlockfile (stream);
- *result = NULL;
- __set_errno (ENOENT);
- return errno;
- }
-- if (p == NULL || buffer[buflen - 1] != '\xff')
-+ if (__builtin_expect (p == NULL, 0) || buffer[buflen - 1] != '\xff')
- {
-- _IO_funlockfile (stream);
-+ funlockfile (stream);
- *result = NULL;
- __set_errno (ERANGE);
- return errno;
-@@ -61,13 +66,21 @@ __fgetsgent_r (FILE *stream, struct sgrp *resbuf, char *buffer, size_t buflen,
- /* Skip leading blanks. */
- while (isspace (*p))
- ++p;
-- } while (*p == '\0' || *p == '#' /* Ignore empty and comment lines. */
-+ } while (*p == '\0' || *p == '#' /* Ignore empty and comment lines. */
- /* Parse the line. If it is invalid, loop to
- get the next line of the file to parse. */
-- || ! parse_line (buffer, (void *) resbuf, (void *) buffer, buflen,
-- &errno));
-+ || ! (parse_result = parse_line (p, resbuf,
-+ (void *) buffer, buflen,
-+ &errno)));
-+
-+ funlockfile (stream);
-
-- _IO_funlockfile (stream);
-+ if (__builtin_expect (parse_result, 0) == -1)
-+ {
-+ /* The parser ran out of space. */
-+ *result = NULL;
-+ return errno;
-+ }
-
- *result = resbuf;
- return 0;
-diff --git a/nss/nss_files/files-sgrp.c b/nss/nss_files/files-sgrp.c
-index 15dc659..05c3805 100644
---- a/nss/nss_files/files-sgrp.c
-+++ b/nss/nss_files/files-sgrp.c
-@@ -23,7 +23,7 @@
- #define DATABASE "gshadow"
- struct sgent_data {};
-
--/* Our parser function is already defined in sgetspent_r.c, so use that
-+/* Our parser function is already defined in sgetsgent_r.c, so use that
- to parse lines from the database file. */
- #define EXTERN_PARSER
- #include "files-parse.c"
---
-2.7.4
-