summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Reimer2019-05-17 20:46:35 +0200
committerManuel Reimer2019-05-17 20:46:35 +0200
commit8ed7abb3510babd08fef732e2e423889b0708b6e (patch)
tree925d4c339c4b0e493d99d5499de20e931a010896
downloadaur-8ed7abb3510babd08fef732e2e423889b0708b6e.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch194
-rw-r--r--PKGBUILD169
-rw-r--r--bz20338.patch114
-rw-r--r--file-truncated-while-reading-soname-after-patchelf.patch85
5 files changed, 593 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..494fb65e319d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = wine-lol-glibc
+ pkgdesc = GNU C Library patched for wine-lol
+ pkgver = 2.29
+ pkgrel = 1
+ url = https://www.gnu.org/software/libc
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = git
+ makedepends = gd
+ makedepends = lib32-gcc-libs
+ makedepends = python
+ depends = linux-api-headers>=4.10
+ depends = tzdata
+ depends = filesystem
+ optdepends = gd: for memusagestat
+ options = !strip
+ options = staticlibs
+ source = https://ftp.gnu.org/gnu/glibc/glibc-2.29.tar.xz
+ source = bz20338.patch
+ source = 0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
+ source = file-truncated-while-reading-soname-after-patchelf.patch
+ source = wine-lol-poc1-glibc.diff::https://bugs.winehq.org/attachment.cgi?id=64482
+ md5sums = e6c279d5b2f0736f740216f152acf974
+ md5sums = dc0d3ad59aeaaf591b085a77de6e03e9
+ md5sums = af5d3c5227ac639effe39667a43879a1
+ md5sums = 0820504d2e83ee15f74a656771361872
+ md5sums = 65e6d204ab9ad787c8dce999c4ba5c17
+
+pkgname = wine-lol-glibc
+
diff --git a/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
new file mode 100644
index 000000000000..ba9b874f3617
--- /dev/null
+++ b/0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
@@ -0,0 +1,194 @@
+From 2cbf10ae2ea9e378ff91b8f5c4d8cb77ed05378e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bart=C5=82omiej=20Piotrowski?= <bpiotrowski@archlinux.org>
+Date: Fri, 10 Aug 2018-2019 14:12:40 +0000
+Subject: [PATCH] Revert "elf: Correct absolute (SHN_ABS) symbol run-time
+ calculation [BZ #19818]"
+
+This reverts commit e7feec374c635b6a29d65c39ae5e1855528fed39.
+---
+ elf/Makefile | 14 ++-----------
+ elf/dl-addr.c | 2 --
+ elf/tst-absolute-sym-lib.c | 25 ------------------------
+ elf/tst-absolute-sym-lib.lds | 19 ------------------
+ elf/tst-absolute-sym.c | 38 ------------------------------------
+ sysdeps/generic/ldsodefs.h | 3 +--
+ 6 files changed, 3 insertions(+), 98 deletions(-)
+ delete mode 100644 elf/tst-absolute-sym-lib.c
+ delete mode 100644 elf/tst-absolute-sym-lib.lds
+ delete mode 100644 elf/tst-absolute-sym.c
+
+diff --git a/elf/Makefile b/elf/Makefile
+index cd0771307f..5084ba4f6f 100644
+--- a/elf/Makefile
++++ b/elf/Makefile
+@@ -186,7 +186,7 @@ tests += restest1 preloadtest loadfail multiload origtest resolvfail \
+ tst-tlsalign tst-tlsalign-extern tst-nodelete-opened \
+ tst-nodelete2 tst-audit11 tst-audit12 tst-dlsym-error tst-noload \
+ tst-latepthread tst-tls-manydynamic tst-nodelete-dlclose \
+- tst-debug1 tst-main1 tst-absolute-sym tst-absolute-zero tst-big-note \
++ tst-debug1 tst-main1 \
+ tst-unwind-ctor tst-unwind-main
+ # reldep9
+ tests-internal += loadtest unload unload2 circleload1 \
+@@ -272,8 +272,7 @@ modules-names = testobj1 testobj2 testobj3 testobj4 testobj5 testobj6 \
+ tst-audit12mod1 tst-audit12mod2 tst-audit12mod3 tst-auditmod12 \
+ tst-latepthreadmod $(tst-tls-many-dynamic-modules) \
+ tst-nodelete-dlclose-dso tst-nodelete-dlclose-plugin \
+- tst-main1mod tst-libc_dlvsym-dso tst-absolute-sym-lib \
+- tst-absolute-zero-lib tst-big-note-lib tst-unwind-ctor-lib
++ tst-main1mod tst-libc_dlvsym-dso tst-unwind-ctor-lib
+ # Most modules build with _ISOMAC defined, but those filtered out
+ # depend on internal headers.
+ modules-names-tests = $(filter-out ifuncmod% tst-libc_dlvsym-dso tst-tlsmod%,\
+@@ -1465,14 +1463,6 @@ tst-main1-no-pie = yes
+ LDLIBS-tst-main1 = $(libsupport)
+ tst-main1mod.so-no-z-defs = yes
+
+-LDLIBS-tst-absolute-sym-lib.so = tst-absolute-sym-lib.lds
+-$(objpfx)tst-absolute-sym-lib.so: $(LDLIBS-tst-absolute-sym-lib.so)
+-$(objpfx)tst-absolute-sym: $(objpfx)tst-absolute-sym-lib.so
+-
+-LDLIBS-tst-absolute-zero-lib.so = tst-absolute-zero-lib.lds
+-$(objpfx)tst-absolute-zero-lib.so: $(LDLIBS-tst-absolute-zero-lib.so)
+-$(objpfx)tst-absolute-zero: $(objpfx)tst-absolute-zero-lib.so
+-
+ # Both the main program and the DSO for tst-libc_dlvsym need to link
+ # against libdl.
+ $(objpfx)tst-libc_dlvsym: $(libdl)
+diff --git a/elf/dl-addr.c b/elf/dl-addr.c
+index e6c7d02094..2250617a73 100644
+--- a/elf/dl-addr.c
++++ b/elf/dl-addr.c
+@@ -59,7 +59,6 @@ determine_info (const ElfW(Addr) addr, struct link_map *match, Dl_info *info,
+ we can omit that test here. */
+ if ((symtab[symndx].st_shndx != SHN_UNDEF
+ || symtab[symndx].st_value != 0)
+- && symtab[symndx].st_shndx != SHN_ABS
+ && ELFW(ST_TYPE) (symtab[symndx].st_info) != STT_TLS
+ && DL_ADDR_SYM_MATCH (match, &symtab[symndx],
+ matchsym, addr)
+@@ -92,7 +91,6 @@ determine_info (const ElfW(Addr) addr, struct link_map *match, Dl_info *info,
+ && ELFW(ST_TYPE) (symtab->st_info) != STT_TLS
+ && (symtab->st_shndx != SHN_UNDEF
+ || symtab->st_value != 0)
+- && symtab->st_shndx != SHN_ABS
+ && DL_ADDR_SYM_MATCH (match, symtab, matchsym, addr)
+ && symtab->st_name < strtabsize)
+ matchsym = (ElfW(Sym) *) symtab;
+diff --git a/elf/tst-absolute-sym-lib.c b/elf/tst-absolute-sym-lib.c
+deleted file mode 100644
+index 912cb0048a..0000000000
+--- a/elf/tst-absolute-sym-lib.c
++++ /dev/null
+@@ -1,25 +0,0 @@
+-/* BZ #19818 absolute symbol calculation shared module.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
+- This file is part of the GNU C Library.
+-
+- The GNU C Library is free software; you can redistribute it and/or
+- modify it under the terms of the GNU Lesser General Public
+- License as published by the Free Software Foundation; either
+- version 2.1 of the License, or (at your option) any later version.
+-
+- The GNU C Library is distributed in the hope that it will be useful,
+- but WITHOUT ANY WARRANTY; without even the implied warranty of
+- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+- Lesser General Public License for more details.
+-
+- You should have received a copy of the GNU Lesser General Public
+- License along with the GNU C Library; if not, see
+- <http://www.gnu.org/licenses/>. */
+-
+-extern char absolute;
+-
+-void *
+-get_absolute (void)
+-{
+- return &absolute;
+-}
+diff --git a/elf/tst-absolute-sym-lib.lds b/elf/tst-absolute-sym-lib.lds
+deleted file mode 100644
+index d4a4128514..0000000000
+--- a/elf/tst-absolute-sym-lib.lds
++++ /dev/null
+@@ -1,19 +0,0 @@
+-/* BZ #19818 absolute symbol calculation linker script.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
+- This file is part of the GNU C Library.
+-
+- The GNU C Library is free software; you can redistribute it and/or
+- modify it under the terms of the GNU Lesser General Public
+- License as published by the Free Software Foundation; either
+- version 2.1 of the License, or (at your option) any later version.
+-
+- The GNU C Library is distributed in the hope that it will be useful,
+- but WITHOUT ANY WARRANTY; without even the implied warranty of
+- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+- Lesser General Public License for more details.
+-
+- You should have received a copy of the GNU Lesser General Public
+- License along with the GNU C Library; if not, see
+- <http://www.gnu.org/licenses/>. */
+-
+-"absolute" = 0x55aa;
+diff --git a/elf/tst-absolute-sym.c b/elf/tst-absolute-sym.c
+deleted file mode 100644
+index 111491d159..0000000000
+--- a/elf/tst-absolute-sym.c
++++ /dev/null
+@@ -1,38 +0,0 @@
+-/* BZ #19818 absolute symbol calculation main executable.
+- Copyright (C) 2018-2019 Free Software Foundation, Inc.
+- This file is part of the GNU C Library.
+-
+- The GNU C Library is free software; you can redistribute it and/or
+- modify it under the terms of the GNU Lesser General Public
+- License as published by the Free Software Foundation; either
+- version 2.1 of the License, or (at your option) any later version.
+-
+- The GNU C Library is distributed in the hope that it will be useful,
+- but WITHOUT ANY WARRANTY; without even the implied warranty of
+- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+- Lesser General Public License for more details.
+-
+- You should have received a copy of the GNU Lesser General Public
+- License along with the GNU C Library; if not, see
+- <http://www.gnu.org/licenses/>. */
+-
+-#include <support/check.h>
+-#include <support/support.h>
+-#include <support/test-driver.h>
+-
+-void *get_absolute (void);
+-
+-static int
+-do_test (void)
+-{
+- void *ref = (void *) 0x55aa;
+- void *ptr;
+-
+- ptr = get_absolute ();
+- if (ptr != ref)
+- FAIL_EXIT1 ("Got %p, expected %p\n", ptr, ref);
+-
+- return 0;
+-}
+-
+-#include <support/test-driver.c>
+diff --git a/sysdeps/generic/ldsodefs.h b/sysdeps/generic/ldsodefs.h
+index 95dc87519b..3cac4fa362 100644
+--- a/sysdeps/generic/ldsodefs.h
++++ b/sysdeps/generic/ldsodefs.h
+@@ -72,8 +72,7 @@ typedef struct link_map *lookup_t;
+ if non-NULL. Don't check for NULL map if MAP_SET is TRUE. */
+ #define SYMBOL_ADDRESS(map, ref, map_set) \
+ ((ref) == NULL ? 0 \
+- : (__glibc_unlikely ((ref)->st_shndx == SHN_ABS) ? 0 \
+- : LOOKUP_VALUE_ADDRESS (map, map_set)) + (ref)->st_value)
++ : LOOKUP_VALUE_ADDRESS (map, map_set) + (ref)->st_value)
+
+ /* On some architectures a pointer to a function is not just a pointer
+ to the actual code of the function but rather an architecture
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02ff5252476d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,169 @@
+# -*- mode: shell-script -*-
+# Maintainer: Manuel Reimer <mail+wine@m-reimer.de>
+
+# This PKGBUILD builds a glibc with a "hack" required to run League Of Legends
+# with wine-staging (wine-lol)
+# See: https://bugs.winehq.org/show_bug.cgi?id=47198#c17
+
+pkgname=wine-lol-glibc
+pkgdesc='GNU C Library patched for wine-lol'
+pkgver=2.29
+pkgrel=1
+arch=(x86_64)
+url='https://www.gnu.org/software/libc'
+license=(GPL LGPL)
+makedepends=(git gd lib32-gcc-libs python)
+depends=('linux-api-headers>=4.10' tzdata filesystem)
+optdepends=('gd: for memusagestat')
+options=(!strip staticlibs)
+#_commit=067fc32968b601493f4b247a3ac00caeea3f3d61
+#source=(git+https://sourceware.org/git/glibc.git#commit=$_commit
+source=(https://ftp.gnu.org/gnu/glibc/glibc-$pkgver.tar.xz
+ bz20338.patch
+ 0001-Revert-elf-Correct-absolute-SHN_ABS-symbol-run-time-.patch
+ file-truncated-while-reading-soname-after-patchelf.patch
+ wine-lol-poc1-glibc.diff::https://bugs.winehq.org/attachment.cgi?id=64482)
+md5sums=('e6c279d5b2f0736f740216f152acf974'
+ 'dc0d3ad59aeaaf591b085a77de6e03e9'
+ 'af5d3c5227ac639effe39667a43879a1'
+ '0820504d2e83ee15f74a656771361872'
+ '65e6d204ab9ad787c8dce999c4ba5c17')
+
+prepare() {
+ mkdir -p glibc-build lib32-glibc-build
+
+ [[ -d glibc-$pkgver ]] && ln -s glibc-$pkgver glibc
+ cd glibc
+
+ local i; for i in ${source[@]}; do
+ case ${i%::*} in
+ *.patch)
+ msg2 "Applying ${i}"
+ patch -p1 -i "$srcdir/${i}"
+ ;;
+ esac
+ done
+
+ # Add wine-lol glibc hack
+ patch -p1 -i "$srcdir/wine-lol-poc1-glibc.diff"
+}
+
+build() {
+ local _configure_flags=(
+ --prefix=/usr/wine-lol-glibc
+ --sysconfdir=/etc
+ --datarootdir=/usr/share
+ --with-headers=/usr/include
+ --with-bugurl=https://bugs.archlinux.org/
+ --enable-add-ons
+ --enable-bind-now
+ --enable-lock-elision
+ --enable-multi-arch
+ --enable-stack-protector=strong
+ --enable-stackguard-randomization
+ --enable-static-pie
+ --disable-profile
+ --disable-werror
+ )
+
+ cd "$srcdir/glibc-build"
+
+ echo "slibdir=/usr/wine-lol-glibc/lib" >> configparms
+ echo "rtlddir=/usr/wine-lol-glibc/lib" >> configparms
+ echo "sbindir=/usr/wine-lol-glibc/bin" >> configparms
+ echo "rootsbindir=/usr/wine-lol-glibc/bin" >> configparms
+
+ # remove fortify for building libraries
+ CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
+
+ "$srcdir/glibc/configure" \
+ --libdir=/usr/wine-lol-glibc/lib \
+ --libexecdir=/usr/wine-lol-glibc/lib \
+ --enable-cet \
+ ${_configure_flags[@]}
+
+ # build libraries with fortify disabled
+ echo "build-programs=no" >> configparms
+ make
+
+ # re-enable fortify for programs
+ sed -i "/build-programs=/s#no#yes#" configparms
+
+ echo "CC += -D_FORTIFY_SOURCE=2" >> configparms
+ echo "CXX += -D_FORTIFY_SOURCE=2" >> configparms
+ make
+
+ cd "$srcdir/lib32-glibc-build"
+ export CC="gcc -m32 -mstackrealign"
+ export CXX="g++ -m32 -mstackrealign"
+
+ echo "slibdir=/usr/wine-lol-glibc/lib32" >> configparms
+ echo "rtlddir=/usr/wine-lol-glibc/lib32" >> configparms
+ echo "sbindir=/usr/wine-lol-glibc/bin" >> configparms
+ echo "rootsbindir=/usr/wine-lol-glibc/bin" >> configparms
+
+ # remove fortify for building libraries
+ CPPFLAGS=${CPPFLAGS/-D_FORTIFY_SOURCE=2/}
+ CFLAGS=${CFLAGS/-fno-plt/}
+ CXXFLAGS=${CXXFLAGS/-fno-plt/}
+
+ "$srcdir/glibc/configure" \
+ --host=i686-pc-linux-gnu \
+ --libdir=/usr/wine-lol-glibc/lib32 \
+ --libexecdir=/usr/wine-lol-glibc/lib32 \
+ ${_configure_flags[@]}
+
+ # build libraries with fortify disabled
+ echo "build-programs=no" >> configparms
+ make
+
+ # re-enable fortify for programs
+ sed -i "/build-programs=/s#no#yes#" configparms
+
+ echo "CC += -D_FORTIFY_SOURCE=2" >> configparms
+ echo "CXX += -D_FORTIFY_SOURCE=2" >> configparms
+ make
+}
+
+package() {
+ make -C glibc-build install_root="$pkgdir" install
+
+ cd glibc
+
+ if check_option 'debug' n; then
+ find "$pkgdir"/usr/wine-lol-glibc/lib -name '*.a' -type f -exec strip $STRIP_STATIC {} + 2> /dev/null || true
+
+ # Do not strip these for gdb and valgrind functionality, but strip the rest
+ find "$pkgdir"/usr/wine-lol-glibc/lib \
+ -not -name 'ld-*.so' \
+ -not -name 'libc-*.so' \
+ -not -name 'libpthread-*.so' \
+ -not -name 'libthread_db-*.so' \
+ -name '*-*.so' -type f -exec strip $STRIP_SHARED {} + 2> /dev/null || true
+ fi
+
+
+
+ cd ../lib32-glibc-build
+
+ make install_root="$pkgdir" install
+
+ # Dynamic linker
+ install -d "$pkgdir/usr/wine-lol-glibc/lib"
+ ln -s ../lib32/ld-linux.so.2 "$pkgdir/usr/wine-lol-glibc/lib/"
+
+ if check_option 'debug' n; then
+ find "$pkgdir"/usr/wine-lol-glibc/lib32 -name '*.a' -type f -exec strip $STRIP_STATIC {} + 2> /dev/null || true
+ find "$pkgdir"/usr/wine-lol-glibc/lib32 \
+ -not -name 'ld-*.so' \
+ -not -name 'libc-*.so' \
+ -not -name 'libpthread-*.so' \
+ -not -name 'libthread_db-*.so' \
+ -name '*-*.so' -type f -exec strip $STRIP_SHARED {} + 2> /dev/null || true
+ fi
+
+ # These have been installed to the same location as the files in the
+ # "system glibc" intentionally to make our glibc use the system files.
+ rm -r "$pkgdir/usr/share"
+ rm -r "$pkgdir/etc"
+}
diff --git a/bz20338.patch b/bz20338.patch
new file mode 100644
index 000000000000..d223e9f08882
--- /dev/null
+++ b/bz20338.patch
@@ -0,0 +1,114 @@
+From 74250a7cdf106d4ca7d9506e6d5dc7c448dc3434 Mon Sep 17 00:00:00 2001
+From: David Michael <david.michael@coreos.com>
+Date: Thu, 15 Dec 2016 15:22:57 -0800
+Subject: [PATCH] gshadow: Sync fgetsgent_r.c with grp/fgetgrent_r.c
+
+ [BZ #20338]
+ * gshadow/fgetsgent_r.c: Include <libio/iolibio.h>.
+ (flockfile): New macro.
+ (funlockfile): Likewise.
+ (__fgetsgent_r): Sync with __fgetgrent_r.
+ * nss/nss_files/files-sgrp.c: Fix "fgetsgent_r.c" typo.
+---
+ gshadow/fgetsgent_r.c | 35 ++++++++++++++++++++++++-----------
+ nss/nss_files/files-sgrp.c | 2 +-
+ 2 files changed, 25 insertions(+), 12 deletions(-)
+
+diff --git a/gshadow/fgetsgent_r.c b/gshadow/fgetsgent_r.c
+index b70f6fa..02cd33a 100644
+--- a/gshadow/fgetsgent_r.c
++++ b/gshadow/fgetsgent_r.c
+@@ -20,39 +20,44 @@
+ #include <gshadow.h>
+ #include <stdio.h>
+
++#include <libio/iolibio.h>
++#define flockfile(s) _IO_flockfile (s)
++#define funlockfile(s) _IO_funlockfile (s)
++
+ /* Define a line parsing function using the common code
+ used in the nss_files module. */
+
+ #define STRUCTURE sgrp
+ #define ENTNAME sgent
+-#define EXTERN_PARSER 1
++#define EXTERN_PARSER 1
+ struct sgent_data {};
+
+ #include <nss/nss_files/files-parse.c>
+
+
+-/* Read one shadow entry from the given stream. */
++/* Read one entry from the given stream. */
+ int
+ __fgetsgent_r (FILE *stream, struct sgrp *resbuf, char *buffer, size_t buflen,
+ struct sgrp **result)
+ {
+ char *p;
++ int parse_result;
+
+- _IO_flockfile (stream);
++ flockfile (stream);
+ do
+ {
+ buffer[buflen - 1] = '\xff';
+ p = fgets_unlocked (buffer, buflen, stream);
+- if (p == NULL && feof_unlocked (stream))
++ if (__builtin_expect (p == NULL, 0) && feof_unlocked (stream))
+ {
+- _IO_funlockfile (stream);
++ funlockfile (stream);
+ *result = NULL;
+ __set_errno (ENOENT);
+ return errno;
+ }
+- if (p == NULL || buffer[buflen - 1] != '\xff')
++ if (__builtin_expect (p == NULL, 0) || buffer[buflen - 1] != '\xff')
+ {
+- _IO_funlockfile (stream);
++ funlockfile (stream);
+ *result = NULL;
+ __set_errno (ERANGE);
+ return errno;
+@@ -61,13 +66,21 @@ __fgetsgent_r (FILE *stream, struct sgrp *resbuf, char *buffer, size_t buflen,
+ /* Skip leading blanks. */
+ while (isspace (*p))
+ ++p;
+- } while (*p == '\0' || *p == '#' || /* Ignore empty and comment lines. */
++ } while (*p == '\0' || *p == '#' /* Ignore empty and comment lines. */
+ /* Parse the line. If it is invalid, loop to
+ get the next line of the file to parse. */
+- ! parse_line (buffer, (void *) resbuf, (void *) buffer, buflen,
+- &errno));
++ || ! (parse_result = parse_line (p, resbuf,
++ (void *) buffer, buflen,
++ &errno)));
++
++ funlockfile (stream);
+
+- _IO_funlockfile (stream);
++ if (__builtin_expect (parse_result, 0) == -1)
++ {
++ /* The parser ran out of space. */
++ *result = NULL;
++ return errno;
++ }
+
+ *result = resbuf;
+ return 0;
+diff --git a/nss/nss_files/files-sgrp.c b/nss/nss_files/files-sgrp.c
+index 15dc659..05c3805 100644
+--- a/nss/nss_files/files-sgrp.c
++++ b/nss/nss_files/files-sgrp.c
+@@ -23,7 +23,7 @@
+ #define DATABASE "gshadow"
+ struct sgent_data {};
+
+-/* Our parser function is already defined in sgetspent_r.c, so use that
++/* Our parser function is already defined in sgetsgent_r.c, so use that
+ to parse lines from the database file. */
+ #define EXTERN_PARSER
+ #include "files-parse.c"
+--
+2.7.4
+
diff --git a/file-truncated-while-reading-soname-after-patchelf.patch b/file-truncated-while-reading-soname-after-patchelf.patch
new file mode 100644
index 000000000000..4c21284bf0b0
--- /dev/null
+++ b/file-truncated-while-reading-soname-after-patchelf.patch
@@ -0,0 +1,85 @@
+[PATCH] ldconfig: file truncated while reading soname after patchelf [BZ #23964]
+
+The way loadaddr is computed from the first LOAD segment in process_elf_file
+assumes .dynstr is also contained in that segment. That is not necessarily
+true, especially for libraries that have been touched by patchelf.
+
+With this patch, the address read from the dynamic segment is checked against
+all applicable segments instead of only the first one.
+
+ [BZ #23964]
+ * elf/readelflib.c: Fix resolving of loadaddr for .dynstr vaddr.
+---
+ elf/readelflib.c | 33 ++++++++++++++++-----------------
+ 1 file changed, 16 insertions(+), 17 deletions(-)
+
+diff --git a/elf/readelflib.c b/elf/readelflib.c
+index 5a1e2dc2df..bc1195c175 100644
+--- a/elf/readelflib.c
++++ b/elf/readelflib.c
+@@ -98,11 +98,6 @@ process_elf_file (const char *file_name, const char *lib, int *flag,
+
+ switch (segment->p_type)
+ {
+- case PT_LOAD:
+- if (loadaddr == (ElfW(Addr)) -1)
+- loadaddr = segment->p_vaddr - segment->p_offset;
+- break;
+-
+ case PT_DYNAMIC:
+ if (dynamic_addr)
+ error (0, 0, _("more than one dynamic segment\n"));
+@@ -176,11 +171,6 @@ process_elf_file (const char *file_name, const char *lib, int *flag,
+ }
+
+ }
+- if (loadaddr == (ElfW(Addr)) -1)
+- {
+- /* Very strange. */
+- loadaddr = 0;
+- }
+
+ /* Now we can read the dynamic sections. */
+ if (dynamic_size == 0)
+@@ -190,22 +180,31 @@ process_elf_file (const char *file_name, const char *lib, int *flag,
+ check_ptr (dynamic_segment);
+
+ /* Find the string table. */
+- dynamic_strings = NULL;
+ for (dyn_entry = dynamic_segment; dyn_entry->d_tag != DT_NULL;
+ ++dyn_entry)
+ {
+ check_ptr (dyn_entry);
+ if (dyn_entry->d_tag == DT_STRTAB)
+- {
+- dynamic_strings = (char *) (file_contents + dyn_entry->d_un.d_val - loadaddr);
+- check_ptr (dynamic_strings);
+- break;
+- }
++ break;
+ }
+
+- if (dynamic_strings == NULL)
++ for (i = 0, segment = elf_pheader;i < elf_header->e_phnum; i++, segment++)
++ {
++ ElfW(Addr) vaddr = dyn_entry->d_un.d_ptr;
++ if (segment->p_type == PT_LOAD &&
++ vaddr >= segment->p_vaddr &&
++ vaddr < segment->p_vaddr + segment->p_filesz)
++ {
++ loadaddr = segment->p_vaddr - segment->p_offset;
++ break;
++ }
++ }
++ if (loadaddr == (ElfW(Addr)) -1)
+ return 1;
+
++ dynamic_strings = (char *) (file_contents + dyn_entry->d_un.d_val - loadaddr);
++ check_ptr (dynamic_strings);
++
+ /* Now read the DT_NEEDED and DT_SONAME entries. */
+ for (dyn_entry = dynamic_segment; dyn_entry->d_tag != DT_NULL;
+ ++dyn_entry)
+--
+2.19.2
+