summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormoonshadow5652023-04-15 22:03:45 +0200
committermoonshadow5652023-04-15 22:03:45 +0200
commit0d6d1ddd1a72506cf5765b5fe2bf12dc40a37e50 (patch)
tree1b21806b2a286fb0658d865b16bd7213db6f5f42
parent2bad5adda012de04a04fc40136de493d1f576b90 (diff)
downloadaur-0d6d1ddd1a72506cf5765b5fe2bf12dc40a37e50.tar.gz
Remove some no longer needed patches
-rw-r--r--.SRCINFO7
-rw-r--r--0007-ntdll-stub-NtSetInformationThread-ThreadPriority.patch18
-rw-r--r--0009-kernel32-dont-create-console-when-not-cui.patch20
-rw-r--r--PKGBUILD24
-rw-r--r--wine-lol-staging.install0
5 files changed, 35 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89b390c4a9ed..eccff8e97ae1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = wine-lol-staging
pkgdesc = A compatibility layer for running Windows programs (staging branch) with LoL patches(abi.vsyscall32=0 version)
pkgver = 8.5
- pkgrel = 2
+ pkgrel = 3
url = https://www.wine-staging.com/
- install = wine-lol-staging.install
arch = x86_64
license = LGPL
makedepends = git
@@ -116,13 +115,13 @@ pkgbase = wine-lol-staging
source = git+https://github.com/wine-mirror/wine.git#tag=wine-8.5
source = 0004-LoL-broken-client-update-fix.patch
source = 0005-LoL-client-slow-start-fix.patch
- source = 0007-ntdll-stub-NtSetInformationThread-ThreadPriority.patch
source = 0008-ntdll-nopguard-call_vectored_handlers.patch
+ source = 0009-kernel32-dont-create-console-when-not-cui.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 7607a84fd357a86bc8fb59d2cf002a3e471bd8ec78ecdb844b0b77b1ae6d11a0
sha256sums = 49dfbf7546c00958e2b426a61371eedf0119471e9998b354595d5c0ce6dab48b
- sha256sums = fc4fba4db2f691e3686fa84dd81935f0eb183d7c5c1215aba33a575b42b38cb5
sha256sums = 2075ddc417ddd11954f76be753c88e04db28f0b3937e60508f178630dd5763eb
+ sha256sums = b19443ba1e01014ab478b03ac84797df2d481432798259371d94e4ba2e7b317c
pkgname = wine-lol-staging
diff --git a/0007-ntdll-stub-NtSetInformationThread-ThreadPriority.patch b/0007-ntdll-stub-NtSetInformationThread-ThreadPriority.patch
deleted file mode 100644
index dbaa2235bc1e..000000000000
--- a/0007-ntdll-stub-NtSetInformationThread-ThreadPriority.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/dlls/ntdll/unix/thread.c b/dlls/ntdll/unix/thread.c
-index d56962e1721..87fdf2634b9 100644
---- a/dlls/ntdll/unix/thread.c
-+++ b/dlls/ntdll/unix/thread.c
-@@ -2402,9 +2402,12 @@ NTSTATUS WINAPI NtSetInformationThread( HANDLE handle, THREADINFOCLASS class,
- WARN("Unimplemented class ThreadPriorityBoost.\n");
- return STATUS_SUCCESS;
-
-+ case ThreadPriority:
-+ WARN("Unimplemented ThreadPriority\n");
-+ return STATUS_SUCCESS;
-+
- case ThreadBasicInformation:
- case ThreadTimes:
-- case ThreadPriority:
- case ThreadDescriptorTableEntry:
- case ThreadEventPair_Reusable:
- case ThreadPerformanceCount:
diff --git a/0009-kernel32-dont-create-console-when-not-cui.patch b/0009-kernel32-dont-create-console-when-not-cui.patch
new file mode 100644
index 000000000000..e034e84c5bd8
--- /dev/null
+++ b/0009-kernel32-dont-create-console-when-not-cui.patch
@@ -0,0 +1,20 @@
+diff --git a/dlls/kernelbase/console.c b/dlls/kernelbase/console.c
+index fa143857bc2..aa37d92ef70 100644
+--- a/dlls/kernelbase/console.c
++++ b/dlls/kernelbase/console.c
+@@ -2342,6 +2342,13 @@ void init_console( void )
+ if (RtlImageNtHeader( mod )->OptionalHeader.Subsystem == IMAGE_SUBSYSTEM_WINDOWS_CUI)
+ alloc_console( no_window );
+ }
+- else if (params->ConsoleHandle && params->ConsoleHandle != CONSOLE_HANDLE_SHELL_NO_WINDOW)
+- create_console_connection( params->ConsoleHandle );
++ else if (params->ConsoleHandle)
++ {
++ HMODULE mod = GetModuleHandleW( NULL );
++ if (params->ConsoleHandle != CONSOLE_HANDLE_SHELL_NO_WINDOW &&
++ RtlImageNtHeader( mod )->OptionalHeader.Subsystem == IMAGE_SUBSYSTEM_WINDOWS_CUI)
++ create_console_connection( params->ConsoleHandle );
++ else
++ params->ConsoleHandle = NULL;
++ }
+ }
diff --git a/PKGBUILD b/PKGBUILD
index 0b307ebcd6ca..0b59f2017d63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: moonshadow565 <moonshadow565@hotmail.com>
+# Maintainer: Kuan-Yen Chou <kuanyenchou@gmail.com>
pkgname=wine-lol-staging
pkgver=8.5
_winever=8.5
-pkgrel=2
+pkgrel=3
pkgdesc='A compatibility layer for running Windows programs (staging branch) with LoL patches(abi.vsyscall32=0 version)'
arch=('x86_64')
url='https://www.wine-staging.com/'
license=('LGPL')
provides=('wine-lol')
-install=wine-lol-staging.install
options=('staticlibs' '!lto' '!strip')
@@ -17,16 +17,16 @@ source=("git+https://github.com/wine-staging/wine-staging.git#tag=v${_winever}"
"git+https://github.com/wine-mirror/wine.git#tag=wine-${_winever}"
"0004-LoL-broken-client-update-fix.patch"
"0005-LoL-client-slow-start-fix.patch"
- "0007-ntdll-stub-NtSetInformationThread-ThreadPriority.patch"
"0008-ntdll-nopguard-call_vectored_handlers.patch"
+ "0009-kernel32-dont-create-console-when-not-cui.patch"
)
sha256sums=('SKIP'
'SKIP'
'7607a84fd357a86bc8fb59d2cf002a3e471bd8ec78ecdb844b0b77b1ae6d11a0'
'49dfbf7546c00958e2b426a61371eedf0119471e9998b354595d5c0ce6dab48b'
- 'fc4fba4db2f691e3686fa84dd81935f0eb183d7c5c1215aba33a575b42b38cb5'
'2075ddc417ddd11954f76be753c88e04db28f0b3937e60508f178630dd5763eb'
+ 'b19443ba1e01014ab478b03ac84797df2d481432798259371d94e4ba2e7b317c'
)
depends=(
@@ -103,28 +103,28 @@ prepare() {
git -C wine config --local advice.detachedHead false
git -C wine checkout wine-${_winever}
- # apply all wine-staging patches
+ # RCS Launcher Optional, not necessary since 64bit update as only thing useful there is missing fonts patch
printf '%s\n' ' -> Applying wine-staging patches...'
cd "${srcdir}/wine"
"${srcdir}/wine-staging/staging/patchinstall.py" --all
cd "${srcdir}/wine"
- # Something with resolving long paths and symlinks, might not be needed if you keep your install in sane place ???
+ # RCS Launcher, Something with resolving long paths and symlinks, needed confirmed 8.5
printf 'Apply 0004-LoL-broken-client-update-fix\n'
patch -Np1 < "${srcdir}/0004-LoL-broken-client-update-fix.patch"
- # Hack for league to start in reasonable time
+ # LCU Launcher, Hack for league to start in reasonable time
printf 'Apply 0005-LoL-client-slow-start-fix.patch\n'
patch -Np1 < "${srcdir}/0005-LoL-client-slow-start-fix.patch"
- # Properly stub ThreadPriority for NtSetInformationThread
- printf 'Apply 0007-ntdll-stub-NtSetInformationThread-ThreadPriority.patch\n'
- patch -Np1 < "${srcdir}/0007-ntdll-stub-NtSetInformationThread-ThreadPriority.patch"
-
- # Add some nops around exception dispatch for pacman/stub.dll to be able to hook
+ # Game, Add some nops around exception dispatch for pacman/stub.dll to be able to hook
printf 'Apply 0008-ntdll-nopguard-call_vectored_handlers.patch\n'
patch -Np1 < "${srcdir}/0008-ntdll-nopguard-call_vectored_handlers.patch"
+
+ # Game Optional, only necessary when starting LoL.exe wine manually (e.g. when running .rofl files)
+ printf 'Apply 0009-kernel32-dont-create-console-when-not-cui.patch\n'
+ patch -Np1 < "${srcdir}/0009-kernel32-dont-create-console-when-not-cui.patch"
}
build() {
diff --git a/wine-lol-staging.install b/wine-lol-staging.install
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/wine-lol-staging.install
+++ /dev/null