summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormoonshadow5652022-07-16 14:06:54 +0200
committermoonshadow5652022-07-16 14:06:54 +0200
commit827ce3787b167b1555ae794126803e1c64e7dfea (patch)
treeb83b8371ca63243513eb5ec5ba383658bf248e01
parent5de510425d22afc6becf7769b249cf6a3c96cbd3 (diff)
downloadaur-827ce3787b167b1555ae794126803e1c64e7dfea.tar.gz
update slow start patch for starting without RiotClientServices GUI
-rw-r--r--0005-LoL-client-slow-start-fix.patch2
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 2 deletions
diff --git a/0005-LoL-client-slow-start-fix.patch b/0005-LoL-client-slow-start-fix.patch
index 9758837ea3fa..77c905ca273a 100644
--- a/0005-LoL-client-slow-start-fix.patch
+++ b/0005-LoL-client-slow-start-fix.patch
@@ -12,7 +12,7 @@ index 3d0c2deca35..b0c03d992d4 100644
+ }
+ const struct timeval zero_tv = { 0, 1000 };
+ if (is_RCS && read_ptr && write_ptr && except_ptr && timeout && timeout->tv_sec == 1 && timeout->tv_usec == 0) {
-+ if (read_ptr->fd_count == 8 && write_ptr->fd_count == 0 && except_ptr->fd_count == 1) {
++ if (read_ptr->fd_count >= 4 && read_ptr->fd_count <= 8 && write_ptr->fd_count == 0 && except_ptr->fd_count == 1) {
+ timeout = &zero_tv;
+ }
+ }
diff --git a/PKGBUILD b/PKGBUILD
index a7262d8c02d4..8ab2db24651d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ sha256sums=('SKIP'
'c127907db75cd8575da27198c8f46aa19dd2a219324e7491761f206f3ce91601'
'c2cb9265567dfe8c9f148e237910792cad7666d9d3cbf68d8717076030cddc92'
'0c5b97c64fd4983119db8675f0686e26143898de1566c4da46d5df74cb98cfb2'
- 'ad03a922191069774757f9f8b12c6eb9b87bbcf16da7b290adb9176fbcaa4ba8'
+ '49dfbf7546c00958e2b426a61371eedf0119471e9998b354595d5c0ce6dab48b'
)
depends=(