summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormoonshadow5652023-01-20 21:15:39 +0100
committermoonshadow5652023-01-20 21:15:39 +0100
commit8aac92044936a8b962faaea926906d4f48d44542 (patch)
tree611bf72e871996c698724ce65a6be7f90e1fafaa
parent366fcfccaf4736fa4eeb4e72b2135c44852e236d (diff)
downloadaur-8aac92044936a8b962faaea926906d4f48d44542.tar.gz
update 8.0-rc4
-rw-r--r--.SRCINFO8
-rw-r--r--0004-LoL-broken-client-update-fix.patch14
-rw-r--r--PKGBUILD9
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dcd8751eecb..8262880fd719 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-lol-staging
pkgdesc = A compatibility layer for running Windows programs (staging branch) with LoL patches(abi.vsyscall32=0 version)
- pkgver = 7.14
+ pkgver = 8.0
pkgrel = 1
url = https://www.wine-staging.com/
install = wine-lol-staging.install
@@ -153,8 +153,8 @@ pkgbase = wine-lol-staging
options = staticlibs
options = !lto
options = !strip
- source = git+https://github.com/wine-staging/wine-staging.git#tag=v7.14
- source = git+https://github.com/wine-mirror/wine.git#tag=wine-7.14
+ source = git+https://github.com/wine-staging/wine-staging.git#tag=v8.0-rc4
+ source = git+https://github.com/wine-mirror/wine.git#tag=wine-8.0-rc4
source = 0002-LoL-6.17+-syscall-fix.patch
source = 0003-LoL-abi.vsyscall32-alternative_patch_by_using_a_fake_cs_segment.patch
source = 0004-LoL-broken-client-update-fix.patch
@@ -164,7 +164,7 @@ pkgbase = wine-lol-staging
sha256sums = SKIP
sha256sums = c127907db75cd8575da27198c8f46aa19dd2a219324e7491761f206f3ce91601
sha256sums = c2cb9265567dfe8c9f148e237910792cad7666d9d3cbf68d8717076030cddc92
- sha256sums = 0c5b97c64fd4983119db8675f0686e26143898de1566c4da46d5df74cb98cfb2
+ sha256sums = 7607a84fd357a86bc8fb59d2cf002a3e471bd8ec78ecdb844b0b77b1ae6d11a0
sha256sums = 49dfbf7546c00958e2b426a61371eedf0119471e9998b354595d5c0ce6dab48b
sha256sums = fe33c51d492de4685b515781ac157a5d02f8048a528404b4fd8319cfc7f5cf25
diff --git a/0004-LoL-broken-client-update-fix.patch b/0004-LoL-broken-client-update-fix.patch
index d33e044b51ea..c069d91e7ebc 100644
--- a/0004-LoL-broken-client-update-fix.patch
+++ b/0004-LoL-broken-client-update-fix.patch
@@ -1,8 +1,8 @@
diff --git a/dlls/ntdll/unix/virtual.c b/dlls/ntdll/unix/virtual.c
-index 94b300c..9f44ddc 100644
+index 0f66429fc9d..9d5975fbe86 100644
--- a/dlls/ntdll/unix/virtual.c
+++ b/dlls/ntdll/unix/virtual.c
-@@ -111,6 +111,8 @@ struct file_view
+@@ -112,6 +112,8 @@ struct file_view
unsigned int protect; /* protection for all pages at allocation time and SEC_* flags */
};
@@ -11,7 +11,7 @@ index 94b300c..9f44ddc 100644
/* per-page protection flags */
#define VPROT_READ 0x01
#define VPROT_WRITE 0x02
-@@ -4310,34 +4312,96 @@ static NTSTATUS get_working_set_ex( HANDLE process, LPCVOID addr,
+@@ -4480,34 +4482,96 @@ static NTSTATUS get_working_set_ex( HANDLE process, LPCVOID addr,
return STATUS_SUCCESS;
}
@@ -66,12 +66,12 @@ index 94b300c..9f44ddc 100644
+ return status;
+}
+
- static NTSTATUS get_memory_section_name( HANDLE process, LPCVOID addr,
- MEMORY_SECTION_NAME *info, SIZE_T len, SIZE_T *ret_len )
+ static unsigned int get_memory_section_name( HANDLE process, LPCVOID addr,
+ MEMORY_SECTION_NAME *info, SIZE_T len, SIZE_T *ret_len )
{
+ SIZE_T current_path_len, max_path_len;
+ WCHAR *name;
- NTSTATUS status;
+ unsigned int status;
if (!info) return STATUS_ACCESS_VIOLATION;
+ max_path_len = len - sizeof(*info) - sizeof(WCHAR); // dont count null char
@@ -115,7 +115,7 @@ index 94b300c..9f44ddc 100644
}
diff --git a/dlls/psapi/tests/psapi_main.c b/dlls/psapi/tests/psapi_main.c
-index 185a406..b4eabf9 100644
+index 185a4062092..b4eabf986ed 100644
--- a/dlls/psapi/tests/psapi_main.c
+++ b/dlls/psapi/tests/psapi_main.c
@@ -471,7 +471,6 @@ static void test_GetMappedFileName(void)
diff --git a/PKGBUILD b/PKGBUILD
index 0e79c61ce83b..9de03eeeec33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: moonshadow565 <moonshadow565@hotmail.com>
pkgname=wine-lol-staging
-pkgver=7.14
+pkgver=8.0
+_winever=8.0-rc4
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (staging branch) with LoL patches(abi.vsyscall32=0 version)'
arch=('x86_64')
@@ -11,8 +12,8 @@ install=wine-lol-staging.install
options=('staticlibs' '!lto' '!strip')
-source=("git+https://github.com/wine-staging/wine-staging.git#tag=v${pkgver}"
- "git+https://github.com/wine-mirror/wine.git#tag=wine-${pkgver}"
+source=("git+https://github.com/wine-staging/wine-staging.git#tag=v${_winever}"
+ "git+https://github.com/wine-mirror/wine.git#tag=wine-${_winever}"
"0002-LoL-6.17+-syscall-fix.patch"
"0003-LoL-abi.vsyscall32-alternative_patch_by_using_a_fake_cs_segment.patch"
"0004-LoL-broken-client-update-fix.patch"
@@ -24,7 +25,7 @@ sha256sums=('SKIP'
'SKIP'
'c127907db75cd8575da27198c8f46aa19dd2a219324e7491761f206f3ce91601'
'c2cb9265567dfe8c9f148e237910792cad7666d9d3cbf68d8717076030cddc92'
- '0c5b97c64fd4983119db8675f0686e26143898de1566c4da46d5df74cb98cfb2'
+ '7607a84fd357a86bc8fb59d2cf002a3e471bd8ec78ecdb844b0b77b1ae6d11a0'
'49dfbf7546c00958e2b426a61371eedf0119471e9998b354595d5c0ce6dab48b'
'fe33c51d492de4685b515781ac157a5d02f8048a528404b4fd8319cfc7f5cf25'
)