summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2019-06-27 00:27:08 +0300
committerStelios Tsampas2019-06-27 00:27:08 +0300
commitafd3f7b29c503d48d8c3985ca26e44de12c48439 (patch)
tree1f39abde26dd3b432d9b10487b99a9b96579ac40
downloadaur-afd3f7b29c503d48d8c3985ca26e44de12c48439.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03821e2eccb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wine-mono-bin
+ pkgdesc = Wine's built-in replacement for Microsoft's .NET Framework
+ pkgver = 4.9.0
+ pkgrel = 1
+ url = https://wiki.winehq.org/Mono
+ arch = any
+ license = GPL
+ license = LGPL2.1
+ license = MPL
+ depends = wine
+ provides = wine-mono=$pkgver
+ conflicts = wine-mono=$pkgver
+ source = https://github.com/madewokherd/wine-mono/releases/download/wine-mono-4.9.0/wine-mono-bin-4.9.0.tar.gz
+ sha512sums = 12bc6e3ca6d5ec7592ce7613b6c3ee1f6e415954f9866757d8c2fa7fa1b5b4488f1a58c368d482c47a4baad5c07431802a85e7d9df63029ef54d034669ccb01a
+
+pkgname = wine-mono-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bab56e19abb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: loathingkernel <loathingkernel a_ gmail d_ com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+pkgname=wine-mono-bin
+pkgver=4.9.0
+pkgrel=1
+pkgdesc="Wine's built-in replacement for Microsoft's .NET Framework"
+arch=('any')
+url="https://wiki.winehq.org/Mono"
+license=('GPL' 'LGPL2.1' 'MPL')
+depends=('wine')
+provides=('wine-mono=$pkgver')
+conflicts=('wine-mono=$pkgver')
+source=("https://github.com/madewokherd/wine-mono/releases/download/${pkgname/-bin/}-$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('12bc6e3ca6d5ec7592ce7613b6c3ee1f6e415954f9866757d8c2fa7fa1b5b4488f1a58c368d482c47a4baad5c07431802a85e7d9df63029ef54d034669ccb01a')
+
+package() {
+ install -Dm 755 -d "$pkgdir"/usr/share/wine/mono/
+ mv ${pkgname/-bin/}-$pkgver "$pkgdir"/usr/share/wine/mono/
+}