summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqaz2020-05-12 18:19:02 +0800
committerqaz2020-05-12 18:19:02 +0800
commit4b90879cb639bc32e463c50d4d049b31481a9762 (patch)
tree43d360079d94859969c2b7724da05a1d0367b7ab
downloadaur-4b90879cb639bc32e463c50d4d049b31481a9762.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--wine-gecko-version-fix.hook11
-rw-r--r--wine-mono-version-fix.hook11
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baa3ec427153
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wine-mono-gecko-version-fix
+ pkgdesc = Fix the version numbers of wine-mono and wine-gecko files to solve the dialog box that pops up when starting wine.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.fkxxyz.com/learn/wine-mono/
+ arch = any
+ license = GPL3
+ depends = pacman
+ depends = wine
+ optdepends = wine-mono
+ optdepends = wine-gecko
+ source = wine-mono-version-fix.hook
+ source = wine-gecko-version-fix.hook
+ md5sums = 2f2958c8de920209c09a168cd75e04c7
+ md5sums = 20d6893254eb74cfb6e79c30af59977a
+
+pkgname = wine-mono-gecko-version-fix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b28e15bfe4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: qaz <fkxxyz@163.com>
+# Contributor: qaz <fkxxyz@163.com>
+
+pkgname=wine-mono-gecko-version-fix
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Fix the version numbers of wine-mono and wine-gecko files to solve the dialog box that pops up when starting wine."
+arch=(any)
+url="https://www.fkxxyz.com/learn/wine-mono/"
+license=('GPL3')
+depends=('pacman' 'wine')
+optdepends=('wine-mono' 'wine-gecko')
+source=(
+ "wine-mono-version-fix.hook"
+ "wine-gecko-version-fix.hook"
+)
+
+package() {
+ install -D "wine-mono-version-fix.hook" \
+ "${pkgdir}/usr/share/libalpm/hooks/wine-mono-version-fix.hook"
+ install -D "wine-gecko-version-fix.hook" \
+ "${pkgdir}/usr/share/libalpm/hooks/wine-gecko-version-fix.hook"
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('2f2958c8de920209c09a168cd75e04c7'
+ '20d6893254eb74cfb6e79c30af59977a')
+
diff --git a/wine-gecko-version-fix.hook b/wine-gecko-version-fix.hook
new file mode 100644
index 000000000000..7ccd930b3023
--- /dev/null
+++ b/wine-gecko-version-fix.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Target = usr/lib/wine/appwiz.cpl.so
+Target = usr/share/wine/gecko/*
+
+[Action]
+Description = Fixing the version of wine-gecko file.
+When = PostTransaction
+Exec = /usr/bin/sh -c 'find /usr/share/wine/gecko -type l -exec unlink {} \; ; ln -sf "$(pacman -Qlq wine-gecko | grep "wine.gecko-\\([-.[:digit:]]\\+\\)-x86_64.msi")" "/usr/share/wine/gecko/$(sed -n "s/.*\\(wine.gecko-[-.[:digit:]]\+-x86_64.msi\\).*/\\1/p" /usr/lib/wine/appwiz.cpl.so)" 2>/dev/null ; ln -sf "$(pacman -Qlq wine-gecko | grep "wine.gecko-\\([-.[:digit:]]\\+\\)-x86.msi")" "/usr/share/wine/gecko/$(sed -n "s/.*\\(wine.gecko-[-.[:digit:]]\+-x86.msi\\).*/\\1/p" /usr/lib32/wine/appwiz.cpl.so)" 2>/dev/null ; true'
diff --git a/wine-mono-version-fix.hook b/wine-mono-version-fix.hook
new file mode 100644
index 000000000000..28eccb953a3d
--- /dev/null
+++ b/wine-mono-version-fix.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Target = usr/lib/wine/appwiz.cpl.so
+Target = usr/share/wine/mono/*
+
+[Action]
+Description = Fixing the version of wine-mono file.
+When = PostTransaction
+Exec = /usr/bin/sh -c 'find /usr/share/wine/mono -type l -exec unlink {} \; ; ln -sf "$(pacman -Qlq wine-mono | grep "wine-mono-\\([-x[:digit:].]\\+\\).msi")" "/usr/share/wine/mono/$(strings -eb /usr/lib/wine/appwiz.cpl.so | sed -n "s/.*\\(wine-mono-[-x[:digit:].]\\+.msi\\).*/\\1/p")" 2>/dev/null ; true'