summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLara Maia2015-06-12 00:36:39 -0300
committerLara Maia2015-06-12 00:36:39 -0300
commit1e7a74e1ca8273931d420b636548f3f7b853a293 (patch)
tree74d32e8175d3de74ecdaf7df8c3cccb0eb5ce6dc
downloadaur-1e7a74e1ca8273931d420b636548f3f7b853a293.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO24
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD31
-rw-r--r--pixi.desktop10
-rw-r--r--pixi.pngbin0 -> 12242 bytes
-rw-r--r--pixi.sh3
7 files changed, 109 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..f6247b8ac3b8
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = wine-pixi
+ pkgdesc = Digipen Freshman Game - Showcase in IGF 2012
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://appdb.winehq.org/objectManager.php?sClass=version&iId=25412
+ arch = any
+ license = Free to use and share
+ depends = wine
+ depends = lib32-openal
+ depends = lib32-libpng
+ depends = lib32-mpg123
+ source = http://www.wyrdysm.com/th15Stuf/Pixi_IGFv1.1.zip
+ source = LICENSE
+ source = pixi.desktop
+ source = pixi.png
+ source = pixi.sh
+
+pkgname = wine-pixi
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c288c021cda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = wine-pixi
+ pkgdesc = Digipen Freshman Game - Showcase in IGF 2012
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://appdb.winehq.org/objectManager.php?sClass=version&iId=25412
+ arch = any
+ license = Free to use and share
+ depends = wine
+ depends = lib32-openal
+ depends = lib32-libpng
+ depends = lib32-mpg123
+ source = http://www.wyrdysm.com/th15Stuf/Pixi_IGFv1.1.zip
+ source = LICENSE
+ source = pixi.desktop
+ source = pixi.png
+ source = pixi.sh
+ md5sums = de1a08f317afcd9e8c101b0972de9656
+ md5sums = 779044cf14091cb2129e12d5c3e1725e
+ md5sums = 49ba015be435fe194b157f3b95ee4b46
+ md5sums = 57b5aede1f007945194904475e129a97
+ md5sums = 296fa5ef79e7a79d42a58f6c25569fda
+
+pkgname = wine-pixi
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c5a92e840957
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The games software present in this package were created by students of DigiPen Institute of Technology (DigiPen),
+and all copyright and other rights in such is owned by DigiPen. While DigiPen allows you to access, download and
+use the software from this area for non-commercial, home use you hereby expressly agree that you will not otherwise
+copy, distribute, modify, or (to the extent not otherwise permitted by law) decompile, disassemble or reverse
+engineer the games software.
+
+THE GAMES SOFTWARE IS MADE AVAILABLE BY DIGIPEN AS-IS AND WITHOUT WARRANTY OF ANY KIND BY DIGIPEN. DIGIPEN HEREBY
+EXPRESSLY DISCLAIMS ANY SUCH WARRANTY, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF MERCHANTABILITY OR
+FITNESS FOR A PARTICULAR PURPOSE.
+
+WITHOUT LIMITING THE GENERALITY OF THE FOREGOING, DIGIPEN SHALL NOT BE LIABLE IN DAMAGES OR OTHERWISE FOR ANY DAMAGE
+OR INJURY FROM DOWNLOADING, DECOMPRESSING, RUNNING OR ATTEMPTING TO RUN, USING OR OTHERWISE DEALING WITH, IN ANY WAY,
+THE GAMES SOFTWARE CONTAINED IN THIS AREA, NOR SHALL DIGIPEN BE LIABLE FOR ANY INCIDENTAL, CONSEQUENTIAL, EXEMPLARY
+OR OTHER TYPES OF DAMAGES ARISING FROM ACCESS TO OR USE OF THE GAMES SOFTWARE.
+
+YOU HEREBY AGREE TO INDEMNIFY, DEFEND AND HOLD HARMLESS DIGIPEN AND ITS DIRECTORS, OFFICERS, EMPLOYEES, AGENTS,
+CONSULTANTS AND CONTRACTORS AGAINST ALL LIABILITY OF ANY KIND ARISING OUT OF YOUR DOWNLOADING, DECOMPRESSING,
+RUNNING OR ATTEMPTING TO RUN, USING OR OTHERWISE DEALING WITH, IN ANY WAY, THE GAMES SOFTWARE.
+
+DIGIPEN MAKES NO WARRANTIES OR REPRESENTATIONS THAT THE GAMES SOFTWARE IS FREE OF MALICIOUS PROGRAMMING, INCLUDING,
+WITHOUT LIMITATION, VIRUSES, TROJAN HORSE PROGRAMS, WORMS, MACROS AND THE LIKE. AS THE PARTY ACCESSING THE GAMES
+SOFTWARE IT IS YOUR RESPONSIBILITY TO GUARD AGAINST AND DEAL WITH THE EFFECTS OF ANY SUCH MALICIOUS PROGRAMMING.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80a394e8ebdc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: BlackICE (manfredi at gmail.com)
+
+pkgname=wine-pixi
+url='http://appdb.winehq.org/objectManager.php?sClass=version&iId=25412'
+pkgdesc='Digipen Freshman Game - Showcase in IGF 2012'
+pkgver=1.1
+pkgrel=1
+arch=('any')
+license=('Free to use and share')
+
+source=('http://www.wyrdysm.com/th15Stuf/Pixi_IGFv1.1.zip'
+ 'LICENSE' 'pixi.desktop' 'pixi.png' 'pixi.sh')
+
+md5sums=('de1a08f317afcd9e8c101b0972de9656'
+ '779044cf14091cb2129e12d5c3e1725e'
+ '49ba015be435fe194b157f3b95ee4b46'
+ '57b5aede1f007945194904475e129a97'
+ '296fa5ef79e7a79d42a58f6c25569fda')
+
+depends=('wine' 'lib32-openal' 'lib32-libpng' 'lib32-mpg123')
+
+
+package() {
+ cd "$scrdir"
+ install -Dm755 pixi.sh "$pkgdir"/usr/bin/pixi
+ install -Dm644 pixi.desktop "$pkgdir"/usr/share/applications/pixi.desktop
+ install -Dm644 pixi.png "$pkgdir"/usr/share/pixi/pixi.png
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/pixi/LICENSE
+
+ cp -rf Pixi_IGFv1.1/* "$pkgdir"/usr/share/pixi/
+}
diff --git a/pixi.desktop b/pixi.desktop
new file mode 100644
index 000000000000..513eaec29915
--- /dev/null
+++ b/pixi.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Pixi
+Type=Application
+Comment=Pixi by DigiPen
+Terminal=false
+Exec=pixi
+Icon=/usr/share/pixi/pixi.png
+Categories=Game;
+GenericName=Pixi
diff --git a/pixi.png b/pixi.png
new file mode 100644
index 000000000000..05ee247d5ec8
--- /dev/null
+++ b/pixi.png
Binary files differ
diff --git a/pixi.sh b/pixi.sh
new file mode 100644
index 000000000000..8d7e073d023d
--- /dev/null
+++ b/pixi.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/pixi
+wine Pixi.exe