summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLara Maia2015-06-12 00:35:19 -0300
committerLara Maia2015-06-12 00:35:19 -0300
commit7e14e2b8fced825a0d2663f31beb60822ede9d11 (patch)
treebd27f89b5ac37b358ed975843051e18d42f9d6f6
downloadaur-7e14e2b8fced825a0d2663f31beb60822ede9d11.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD30
-rw-r--r--pixi2.desktop10
-rw-r--r--pixi2.sh3
5 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..869a19852267
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wine-pixi2
+ pkgdesc = Digipen Sophomore Game - Final Version
+ pkgver = 2.0
+ pkgrel = 2
+ url = https://www.digipen.edu/?id=1170&proj=26000
+ arch = any
+ license = Free to use and share
+ depends = wine
+ depends = lib32-openal
+ source = http://lara.craft.net.br/pixi-2.zip
+ source = pixi2.desktop
+ source = pixi2.sh
+ source = LICENSE
+ md5sums = 6dd1652d26df493aee13a7df3fdaf7c6
+ md5sums = e577c6fbd8e49132a823fc616c541227
+ md5sums = 9e9d133b559ef4db4df4f31fd0127ae9
+ md5sums = 779044cf14091cb2129e12d5c3e1725e
+
+pkgname = wine-pixi2
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c5a92e840957
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The games software present in this package were created by students of DigiPen Institute of Technology (DigiPen),
+and all copyright and other rights in such is owned by DigiPen. While DigiPen allows you to access, download and
+use the software from this area for non-commercial, home use you hereby expressly agree that you will not otherwise
+copy, distribute, modify, or (to the extent not otherwise permitted by law) decompile, disassemble or reverse
+engineer the games software.
+
+THE GAMES SOFTWARE IS MADE AVAILABLE BY DIGIPEN AS-IS AND WITHOUT WARRANTY OF ANY KIND BY DIGIPEN. DIGIPEN HEREBY
+EXPRESSLY DISCLAIMS ANY SUCH WARRANTY, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTY OF MERCHANTABILITY OR
+FITNESS FOR A PARTICULAR PURPOSE.
+
+WITHOUT LIMITING THE GENERALITY OF THE FOREGOING, DIGIPEN SHALL NOT BE LIABLE IN DAMAGES OR OTHERWISE FOR ANY DAMAGE
+OR INJURY FROM DOWNLOADING, DECOMPRESSING, RUNNING OR ATTEMPTING TO RUN, USING OR OTHERWISE DEALING WITH, IN ANY WAY,
+THE GAMES SOFTWARE CONTAINED IN THIS AREA, NOR SHALL DIGIPEN BE LIABLE FOR ANY INCIDENTAL, CONSEQUENTIAL, EXEMPLARY
+OR OTHER TYPES OF DAMAGES ARISING FROM ACCESS TO OR USE OF THE GAMES SOFTWARE.
+
+YOU HEREBY AGREE TO INDEMNIFY, DEFEND AND HOLD HARMLESS DIGIPEN AND ITS DIRECTORS, OFFICERS, EMPLOYEES, AGENTS,
+CONSULTANTS AND CONTRACTORS AGAINST ALL LIABILITY OF ANY KIND ARISING OUT OF YOUR DOWNLOADING, DECOMPRESSING,
+RUNNING OR ATTEMPTING TO RUN, USING OR OTHERWISE DEALING WITH, IN ANY WAY, THE GAMES SOFTWARE.
+
+DIGIPEN MAKES NO WARRANTIES OR REPRESENTATIONS THAT THE GAMES SOFTWARE IS FREE OF MALICIOUS PROGRAMMING, INCLUDING,
+WITHOUT LIMITATION, VIRUSES, TROJAN HORSE PROGRAMS, WORMS, MACROS AND THE LIKE. AS THE PARTY ACCESSING THE GAMES
+SOFTWARE IT IS YOUR RESPONSIBILITY TO GUARD AGAINST AND DEAL WITH THE EFFECTS OF ANY SUCH MALICIOUS PROGRAMMING.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0801108de948
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lara Maia <lara@craft.net.br>
+
+pkgname=wine-pixi2
+url='https://www.digipen.edu/?id=1170&proj=26000'
+pkgdesc='Digipen Sophomore Game - Final Version'
+pkgver=2.0
+pkgrel=2
+arch=('any')
+license=('Free to use and share')
+
+source=('http://lara.craft.net.br/pixi-2.zip'
+ 'pixi2.desktop' 'pixi2.sh' 'LICENSE')
+
+md5sums=('6dd1652d26df493aee13a7df3fdaf7c6'
+ 'e577c6fbd8e49132a823fc616c541227'
+ '9e9d133b559ef4db4df4f31fd0127ae9'
+ '779044cf14091cb2129e12d5c3e1725e')
+
+depends=('wine' 'lib32-openal')
+
+
+package() {
+ cd "$scrdir"
+ install -Dm755 pixi2.sh "$pkgdir"/usr/bin/pixi2/pixi2.sh
+ install -Dm644 pixi2.desktop "$pkgdir"/usr/share/applications/pixi2.desktop
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/pixi2/LICENSE
+
+ mkdir -p "$pkgdir"/usr/share/pixi2/
+ cp -rf Pixi_Final/* "$pkgdir"/usr/share/pixi2/
+}
diff --git a/pixi2.desktop b/pixi2.desktop
new file mode 100644
index 000000000000..8a956e60ba2d
--- /dev/null
+++ b/pixi2.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=2.0
+Name=Pixi 2
+Type=Application
+Comment=Pixi by DigiPen
+Terminal=false
+Exec=pixi2
+Icon=/usr/share/pixi2/pixilogo.ico
+Categories=Game;
+GenericName=Pixi2
diff --git a/pixi2.sh b/pixi2.sh
new file mode 100644
index 000000000000..6d73f0966070
--- /dev/null
+++ b/pixi2.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/pixi2
+wine Pixi.exe