summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Hernberg2015-08-08 20:37:09 +0200
committerJoakim Hernberg2015-08-08 20:37:09 +0200
commitc20d7310d55111a99265a996ac16a1e6fddfbe6e (patch)
treede1d81b47b4df3638cc75cf815ebe82c682d0c6c
parentece2b6c695b59b155973f9bca40977e57ceb0d7b (diff)
downloadaur-c20d7310d55111a99265a996ac16a1e6fddfbe6e.tar.gz
bump to 1.7.49-1
-rw-r--r--.SRCINFO17
-rwxr-xr-xPKGBUILD15
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f65aff817714..9203b2d9ba0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 4.2.1
-# Mon Jun 29 08:38:22 UTC 2015
+# Sat Aug 8 18:35:53 UTC 2015
pkgbase = wine-rt
pkgdesc = Realtime Wine - maps windows priority levels to linux scheduling policies
- pkgver = 1.7.46
+ pkgver = 1.7.49
pkgrel = 1
url = http://www.winehq.com
install = wine-rt.install
@@ -120,21 +120,20 @@ pkgbase = wine-rt
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=1.7.46
- provides = bin32-wine=1.7.46
- provides = wine-wow64=1.7.46
+ provides = wine=1.7.49
+ provides = bin32-wine=1.7.49
+ provides = wine-wow64=1.7.49
conflicts = wine
conflicts = bin32-wine
conflicts = wine-wow64
replaces = wine
replaces = bin32-wine
options = staticlibs
- options = !buildflags
- source = http://prdownloads.sourceforge.net/wine/wine-1.7.46.tar.bz2
- source = http://prdownloads.sourceforge.net/wine/wine-1.7.46.tar.bz2.sign
+ source = http://prdownloads.sourceforge.net/wine/wine-1.7.49.tar.bz2
+ source = http://prdownloads.sourceforge.net/wine/wine-1.7.49.tar.bz2.sign
source = 30-win32-aliases.conf
source = wine-rt-101107.patch
- sha256sums = 9ab4046cc676de3054f9f2560e7d757b25324f72dd9a9cfed0d4aa48cc87350b
+ sha256sums = c8a1589753493cb6b71b3772b730cdf90059fe0f29cbfb369fc9a2339766b789
sha256sums = SKIP
sha256sums = 9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7
sha256sums = cd8c48c9e5111b6acb47120da0272bc7afe3acc1f021443c81bb75d5d40ba4cc
diff --git a/PKGBUILD b/PKGBUILD
index c2e570efa245..e18e2bd07be8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
pkgname=wine-rt
-pkgver=1.7.46
+pkgver=1.7.49
pkgrel=1
_pkgbasever=${pkgver/rc/-rc}
@@ -14,7 +14,7 @@ source=(http://prdownloads.sourceforge.net/wine/wine-$_pkgbasever.tar.bz2{,.sign
30-win32-aliases.conf
wine-rt-101107.patch)
-sha256sums=('9ab4046cc676de3054f9f2560e7d757b25324f72dd9a9cfed0d4aa48cc87350b'
+sha256sums=('c8a1589753493cb6b71b3772b730cdf90059fe0f29cbfb369fc9a2339766b789'
'SKIP'
'9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7'
'cd8c48c9e5111b6acb47120da0272bc7afe3acc1f021443c81bb75d5d40ba4cc')
@@ -25,7 +25,6 @@ pkgdesc="Realtime Wine - maps windows priority levels to linux scheduling polici
url="http://www.winehq.com"
arch=(i686 x86_64)
options=(staticlibs)
-options=(staticlibs !buildflags) # remove !buildflags once https://bugs.winehq.org/show_bug.cgi?id=38653 is resolved
license=(LGPL)
install=wine-rt.install
@@ -125,6 +124,10 @@ prepare() {
build() {
cd "$srcdir"
+ # remove once https://bugs.winehq.org/show_bug.cgi?id=38653 is resolved
+ export CFLAGS="${CFLAGS/-O2/} -O0"
+ export CXXFLAGS="${CXXFLAGS/-O2/} -O0"
+
# Allow ccache to work
mv wine-$_pkgbasever wine
@@ -135,10 +138,6 @@ build() {
# These additional CPPFLAGS solve FS#27662 and FS#34195
export CPPFLAGS="${CPPFLAGS/-D_FORTIFY_SOURCE=2/} -D_FORTIFY_SOURCE=0"
- # Fix build with GCC5
- export CFLAGS="${CFLAGS/-O2/} -O0"
- export CXXFLAGS="${CXXFLAGS/-O2/} -O0"
-
if [[ $CARCH == x86_64 ]]; then
msg2 "Building Wine-64..."
@@ -206,3 +205,5 @@ package() {
mkdir -p "$pkgdir/usr/share/doc/wine-rt"
cp "$srcdir/wine/README.WINE-RT" "$pkgdir/usr/share/doc/wine-rt"
}
+
+# vim:set ts=8 sts=2 sw=2 et: