summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2017-01-22 11:11:55 -0800
committerMike Swanson2017-01-22 11:11:55 -0800
commit2b38195cd7cd732069e65c9534f502a1283c599a (patch)
tree246ccf041f01574a3a018bbe1f9f3c9ff18b4cbd
parent80ba041d0cf293dca32bbc4e74c824ee4184b41c (diff)
downloadaur-2b38195cd7cd732069e65c9534f502a1283c599a.tar.gz
Fix build with flex 2.6.3
-rw-r--r--.SRCINFO6
-rw-r--r--0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch35
-rw-r--r--PKGBUILD16
3 files changed, 52 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09657338962a..12a8679ef77d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 22 00:22:36 UTC 2016
+# Sun Jan 22 19:11:41 UTC 2017
pkgbase = wine-stable
pkgdesc = A compatibility layer for running Windows programs
pkgver = 1.8.6
- pkgrel = 1
+ pkgrel = 2
url = http://www.winehq.com
arch = i686
arch = x86_64
@@ -67,9 +67,11 @@ pkgbase = wine-stable
source = https://dl.winehq.org/wine/source/1.8/wine-1.8.6.tar.bz2
source = https://dl.winehq.org/wine/source/1.8/wine-1.8.6.tar.bz2.sign
source = 30-win32-aliases.conf
+ source = 0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch
sha256sums = b1797896eb3b63aab8a4753cc756d6211a0e85460146a1b52063ec79c13906d3
sha256sums = SKIP
sha256sums = 9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7
+ sha256sums = da2f15457044a397483bbf52bf4e59f1000bf270ab823a0b8957e905a1a933f7
depends_x86_64 = lib32-fontconfig
depends_x86_64 = lib32-freetype2
depends_x86_64 = lib32-gcc-libs
diff --git a/0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch b/0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch
new file mode 100644
index 000000000000..45213ac376fe
--- /dev/null
+++ b/0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch
@@ -0,0 +1,35 @@
+From e0889eac30d17b995d4f8a9f5c80f9d994050c29 Mon Sep 17 00:00:00 2001
+From: Mike Swanson <mikeonthecomputer@gmail.com>
+Date: Sun, 22 Jan 2017 10:49:44 -0800
+Subject: [PATCH] programs/winhlp32: Use noyywrap for macro.lex.l
+
+flex 2.6.3 broke the previous version, but this is a well-supported
+way of achieving the same goal, used elsewhere in the Wine source too.
+---
+ programs/winhlp32/macro.lex.l | 6 +-----
+ 1 file changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/programs/winhlp32/macro.lex.l b/programs/winhlp32/macro.lex.l
+index 8f6945ca98..ff8a4832d3 100644
+--- a/programs/winhlp32/macro.lex.l
++++ b/programs/winhlp32/macro.lex.l
+@@ -20,7 +20,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA
+ */
+ %}
+-%option noinput nounput never-interactive 8bit
++%option noinput nounput noyywrap never-interactive 8bit
+ %x quote
+ %{
+ #include "config.h"
+@@ -367,7 +367,3 @@ WINHELP_WINDOW* MACRO_CurrentWindow(void)
+ {
+ return lex_data ? lex_data->window : Globals.active_win;
+ }
+-
+-#ifndef yywrap
+-int yywrap(void) { return 1; }
+-#endif
+--
+2.11.0
+
diff --git a/PKGBUILD b/PKGBUILD
index da47ff380a8a..b10082386551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,15 @@
pkgname=wine-stable
pkgver=1.8.6
-pkgrel=1
+pkgrel=2
source=(https://dl.winehq.org/wine/source/1.8/wine-$pkgver.tar.bz2{,.sign}
- 30-win32-aliases.conf)
+ 30-win32-aliases.conf
+ 0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch)
sha256sums=('b1797896eb3b63aab8a4753cc756d6211a0e85460146a1b52063ec79c13906d3'
'SKIP'
- '9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7')
+ '9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7'
+ 'da2f15457044a397483bbf52bf4e59f1000bf270ab823a0b8957e905a1a933f7')
validpgpkeys=(5AC1A08B03BD7A313E0A955AF5E6E9EEB9461DD7
DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D)
@@ -57,6 +59,14 @@ prepare() {
# Allow ccache to work
mv wine-$pkgver wine
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -d wine -p1 -i "$patch"
+ fi
+ done
+
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i wine/configure*
# These additional CPPFLAGS solve FS#27662 and FS#34195