summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2017-01-24 16:51:44 -0800
committerMike Swanson2017-01-24 16:51:44 -0800
commit4e102ed65636b7c73566e0f58bf4d4bb52d0e895 (patch)
tree08f038fab907fabb98e70b7504eae1208d6cd8ef
parentbf9814ccbfee09b6460028601fb83186ae0a16b5 (diff)
downloadaur-4e102ed65636b7c73566e0f58bf4d4bb52d0e895.tar.gz
Update to 2.0
-rw-r--r--.SRCINFO18
-rw-r--r--0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l-and-p.patch (renamed from 0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch)20
-rw-r--r--PKGBUILD17
3 files changed, 30 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee85ffbb8308..01847339ab41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jan 23 00:51:49 UTC 2017
+# Wed Jan 25 00:51:18 UTC 2017
pkgbase = wine-stable
pkgdesc = A compatibility layer for running Windows programs
- pkgver = 1.8.6
- pkgrel = 4
+ pkgver = 2.0
+ pkgrel = 1
url = http://www.winehq.com
arch = i686
arch = x86_64
@@ -61,17 +61,17 @@ pkgbase = wine-stable
optdepends = openal
optdepends = samba
optdepends = v4l-utils
- provides = wine=1.8.6
+ provides = wine=2.0
conflicts = wine
options = staticlibs
- source = https://dl.winehq.org/wine/source/1.8/wine-1.8.6.tar.bz2
- source = https://dl.winehq.org/wine/source/1.8/wine-1.8.6.tar.bz2.sign
+ source = https://dl.winehq.org/wine/source/2.0/wine-2.0.tar.bz2
+ source = https://dl.winehq.org/wine/source/2.0/wine-2.0.tar.bz2.sign
source = 30-win32-aliases.conf
- source = 0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch
- sha256sums = b1797896eb3b63aab8a4753cc756d6211a0e85460146a1b52063ec79c13906d3
+ source = 0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l-and-p.patch
+ sha256sums = 9756f5a2129b6a83ba701e546173cbff86caa671b0af73eb8f72c03b20c066c6
sha256sums = SKIP
sha256sums = 9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7
- sha256sums = da2f15457044a397483bbf52bf4e59f1000bf270ab823a0b8957e905a1a933f7
+ sha256sums = d6ab08b246be10459957aa5c5f1a620793a2974125191fc7da4a23f7e4484293
depends_x86_64 = lib32-fontconfig
depends_x86_64 = lib32-freetype2
depends_x86_64 = lib32-gcc-libs
diff --git a/0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch b/0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l-and-p.patch
index 45213ac376fe..1287db950eb2 100644
--- a/0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch
+++ b/0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l-and-p.patch
@@ -1,28 +1,34 @@
-From e0889eac30d17b995d4f8a9f5c80f9d994050c29 Mon Sep 17 00:00:00 2001
+From 2472b819eabc76376d5552bd72b4f1f3cfa589da Mon Sep 17 00:00:00 2001
From: Mike Swanson <mikeonthecomputer@gmail.com>
Date: Sun, 22 Jan 2017 10:49:44 -0800
-Subject: [PATCH] programs/winhlp32: Use noyywrap for macro.lex.l
+Subject: [PATCH] programs/winhlp32: Use noyywrap for macro.lex.l and prefix
flex 2.6.3 broke the previous version, but this is a well-supported
way of achieving the same goal, used elsewhere in the Wine source too.
+
+To avoid warnings in compilation, also set prefix="winhlp32_" --
+this is consistent with how other lex files work too.
+
+Signed-off-by: Mike Swanson <mikeonthecomputer@gmail.com>
---
- programs/winhlp32/macro.lex.l | 6 +-----
- 1 file changed, 1 insertion(+), 5 deletions(-)
+ programs/winhlp32/macro.lex.l | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/programs/winhlp32/macro.lex.l b/programs/winhlp32/macro.lex.l
-index 8f6945ca98..ff8a4832d3 100644
+index 8f6945ca98..2e03660278 100644
--- a/programs/winhlp32/macro.lex.l
+++ b/programs/winhlp32/macro.lex.l
-@@ -20,7 +20,7 @@
+@@ -20,7 +20,8 @@
* Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA
*/
%}
-%option noinput nounput never-interactive 8bit
+%option noinput nounput noyywrap never-interactive 8bit
++%option prefix="winhlp32_"
%x quote
%{
#include "config.h"
-@@ -367,7 +367,3 @@ WINHELP_WINDOW* MACRO_CurrentWindow(void)
+@@ -367,7 +368,3 @@ WINHELP_WINDOW* MACRO_CurrentWindow(void)
{
return lex_data ? lex_data->window : Globals.active_win;
}
diff --git a/PKGBUILD b/PKGBUILD
index 8372c9217baf..e25c37e3f4aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
-# Warning: If you are downgrading from the development branch (Wine 1.9.x,
+# Warning: If you are downgrading from the development branch (Wine 2.1.x,
# for example), your WINEPREFIX may break and experience unusual bugs.
# Try to make a clean WINEPREFIX, such as by doing “rm -rf ~/.wine”
pkgname=wine-stable
-pkgver=1.8.6
-pkgrel=4
+pkgver=2.0
+pkgrel=1
-source=(https://dl.winehq.org/wine/source/1.8/wine-$pkgver.tar.bz2{,.sign}
+source=(https://dl.winehq.org/wine/source/2.0/wine-$pkgver.tar.bz2{,.sign}
30-win32-aliases.conf
- 0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l.patch)
-sha256sums=('b1797896eb3b63aab8a4753cc756d6211a0e85460146a1b52063ec79c13906d3'
+ 0001-programs-winhlp32-Use-noyywrap-for-macro.lex.l-and-p.patch)
+sha256sums=('9756f5a2129b6a83ba701e546173cbff86caa671b0af73eb8f72c03b20c066c6'
'SKIP'
'9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7'
- 'da2f15457044a397483bbf52bf4e59f1000bf270ab823a0b8957e905a1a933f7')
+ 'd6ab08b246be10459957aa5c5f1a620793a2974125191fc7da4a23f7e4484293')
validpgpkeys=(5AC1A08B03BD7A313E0A955AF5E6E9EEB9461DD7
DA23579A74D4AD9AF9D3F945CEFAC8EAAF17519D)
@@ -74,7 +74,7 @@ prepare() {
# Get rid of old build dirs
rm -rf wine-{32,64}-build
- mkdir wine-32-build
+ mkdir wine-{32,64}-build
}
build() {
@@ -83,7 +83,6 @@ build() {
if [[ $CARCH == x86_64 ]]; then
msg2 "Building Wine-64..."
- mkdir wine-64-build
cd "$srcdir/wine-64-build"
../wine/configure \
--prefix=/usr \