summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2023-05-27 08:46:52 -0700
committerMike Swanson2023-05-27 08:46:52 -0700
commit36ebbe857e0d1e912d41fe9282792f290fb2afae (patch)
tree470ac6edf0097f3b7eab12391008ee527d0183d6
parent4caaf995f38265ecb3c936ccf83c570c2a034d06 (diff)
downloadaur-36ebbe857e0d1e912d41fe9282792f290fb2afae.tar.gz
Update to 7.4.1
Bugfix release for 7.4.0, but we have to change the directory name it’s installed to so wine-stable will still be happy to load it.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c84e9531f45b..b3e4a915cc54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = wine-stable-mono
- pkgdesc = Wine's built-in replacement for Microsoft's .NET Framework (for wine-stable)
- pkgver = 7.4.0
+ pkgdesc = Wine’s built-in replacement for Microsoft’s .NET Framework (for wine-stable)
+ pkgver = 7.4.1
pkgrel = 1
url = https://wiki.winehq.org/Mono
arch = any
license = GPL
license = LGPL2.1
license = MPL
- provides = wine-mono=7.4.0
+ provides = wine-mono=7.4.1
conflicts = wine-mono
- source = https://dl.winehq.org/wine/wine-mono/7.4.0/wine-mono-7.4.0-x86.tar.xz
- b2sums = 3a74106b9b3f21a88c2435f7988d66a54e08beea931a0ce0df6431c21add4ee2685bf9c9cb2404ee1a685736d61b1aee3cdd507130e5c5dddba7e506a2ff18bb
+ source = https://github.com/madewokherd/wine-mono/releases/download/wine-mono-7.4.1/wine-mono-7.4.1-x86.tar.xz
+ b2sums = 28adbcca630698e74e455fbe37b8cd60c3d836c503db6a2df20e4db3e12f549a5d1fae6a4c0ccd6068e2667f700fbfe09858b95f156ad8d660ef3804773179a0
pkgname = wine-stable-mono
diff --git a/PKGBUILD b/PKGBUILD
index 36c1db54b943..adfe18d82fd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
pkgname=wine-stable-mono
_pkgname=wine-mono
-pkgver=7.4.0
+pkgver=7.4.1
pkgrel=1
-pkgdesc="Wine's built-in replacement for Microsoft's .NET Framework (for wine-stable)"
+pkgdesc='Wine’s built-in replacement for Microsoft’s .NET Framework (for wine-stable)'
arch=('any')
url="https://wiki.winehq.org/Mono"
license=('GPL' 'LGPL2.1' 'MPL')
conflicts=('wine-mono')
provides=("wine-mono=$pkgver")
-source=("https://dl.winehq.org/wine/$_pkgname/$pkgver/$_pkgname-$pkgver-x86.tar.xz")
-b2sums=('3a74106b9b3f21a88c2435f7988d66a54e08beea931a0ce0df6431c21add4ee2685bf9c9cb2404ee1a685736d61b1aee3cdd507130e5c5dddba7e506a2ff18bb')
+source=("https://github.com/madewokherd/wine-mono/releases/download/wine-mono-$pkgver/wine-mono-$pkgver-x86.tar.xz")
+b2sums=('28adbcca630698e74e455fbe37b8cd60c3d836c503db6a2df20e4db3e12f549a5d1fae6a4c0ccd6068e2667f700fbfe09858b95f156ad8d660ef3804773179a0')
package() {
install -d -m755 "$pkgdir"/usr/share/wine/mono/
- cp -r -a --no-preserve='ownership' $_pkgname-$pkgver "$pkgdir"/usr/share/wine/mono/
+ # Fake the file system version so Wine 8.0 is happy
+ cp -r -a --no-preserve='ownership' $_pkgname-$pkgver "$pkgdir"/usr/share/wine/mono/$_pkgname-7.4.0
}