summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-09-04 13:26:50 -0300
committerDaniel Bermond2017-09-04 13:26:50 -0300
commit3e7a7070745504c26ef20e2ccf12c842b746ca78 (patch)
tree1b14633908a93633641cd8050fd6fc8027af8790
parentb8614752e2e0c180eb0eea1a297eaea64bccd157 (diff)
downloadaur-3e7a7070745504c26ef20e2ccf12c842b746ca78.tar.gz
Cosmetic changings
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 157a07c405b9..c0f9a768b230 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jul 16 14:15:14 UTC 2017
+# Mon Sep 4 16:01:38 UTC 2017
pkgbase = wine-staging-git
pkgdesc = A compatibility layer for running Windows programs (staging branch, git version)
pkgver = 2.12.r6.g201e6261+wine.2.12.r134.gab313dd3be
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wine-compholio/wine-staging/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b6f6d3696659..5f2d422e3eaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wine-staging-git
pkgver=2.12.r6.g201e6261+wine.2.12.r134.gab313dd3be
-pkgrel=1
+pkgrel=2
pkgdesc='A compatibility layer for running Windows programs (staging branch, git version)'
arch=('i686' 'x86_64')
url='https://github.com/wine-compholio/wine-staging/'
@@ -110,17 +110,17 @@ fi
prepare() {
cd 'wine-git'
- msg2 'Cleaning wine source code tree...'
# restore the wine tree to its git origin state, without wine-staging patches
# (necessary for reapllying wine-staging patches in succedent builds,
# otherwise the patches will fail to be reapplied)
+ msg2 'Cleaning wine source code tree...'
git reset --hard HEAD # restore tracked files
git clean -xdf # delete untracked files
# change back to the wine upstream commit that this version of wine-staging is based in
msg2 'Changing wine HEAD to the wine-staging base commit...'
- git checkout "$(../"${pkgname}"/patches/patchinstall.sh --upstream-commit)"
+ git checkout "$(../"$pkgname"/patches/patchinstall.sh --upstream-commit)"
}
pkgver() {
@@ -130,7 +130,7 @@ pkgver() {
| sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//' \
| sed "s/^latest.release/${_staging_tag}/")"
cd "${srcdir}/wine-git"
- local _wine_version="$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+ local _wine_version="$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//')"
printf '%s+%s' "$_staging_version" "$_wine_version"
}
@@ -188,7 +188,7 @@ package() {
if [ "$CARCH" = 'i686' ]
then
- make prefix="$pkgdir/usr" install
+ make prefix="${pkgdir}/usr" install
else
make prefix="${pkgdir}/usr" \
libdir="${pkgdir}/usr/lib32" \