summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-03-07 16:05:12 +0000
committerDaniel Bermond2020-03-07 16:05:12 +0000
commit714c8bd82cbcf0405c56c5572c75167a34e6a2e0 (patch)
treea463bbb70c8d06766db4b7857d09fc708cd0d776
parenta6d26e3132a775d46b564d8cc7d38523d33b7e67 (diff)
downloadaur-714c8bd82cbcf0405c56c5572c75167a34e6a2e0.tar.gz
depends: add faudio. Disable xactengine-initial patchset.
faudio is used in repository package since version 5.2-2[1]. The recently introduced xactengine-initial patchset causes a build error with winegcc when building xaudio2_7 tests: /usr/bin/ld: cannot find -lx3daudio1_7 Apparently, this is being caused by the recent upstream commit 2fc5c88[2] that adds the xactengine-initial patchset. Temporarily disable this recently introduced patchset so that the package can be built. References ---------- [1] https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/wine-staging&id=f1617c6f55896ec22573a42912964f9f3e108bf9 [2] https://github.com/wine-staging/wine-staging/commit/2fc5c88068e3dea2612c182ff300511aa2954242
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5de1753364a8..007b8a05581d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-staging-git
pkgdesc = A compatibility layer for running Windows programs (staging branch, git version)
- pkgver = 4.20.r4.ga9639c41+wine.4.20.r74.ga9c4b309f6
+ pkgver = 5.3.r14.g5213d551+wine.5.3.r139.g4f53be1a6e
pkgrel = 1
url = https://www.wine-staging.com/
install = wine-staging-git.install
@@ -100,6 +100,8 @@ pkgbase = wine-staging-git
makedepends = lib32-gcc-libs
makedepends = libpcap
makedepends = lib32-libpcap
+ makedepends = faudio
+ makedepends = lib32-faudio
makedepends = desktop-file-utils
optdepends = giflib
optdepends = lib32-giflib
@@ -152,10 +154,10 @@ pkgbase = wine-staging-git
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=4.20.r74.ga9c4b309f6
- provides = wine-wow64=4.20.r74.ga9c4b309f6
- provides = wine-git=4.20.r74.ga9c4b309f6
- provides = wine-staging=4.20.r4.ga9639c41
+ provides = wine=5.3.r139.g4f53be1a6e
+ provides = wine-wow64=5.3.r139.g4f53be1a6e
+ provides = wine-git=5.3.r139.g4f53be1a6e
+ provides = wine-staging=5.3.r14.g5213d551
conflicts = wine
conflicts = wine-wow64
options = staticlibs
@@ -197,5 +199,7 @@ pkgname = wine-staging-git
depends = lib32-gcc-libs
depends = libpcap
depends = lib32-libpcap
+ depends = faudio
+ depends = lib32-faudio
depends = desktop-file-utils
diff --git a/PKGBUILD b/PKGBUILD
index fa64b929e100..80686e38590d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=wine-staging-git
-pkgver=4.20.r4.ga9639c41+wine.4.20.r74.ga9c4b309f6
+pkgver=5.3.r14.g5213d551+wine.5.3.r139.g4f53be1a6e
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (staging branch, git version)'
arch=('i686' 'x86_64')
@@ -22,6 +22,7 @@ _depends=(
'libsm' 'lib32-libsm'
'gcc-libs' 'lib32-gcc-libs'
'libpcap' 'lib32-libpcap'
+ 'faudio' 'lib32-faudio'
'desktop-file-utils'
)
makedepends=('git' 'autoconf' 'ncurses' 'bison' 'perl' 'fontforge' 'flex'
@@ -146,10 +147,10 @@ prepare() {
# fix path of opencl headers
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
- # apply all wine-staging patches
+ # apply wine-staging patches (exclude xactengine-initial due to build error)
printf '%s\n' ' -> Applying wine-staging patches...'
cd "${srcdir}/wine-staging/patches"
- ./patchinstall.sh DESTDIR="${srcdir}/wine" --all
+ ./patchinstall.sh DESTDIR="${srcdir}/wine" --all -W xactengine-initial
}
pkgver() {