summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Norberg2018-04-13 15:27:58 +0200
committerLars Norberg2018-04-13 15:27:58 +0200
commit7be23b417df9809b46d2f348d23bd32b18df9786 (patch)
tree5b8a6dabc6d9532b350eed7b5cd46ca4258db2af
parent65c80d834fb4c923859c366d963825b7e82593d5 (diff)
downloadaur-7be23b417df9809b46d2f348d23bd32b18df9786.tar.gz
added versioning to wine provides
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34214af21808..9f597751d9b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-staging-pba-git
pkgdesc = Wine staging branch with PBA patches for increased D3D performance. Git versions. (Also includes Path of Exile DX11 patch!)
- pkgver = 3.5.r9.ga596208a+wine.3.5.r130.gdd2624a24f+pba.3.5.r33.8c72f84
+ pkgver = 3.5.r13.g3fe54232+wine.3.5.r193.ga7b33a6a42+pba.3.5.r33.8c72f84
pkgrel = 1
url = https://github.com/acomminos/wine-pba
install = wine.install
@@ -164,9 +164,10 @@ pkgbase = wine-staging-pba-git
optdepends = lib32-vulkan-icd-loader
optdepends = cups
optdepends = samba
- provides = wine
- provides = wine-wow64
- provides = wine-staging
+ provides = wine=3.5.r193.ga7b33a6a42+pba.3.5.r33.8c72f84
+ provides = wine-wow64=3.5.r193.ga7b33a6a42+pba.3.5.r33.8c72f84
+ provides = wine-git=3.5.r193.ga7b33a6a42+pba.3.5.r33.8c72f84
+ provides = wine-staging=3.5.r13.g3fe54232
conflicts = wine
conflicts = wine-wow64
conflicts = wine-staging
diff --git a/PKGBUILD b/PKGBUILD
index bc4c716725b2..658387bcf48d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Lars Norberg < arch-packages at cogwerkz dot org >
pkgname=wine-staging-pba-git
-pkgver=3.5.r9.ga596208a+wine.3.5.r130.gdd2624a24f+pba.3.5.r33.8c72f84
+pkgver=3.5.r13.g3fe54232+wine.3.5.r193.ga7b33a6a42+pba.3.5.r33.8c72f84
pkgrel=1
_winesrcdir='wine-git'
_stgsrcdir='wine-staging-git'
@@ -106,8 +106,12 @@ sha256sums=('SKIP'
'50ccb5bd2067e5d2739c5f7abcef11ef096aa246f5ceea11d2c3b508fc7f77a1'
'9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7'
'c589c1668851cf5973b8e76d9bd6ae3b9cb9e6524df5d9cb90af4ac20d61d152')
-
-provides=('wine' 'wine-wow64' 'wine-staging')
+provides=(
+ "wine=$( printf '%s' "$pkgver" | sed 's/.*\+wine\.//')"
+ "wine-wow64=$( printf '%s' "$pkgver" | sed 's/.*\+wine\.//')"
+ "wine-git=$( printf '%s' "$pkgver" | sed 's/.*\+wine\.//')"
+ "wine-staging=$(printf '%s' "$pkgver" | sed 's/\+wine.*//')"
+)
conflicts=('wine' 'wine-wow64' 'wine-staging')
makedepends=(${makedepends[@]} ${depends[@]})
install=wine.install