summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrià Cereto-Massagué2018-03-13 15:51:06 +0100
committerAdrià Cereto-Massagué2018-03-13 15:51:06 +0100
commit1235848d3b9909eadd6e6382608d379ff6e3fdb1 (patch)
tree8efa5d24c1eda402c9e8b6ebd5f36f05d5b11379
parentd296016fa55c765cf5dec06b9132abd28ce980dc (diff)
downloadaur-1235848d3b9909eadd6e6382608d379ff6e3fdb1.tar.gz
Revert "change to stable staging"
This reverts commit d296016fa55c765cf5dec06b9132abd28ce980dc.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abfc83f58453..91c516ad8e83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wine-staging-vulkan-git
pkgdesc = A compatibility layer for running Windows programs (staging branch, git version) with Vulkan patches
- pkgver = 3.3+20180304.58661056ff
- pkgrel = 1
+ pkgver = 3.3.r0.ge09e1fd3+
+ pkgrel = 2
url = https://www.wine-staging.com/
install = wine-staging-vulkan-git.install
arch = i686
@@ -137,17 +137,17 @@ pkgbase = wine-staging-vulkan-git
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=3.3+20180304.58661056ff
- provides = wine-wow64=3.3+20180304.58661056ff
- provides = wine-git=3.3+20180304.58661056ff
- provides = wine-staging=3.3+20180304.58661056ff
+ provides = wine=3.3.r0.ge09e1fd3+
+ provides = wine-wow64=3.3.r0.ge09e1fd3+
+ provides = wine-git=3.3.r0.ge09e1fd3+
+ provides = wine-staging=3.3.r0.ge09e1fd3+
conflicts = wine
conflicts = wine-wow64
conflicts = wine-git
conflicts = wine-staging
options = staticlibs
source = wine-git::git+https://github.com/roderickc/wine-vulkan.git
- source = staging.tar.gz::https://github.com/wine-staging/wine-staging/archive/v3.3.tar.gz
+ source = wine-staging-vulkan-git::git+https://github.com/wine-staging/wine-staging.git
source = harmony-fix.diff
source = 30-win32-aliases.conf
source = wine-binfmt.conf
diff --git a/PKGBUILD b/PKGBUILD
index 3df862742ff8..14da1ff175c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
# Contributor: Daniel Bermond < yahoo-com: danielbermond >
pkgname=wine-staging-vulkan-git
-_staging_ver=3.3
-pkgver=3.3+20180304.58661056ff
-pkgrel=1
+pkgver=3.3.r0.ge09e1fd3+
+pkgrel=2
pkgdesc='A compatibility layer for running Windows programs (staging branch, git version) with Vulkan patches'
arch=('i686' 'x86_64')
url='https://www.wine-staging.com/'
@@ -83,7 +82,7 @@ optdepends=(
options=('staticlibs')
install="$pkgname".install
source=('wine-git'::'git+https://github.com/roderickc/wine-vulkan.git'
- "staging.tar.gz"::'https://github.com/wine-staging/wine-staging/archive/v3.3.tar.gz'
+ "$pkgname"::'git+https://github.com/wine-staging/wine-staging.git'
'harmony-fix.diff'
'30-win32-aliases.conf'
'wine-binfmt.conf')
@@ -117,9 +116,6 @@ else
fi
prepare() {
- tar xvf staging.tar.gz
- rm -rf $pkgname
- mv wine-staging-* $pkgname
cd 'wine-git'
# restore the wine tree to its git origin state, without wine-staging patches
@@ -141,8 +137,15 @@ prepare() {
}
pkgver() {
+ cd "$pkgname"
+ local _staging_tag="$(git tag --sort='version:refname' | tail -n1 | sed 's/-/./g;s/^v//;s/\.rc/rc/')"
+ local _staging_version="$(git describe --long --tags \
+ | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;s/\.rc/rc/' \
+ | sed "s/^latest.release/${_staging_tag}/")"
cd "${srcdir}/wine-git"
- echo $_staging_ver+$(git log -1 --format=%cd.%h --date=short|tr -d -)
+ local _wine_version="$(git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;s/\.rc/rc/')"
+
+ printf '%s+%s' "$_staging_version" "$_wine_version"
}
build() {