summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSego2023-02-08 17:31:39 +0400
committerSego2023-02-08 17:31:39 +0400
commit64efaadf6be3476a3480ad45e3ead113d9bca7ae (patch)
treeb9f1b1127d933fa21845dcb97eb634d78bdb9238
parent8a31476df687194a7f7a287bd92c5d1e62b36733 (diff)
downloadaur-64efaadf6be3476a3480ad45e3ead113d9bca7ae.tar.gz
Update wine version and make package work
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33eff19691e4..d2fa24c7e443 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-tkg-roblox
pkgdesc = wine-tkg-git with patches for Roblox
- pkgver = 7.20
+ pkgver = 8.1
pkgrel = 1
url = https://github.com/Frogging-Family/wine-tkg-git
arch = x86_64
@@ -108,9 +108,11 @@ pkgbase = wine-tkg-roblox
depends = lib32-faudio
depends = desktop-file-utils
depends = jxrlib
- source = roblox-wine-staging-v2.5.patch::https://raw.githubusercontent.com/SegoGithub/robloxWineBuildGuide/e8761a8615499660f5e257d6401ec372c2aa074b/roblox-wine-staging-v2.5.patch
+ source = roblox-wine-staging-v2.5.patch::https://raw.githubusercontent.com/NyanCatTW1/robloxWineBuildGuide/1ac0a104e3f6c691021662ec659e8185071f2383/roblox-wine-staging-v2.5.patch
+ source = use-wine-81.patch::https://github.com/SegoGithub/wine-tkg-git/commit/7296259b6dfa640da2f810eafd19ddaa2c5d92b0.patch
source = git+https://github.com/Frogging-Family/wine-tkg-git
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = wine-tkg-roblox
diff --git a/PKGBUILD b/PKGBUILD
index 70cfa9b75367..9f04ff68251c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Mohamed Ahmed (Sego) <sego at sego dot app>
pkgname=wine-tkg-roblox
pkgrel=1
-pkgver=7.20
+pkgver=8.1
url="https://github.com/Frogging-Family/wine-tkg-git"
-# this fork of the patch uses a wine version before the breaking changes were made to wine upstream
-# https://github.com/Frogging-Family/wine-tkg-git/issues/889
-source=("roblox-wine-staging-v2.5.patch::https://raw.githubusercontent.com/SegoGithub/robloxWineBuildGuide/e8761a8615499660f5e257d6401ec372c2aa074b/roblox-wine-staging-v2.5.patch"
+source=("roblox-wine-staging-v2.5.patch::https://raw.githubusercontent.com/NyanCatTW1/robloxWineBuildGuide/1ac0a104e3f6c691021662ec659e8185071f2383/roblox-wine-staging-v2.5.patch"
+ "use-wine-81.patch::https://github.com/SegoGithub/wine-tkg-git/commit/7296259b6dfa640da2f810eafd19ddaa2c5d92b0.patch"
"git+https://github.com/Frogging-Family/wine-tkg-git")
pkgdesc="wine-tkg-git with patches for Roblox"
arch=('x86_64')
sha256sums=('SKIP'
+ 'SKIP'
'SKIP')
license=('LGPL')
@@ -73,6 +73,7 @@ makedepends=('patch' 'git' 'autoconf' 'ncurses' 'bison' 'perl' 'fontforge' 'flex
build() {
cd "$srcdir/wine-tkg-git/wine-tkg-git"
git apply "$srcdir/roblox-wine-staging-v2.5.patch"
+ git apply "$srcdir/use-wine-81.patch"
makepkg -si --noconfirm
}