summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2018-11-11 01:14:48 -0500
committerSean Anderson2018-11-11 01:14:48 -0500
commit1e58ab0804011e94d09c622f3f5f6ee5200ba87c (patch)
tree398ac880bafebd2eb7ec1148248d82af464c6691
parent99872e4e6d3cebfe0daa675f09f8ee8251fe12e0 (diff)
downloadaur-1e58ab0804011e94d09c622f3f5f6ee5200ba87c.tar.gz
First working version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
-rw-r--r--wine-valve-git.install (renamed from wine-valve.install)0
3 files changed, 35 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19b1846e8abb..0dc89f48016b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-pkgbase = wine-valve
+pkgbase = wine-valve-git
pkgdesc = A compatibility layer for running Windows programs (Valve version)
- pkgver = 3.14
+ pkgver = 3.16.r203.g174d487bf8
pkgrel = 1
url = https://github.com/wine-mirror/wine
- install = wine-valve.install
+ install = wine-valve-git.install
arch = i686
arch = x86_64
license = LGPL
@@ -125,9 +125,10 @@ pkgbase = wine-valve
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=3.14
- provides = bin32-wine=3.14
- provides = wine-wow64=3.14
+ provides = wine=3.16.r203.g174d487bf8
+ provides = bin32-wine=3.16.r203.g174d487bf8
+ provides = wine-wow64=3.16.r203.g174d487bf8
+ provides = wine-valve=3.16.r203.g174d487bf8
conflicts = wine
conflicts = wine-staging
conflicts = wine-staging-git
@@ -135,16 +136,16 @@ pkgbase = wine-valve
conflicts = wine-wow64
replaces = bin32-wine
options = staticlibs
- source = https://github.com/wine-mirror/wine/archive/wine-3.14.tar.gz
+ source = wine-valve-git::git+https://github.com/ValveSoftware/wine.git
source = harmony-fix.diff
source = 30-win32-aliases.conf
source = wine-binfmt.conf
- sha256sums = 3cb739a07939e48cf949c70f0f351fde5814529688594de0ba839cecd73ee07e
+ sha256sums = SKIP
sha256sums = 50ccb5bd2067e5d2739c5f7abcef11ef096aa246f5ceea11d2c3b508fc7f77a1
sha256sums = 9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7
sha256sums = 6dfdefec305024ca11f35ad7536565f5551f09119dda2028f194aee8f77077a4
-pkgname = wine-valve
+pkgname = wine-valve-git
depends = fontconfig
depends = lib32-fontconfig
depends = lcms2
diff --git a/PKGBUILD b/PKGBUILD
index 19f975cba447..f6e479405b9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,8 @@
# Contributor: Sidney Crestani <sidneycrestani@archlinux.net>
# Contributor: sxe <sxxe@gmx.de>
-pkgname=wine-valve
-pkgver=3.14
-_oname=wine-wine-$pkgver
+pkgname=wine-valve-git
+pkgver=3.16.r203.g174d487bf8
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (Valve version)'
arch=('i686' 'x86_64')
@@ -79,11 +78,11 @@ optdepends=(
)
options=('staticlibs')
install="$pkgname.install"
-source=("https://github.com/wine-mirror/wine/archive/wine-$pkgver.tar.gz"
+source=("$pkgname::git+https://github.com/ValveSoftware/wine.git"
'harmony-fix.diff'
'30-win32-aliases.conf'
'wine-binfmt.conf')
-sha256sums=('3cb739a07939e48cf949c70f0f351fde5814529688594de0ba839cecd73ee07e'
+sha256sums=('SKIP'
'50ccb5bd2067e5d2739c5f7abcef11ef096aa246f5ceea11d2c3b508fc7f77a1'
'9901a5ee619f24662b241672a7358364617227937d5f6d3126f70528ee5111e7'
'6dfdefec305024ca11f35ad7536565f5551f09119dda2028f194aee8f77077a4')
@@ -94,17 +93,22 @@ then
_depends=(${_depends[@]/*32-*/})
makedepends=(${makedepends[@]/*32-*/} ${_depends[@]})
optdepends=(${optdepends[@]/*32-*/})
- provides=("wine=${pkgver}")
+ provides=("wine=${pkgver}" "wine-valve=${pkgver}")
conflicts=('wine' 'wine-staging' 'wine-staging-git')
else
makedepends=(${makedepends[@]} ${_depends[@]})
- provides=("wine=${pkgver}" "bin32-wine=${pkgver}" "wine-wow64=${pkgver}")
+ provides=("wine=${pkgver}" "bin32-wine=${pkgver}" "wine-wow64=${pkgver}" "wine-valve=${pkgver}")
conflicts=('wine' 'wine-staging' 'wine-staging-git' 'bin32-wine' 'wine-wow64')
replaces=('bin32-wine')
fi
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'wine-' prefix that presents in the git tag
+ git describe --long | sed 's/^wine-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
prepare() {
- cd "$_oname"
+ cd "$pkgname"
# fix path of opencl headers
sed 's|OpenCL/opencl.h|CL/opencl.h|g' -i configure*
@@ -115,8 +119,8 @@ prepare() {
build() {
# delete old build dirs (from previous builds) and make new ones
- rm -rf "$_oname"-{32,64}-build
- mkdir -p "$_oname"-32-build
+ rm -rf "$pkgname"-{32,64}-build
+ mkdir -p "$pkgname"-32-build
# workaround for FS#55128
# https://bugs.archlinux.org/task/55128
@@ -130,20 +134,21 @@ build() {
then
msg2 'Building Wine-64...'
- mkdir "$_oname"-64-build
- cd "$_oname"-64-build
+ mkdir "$pkgname"-64-build
+ cd "$pkgname"-64-build
- ../"$_oname"/configure \
+ ../"$pkgname"/configure \
--prefix='/usr' \
--libdir='/usr/lib' \
--with-x \
--with-gstreamer \
- --enable-win64
+ --enable-win64 \
+ --disable-tests
make
local _wine32opts=(
'--libdir=/usr/lib32'
- "--with-wine64=${srcdir}/${_oname}-64-build"
+ "--with-wine64=${srcdir}/${pkgname}-64-build"
)
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
@@ -152,12 +157,13 @@ build() {
# build wine 32-bit
msg2 'Building Wine-32...'
- cd "${srcdir}/${_oname}"-32-build
+ cd "${srcdir}/${pkgname}"-32-build
- ../"$_oname"/configure \
+ ../"$pkgname"/configure \
--prefix='/usr' \
--with-x \
--with-gstreamer \
+ --disable-tests \
${_wine32opts[@]}
make
}
@@ -169,7 +175,7 @@ package() {
# (according to the wine wiki, this reverse 32-bit/64-bit packaging order is important)
msg2 'Packaging Wine-32...'
- cd "$_oname"-32-build
+ cd "$pkgname"-32-build
if [ "$CARCH" = 'i686' ]
then
@@ -182,7 +188,7 @@ package() {
# package wine 64-bit
msg2 'Packaging Wine-64...'
- cd "${srcdir}/${_oname}"-64-build
+ cd "${srcdir}/${pkgname}"-64-build
make prefix="$pkgdir/usr" \
libdir="$pkgdir/usr/lib" \
diff --git a/wine-valve.install b/wine-valve-git.install
index 88a31c4353e6..88a31c4353e6 100644
--- a/wine-valve.install
+++ b/wine-valve-git.install