summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshH1002019-10-03 16:47:17 -0600
committerJoshH1002019-10-03 16:47:17 -0600
commitd75dbb8271a9415fe303fc3726f1497367fdf706 (patch)
tree894828c7f5d46ac4f8b93dbc975d5497aa01fb0a
parent4e2bd95e44e2241ef5be7742fbe0d78c2d2523ee (diff)
downloadaur-d75dbb8271a9415fe303fc3726f1497367fdf706.tar.gz
updated to use proton 4.11 branch & added vkd3d dependency
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76c7d79dbdd2..7ed395959c22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wine-valve-git
pkgdesc = A compatibility layer for running Windows programs (Valve version)
- pkgver = 4.2.r270.g06353f78c3
+ pkgver = 4.11.r415.g08a1b1024f
pkgrel = 1
url = https://github.com/ValveSoftware/wine.git
install = wine-valve-git.install
@@ -88,6 +88,7 @@ pkgbase = wine-valve-git
makedepends = lib32-libpcap
makedepends = desktop-file-utils
makedepends = libgphoto2
+ makedepends = vkd3d
optdepends = giflib
optdepends = lib32-giflib
optdepends = libpng
@@ -127,10 +128,10 @@ pkgbase = wine-valve-git
optdepends = cups
optdepends = samba
optdepends = dosbox
- provides = wine=4.2.r270.g06353f78c3
- provides = bin32-wine=4.2.r270.g06353f78c3
- provides = wine-wow64=4.2.r270.g06353f78c3
- provides = wine-valve=4.2.r270.g06353f78c3
+ provides = wine=4.11.r415.g08a1b1024f
+ provides = bin32-wine=4.11.r415.g08a1b1024f
+ provides = wine-wow64=4.11.r415.g08a1b1024f
+ provides = wine-valve=4.11.r415.g08a1b1024f
conflicts = wine
conflicts = wine-staging
conflicts = wine-staging-git
@@ -138,7 +139,7 @@ pkgbase = wine-valve-git
conflicts = wine-wow64
replaces = bin32-wine
options = staticlibs
- source = wine-valve-git::git+https://github.com/ValveSoftware/wine.git#branch=proton_4.2
+ source = wine-valve-git::git+https://github.com/ValveSoftware/wine.git#branch=proton_4.11
source = 30-win32-aliases.conf
source = wine-binfmt.conf
sha256sums = SKIP
@@ -176,4 +177,5 @@ pkgname = wine-valve-git
depends = lib32-libpcap
depends = desktop-file-utils
depends = libgphoto2
+ depends = vkd3d
diff --git a/PKGBUILD b/PKGBUILD
index 49a9859604ef..7a12ee3427a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Conttributor: xiretza <xiretza+aur@gmail.com>
pkgname=wine-valve-git
-pkgver=4.2.r270.g06353f78c3
+pkgver=4.11.r415.g08a1b1024f
pkgrel=1
pkgdesc='A compatibility layer for running Windows programs (Valve version)'
arch=('i686' 'x86_64')
@@ -29,6 +29,7 @@ _depends=(
'libpcap' 'lib32-libpcap'
'desktop-file-utils'
'libgphoto2'
+ 'vkd3d'
)
makedepends=('git' 'autoconf' 'ncurses' 'bison' 'perl' 'fontforge' 'flex'
'gcc>=4.5.0-2'
@@ -81,7 +82,7 @@ optdepends=(
)
options=('staticlibs')
install="$pkgname.install"
-source=("$pkgname::git+https://github.com/ValveSoftware/wine.git#branch=proton_4.2"
+source=("$pkgname::git+https://github.com/ValveSoftware/wine.git#branch=proton_4.11"
'30-win32-aliases.conf'
'wine-binfmt.conf')
@@ -100,14 +101,8 @@ else
replaces=('bin32-wine')
fi
-#pkgver() {
-# cd "$pkgname"
-# # cutting off 'wine-' prefix that presents in the git tag
-# echo 3.16.$(git log -1 --format="%cd" --date=short | sed 's|-||g')
-#}
pkgver() {
-# cd "$srcdir"
cd "$pkgname"
git describe --always | sed 's/^wine-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}