summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-01-17 18:08:36 -0800
committerxiota2024-01-17 18:08:36 -0800
commitd51bf1124e95481e1526204e8ebe51c9f55203b9 (patch)
treef7e909daff38cdc7b1af00025bf724e21c82f585
parentb7e3b05a3834d87cbdb160dcd7f1329dbe1b3534 (diff)
downloadaur-d51bf1124e95481e1526204e8ebe51c9f55203b9.tar.gz
9.0.r0: enable wayland support
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD33
2 files changed, 31 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f6a0e775f86..f5b291001eea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,23 @@
pkgbase = wine-wow64-git
pkgdesc = A compatibility layer for running Windows programs
- pkgver = 8.21.r438.g7a8c039a
+ pkgver = 9.0.r0.gfd115355
pkgrel = 1
url = https://gitlab.winehq.org/wine/wine
arch = x86_64
license = LGPL-2.1-or-later
+ makedepends = libcups
+ makedepends = libxxf86vm
+ makedepends = mesa
+ makedepends = mesa-libgl
+ makedepends = vulkan-icd-loader
makedepends = autoconf
makedepends = bison
makedepends = flex
makedepends = git
- makedepends = libgphoto2
makedepends = mingw-w64-gcc
makedepends = opencl-headers
makedepends = perl
- makedepends = samba
- makedepends = sane
makedepends = vulkan-headers
- makedepends = libcups
- makedepends = libxxf86vm
- makedepends = mesa
- makedepends = mesa-libgl
- makedepends = vulkan-icd-loader
- depends = desktop-file-utils
depends = alsa-lib
depends = fontconfig
depends = freetype2
@@ -37,14 +33,17 @@ pkgbase = wine-wow64-git
depends = pcsclite
depends = sdl2
depends = v4l-utils
+ depends = desktop-file-utils
+ depends = libgphoto2
+ depends = samba
+ depends = sane
+ depends = libxkbcommon
+ depends = wayland
+ optdepends = alsa-plugins
optdepends = cups
optdepends = dosbox
- optdepends = libgphoto2
- optdepends = samba
- optdepends = sane
- optdepends = alsa-plugins
- provides = wine-wow64=8.21
- provides = wine=8.21
+ provides = wine-wow64=9.0
+ provides = wine=9.0
conflicts = wine-wow64
conflicts = wine
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index e492b60908ce..c0d1fc571a00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
# basic info
_pkgname="wine"
pkgname="$_pkgname${_pkgtype:-}"
-pkgver=8.21.r438.g7a8c039a
+pkgver=9.0.r0.gfd115355
pkgrel=1
pkgdesc="A compatibility layer for running Windows programs"
url="https://gitlab.winehq.org/wine/wine"
@@ -26,8 +26,6 @@ arch=(x86_64)
# main package
_main_package() {
depends=(
- desktop-file-utils
-
alsa-lib #lib32-alsa-lib
fontconfig #lib32-fontconfig
freetype2 #lib32-freetype2
@@ -43,34 +41,34 @@ _main_package() {
pcsclite #lib32-pcsclite
sdl2 #lib32-sdl2
v4l-utils #lib32-v4l-utils
+ desktop-file-utils
+ libgphoto2
+ samba
+ sane
+
+ # with-wayland
+ libxkbcommon
+ wayland
)
makedepends=(
+ libcups #lib32-libcups
+ libxxf86vm #lib32-libxxf86vm
+ mesa #lib32-mesa
+ mesa-libgl #lib32-mesa-libgl
+ vulkan-icd-loader #lib32-vulkan-icd-loader
autoconf
bison
flex
git
- libgphoto2
mingw-w64-gcc
opencl-headers
perl
- samba
- sane
vulkan-headers
-
- libcups #lib32-libcups
- libxxf86vm #lib32-libxxf86vm
- mesa #lib32-mesa
- mesa-libgl #lib32-mesa-libgl
- vulkan-icd-loader #lib32-vulkan-icd-loader
)
optdepends=(
+ alsa-plugins #lib32-alsa-plugins
cups
dosbox
- libgphoto2
- samba
- sane
-
- alsa-plugins #lib32-alsa-plugins
)
options=(staticlibs !lto)
@@ -195,6 +193,7 @@ build() {
--prefix=/usr
--libdir=/usr/lib
--enable-archs=x86_64,i386
+ --with-wayland
)
cd "$_pkgsrc"