summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWheelchairArtist2023-10-01 13:12:58 +0200
committerWheelchairArtist2023-10-01 13:12:58 +0200
commit1b116df5b7fb307a24ea34790086b68bf23aaf25 (patch)
treea1e07d6799966b4ed601e785fe335dcfb89cc650
parentc64ccfc9339bbee64572b4b119ecc889e9e4c5e7 (diff)
downloadaur-1b116df5b7fb307a24ea34790086b68bf23aaf25.tar.gz
fix checksums and filenames
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7620f4badf6..5b103f2f8890 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wineasio
pkgdesc = ASIO driver implementation for Wine
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wineasio/wineasio
install = wineasio.install
arch = x86_64
@@ -13,6 +13,6 @@ pkgbase = wineasio
depends = realtime-privileges
depends = wine
source = https://github.com/wineasio/wineasio/releases/download/v1.2.0/wineasio-1.2.0.tar.gz
- sha256sums = aa26ec986878d3fee1b99d0b31d0085379a78fcace20defbaf9627f007e2f2cc
+ sha256sums = 13f20c7b3d45b474833e6c60cb58bcad7295e97dd39239bf00f85c02272cc0f4
pkgname = wineasio
diff --git a/PKGBUILD b/PKGBUILD
index d5e38f92789d..e8a570861a5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=wineasio
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="ASIO driver implementation for Wine"
url="https://github.com/wineasio/wineasio"
@@ -23,7 +23,7 @@ source=(
"https://github.com/wineasio/wineasio/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
)
sha256sums=(
- 'aa26ec986878d3fee1b99d0b31d0085379a78fcace20defbaf9627f007e2f2cc'
+ '13f20c7b3d45b474833e6c60cb58bcad7295e97dd39239bf00f85c02272cc0f4'
)
prepare(){
@@ -39,10 +39,10 @@ build() {
package() {
cd "$pkgname-$pkgver"
- install -D -m755 build32/"$pkgname".dll.so "$pkgdir"/usr/lib32/wine/i386-unix/"$pkgname".dll.so
- install -D -m644 build32/"$pkgname".dll "$pkgdir"/usr/lib32/wine/i386-windows/"$pkgname".dll
- install -D -m755 build64/"$pkgname".dll.so "$pkgdir"/usr/lib/wine/x86_64-unix/"$pkgname".dll.so
- install -D -m644 build64/"$pkgname".dll "$pkgdir"/usr/lib/wine/x86_64-windows/"$pkgname".dll
+ install -D -m755 build32/"$pkgname"32.dll.so "$pkgdir"/usr/lib32/wine/i386-unix/"$pkgname"32.dll.so
+ install -D -m644 build32/"$pkgname"32.dll "$pkgdir"/usr/lib32/wine/i386-windows/"$pkgname"32.dll
+ install -D -m755 build64/"$pkgname"64.dll.so "$pkgdir"/usr/lib/wine/x86_64-unix/"$pkgname"64.dll.so
+ install -D -m644 build64/"$pkgname"64.dll "$pkgdir"/usr/lib/wine/x86_64-windows/"$pkgname"64.dll
install -D -m755 gui/wineasio-settings "$pkgdir"/usr/bin/wineasio-settings
install -D -m644 gui/settings.py "$pkgdir"/usr/share/"$pkgname"/settings.py
install -D -m644 gui/ui_settings.py "$pkgdir"/usr/share/"$pkgname"/ui_settings.py